Announcement

Collapse
No announcement yet.

Normals of nesh break when loading as a skeletal mesh

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Normals of nesh break when loading as a skeletal mesh

    Hi! I have some problem with my female model. I should to split model by parts (arms, legs, head etc.) and export them apart without seams. I create custom normals for parts from full mesh. When I import it like a static mesh - there no seams, but skeletal mesh make them. If you know how I can get rid of seams - please help!

    #2
    That's got nothing to do with Normals. A normal is an imaginary line pointing out towards the direction of a face - always perpendicular to the surface.

    That said, the issue is expected. Skeletal mesh is used to deform things, as such levels of deformation through weight paint on different areas/pieces can and often have different pulls. A static mesh has none of that, and it will be therefore exactly as you see it within the editing program of choice at all times.

    There are several solutions to this.
    1 is to make sure the weight paint is 100% correct on both areas without decimal points. This will lessen the separation.
    2 is to place that seam elsewhere either lower or hither where the weight paint is already OK an it is only affected by one bone - the neck bone.
    3 is to ignore it completely and cover it with clothing.
    4 is to not seperate the meshes - which then means you have to change bone structures to change faces and it's a lot more complicated.

    Personally, unless there is a very specific need to have the seam down there (which usually is done because you cover it with clothing), I would place the seam just under the jawline/neck. it would be harder to detect in most normal views that way. still detectable though, unless the weight painting is on point.

    Comment


      #3
      In your import options under the mesh rollout, make sure you have Normal Import Method set to "Import Normals" (or "Import Normals and Tangents"). As far as I know by default it is set to recompute normals, which will obviously break any explicit vertex normals you've set.

      Comment

      Working...
      X