Announcement

Collapse
No announcement yet.

BoneBreaker - FREE Blender plugin for mannequin animation

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #61
    Hey, I Imported animation and I'm trying to export animation same animation with added anim curves but the only way for the anim curve to export correctly I have to export "Rig" and the only way to export "Rig" is clicking "Do it all" under "Rig Actions" and my animations get all messed up when I do it, all I want is export animation exactly as imported but with the anim curves added. Is it Possible to export animation with anim curves without doing any of the rig actions?

    Comment


      #62
      You can also just use the Export Curves plugin directly from the File Export dialogue. it should export the curves without having to be tied to the UI at all.
      Likewise, the new Edges and Faces export buttons open the Curves FBX export, so you could use one of those as well - usually you either want a face or a an edge smoothing group anyway.

      Comment


        #63
        Originally posted by MostHost LA View Post
        You can also just use the Export Curves plugin directly from the File Export dialogue. it should export the curves without having to be tied to the UI at all.
        Likewise, the new Edges and Faces export buttons open the Curves FBX export, so you could use one of those as well - usually you either want a face or a an edge smoothing group anyway.
        Awesome I'm going to try that idk why I didn't think of that in the first place. Thank you so much

        Comment


          #64


          I get this error. Rigify almost get set up, but for example the twit bones are not working, also the animation isn't applied. I'm using Blender 2,81

          *edit: I tried 2.8 and it works there (the twist bones don't, I'm not sure if it's intentional)Click image for larger version  Name:	pic.jpg Views:	0 Size:	294.4 KB ID:	1691965
          Last edited by mzprox; 11-27-2019, 07:07 PM.

          Comment


            #65
            The issue there is with the Rigify script. Not Bone breaker or anything I have control over.
            Perhaps, your file is an older rig that you opened within the new version?

            Rigify creates a rig ID which is obviously not being found (or so the error reads).

            I would suggest starting from scratch, import the mannequin and generate the rig, see if that works.

            I haven't tried the version you are on, everything works fine up to 2.80.75

            Comment


              #66
              Hello, I would need an advice for baking an animation.
              I usually make the rig animation, keep it unstashed, select all bones of the armature itself in pose mode and bake the animation but the problem is that I put a child constraint on left hand IK so it follows the right (a simple gun shot with left hand on the grip) but this constraint disappears when I click on "No" (between "Ue4" and "My") which seems to be necessary for the anim to work, or at least for bones to follow the anim. I don't know why it disappear, especially since the constraint is in the rig, and I tell the armature to follow "no"

              Since I don't find a solution for this I have tried the "key all frames" button, but it simply delete everything and gives me a message about UE4 key (attached picture). I looked on your website and it is simply said to make the animation and click the button. I don't know how to click the button, do I have to select the rig or the armature, edit mode/pose mode, select bones...?

              Also I remember there was sliders to set the influence of IKs, bone set visibility, I can't find them anymore I have looked everywhere, have they been removed?

              I'm not able to understand the error, I hope you will have a tip
              Thank you


              Click image for larger version

Name:	Image-4.jpg
Views:	44
Size:	78.2 KB
ID:	1720510
              Attached Files

              Comment


                #67
                "No" removes all constraints. And is necessary when switching the types of animations you want the final result to follow.

                The base process is to get the rig to follow Ue4 anims. Key all significant frames. Click NO to remove constraints, and click "my" to get the rig to folllow the manually keyd animation from before.

                Ue4 button is disabled if the FBX file you import doesn't contain an animation.

                Specifically re the error, it seems you moved things away from the collections they need to belong to.
                if nothing is within those the system can't possibly function.

                If you play/mess with constraints you need to be 100% sure what you are doing.
                connecting the left hand to the right hand is fine, but you should then manually key Loc Rot Scale for that bone and remove the constraint prior to moving forward with baking the animation down.

                Comment


                  #68
                  Thanks for the answer.
                  Indeed things must be in the right collection, I realized it because at the begining I renamed the collection to something else and nothing was working so I removed nothing from collections and let as it is. You see on the pic there is nothing because all is deleted when I press key all frames. To bake my anim, I have to go to the regular pose menu

                  So from what I understand when I create an anim that needs this constraint, I have to have a key at 0 time for the left Ik at the right location, then add the constraint, make anim, remove constraint and bake. And I have to re-add the constraint if I need to tweak the anim.

                  Comment


                    #69
                    If the animation is baked you probably won't need to re-add a constraint. The bones of the right hand will have been keyed, so you would have to go in and remove or adjust those keys.

                    Comment


                      #70
                      If I need to tweak the anim I won't modify the baked one, I tweak the rig anim and rebake the armature, and each time the constraint must be readded...

                      I still don't understand why "key all frames" deletes rigs and meshes

                      Comment


                        #71
                        If you are referring to a button of the plugin I can have a look, if you are referring to the blender built in function I can't do much about it. It could be the latest version has a bug too. Haven't experienced it myself.

                        Comment


                          #72
                          Yes the button of the plugin (I wouldn't have asked otherwise ).

                          Here before pressing the button (constraint re added, the armature follows the rig) :


                          Click image for larger version

Name:	before.jpg
Views:	46
Size:	336.8 KB
ID:	1721167


                          And this is when pressing the button :

                          Click image for larger version

Name:	after.jpg
Views:	22
Size:	246.8 KB
ID:	1721169

                          I can see the error is about UE4 key, I guess it is related to collection, but I didn't remove or rename this collection.

                          An other precision, I'm using the very last blender version, and the imported fbx was a skeletal mesh without animation
                          Attached Files

                          Comment


                            #73
                            It is wierd that you get stuff removed from the scene, but you are also missing the right thing from the right categories, so the error is probably due to that.

                            Since the script contains no delete commands, it is more likely that the rig has been hidden from view or something.

                            Start over with a new file.
                            open the mannequin or your character ue4 compatible file and click do it all.
                            maintain that file as the one to make modifications to animations. Don't change file structure.

                            Copy over your animations in pose mode.
                            they can be copied from file to file no problem. Just select all the rig parts you want to copy, ctrl c, go to the clean file and ctrl v in pose mode on the appropriate frame #.

                            Just so you know, the key all frames button takes all the frames from the UE4 imported animation and keys the rig so that constraints can be swapped and the animation can be edited / republished.
                            The scenario or path to follow would be - import an animation from ue4, do it all for the rig, do it all for the animations, ensure that UE4 is followed, key all frames, no follow, my anim.
                            That is essentially what that button was added in to do.


                            Comment


                              #74
                              I get it for the button , I tried in a new file and it works, it doesn't bake to the armature but no problem since I don't import animations and there is the regular bake method.
                              For the moment i'll keep re add the constraint when needed, which is quite often in fact but I can go on
                              Thanks a lot for your time !

                              Comment


                                #75
                                If you do it often enough, you can make your own custom button to add/remove the constraint.
                                open up my Plugin's .py files and copy the way it works off one of the constraint functions. Add a button to the UI or replace one you don't use

                                Comment

                                Working...
                                X