Announcement

Collapse
No announcement yet.

libpng security vulnerability

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    thanks for this, saved my day too

    Leave a comment:


  • replied
    Saved my day
    using 4.12.5 here
    Thanks a lot

    Leave a comment:


  • replied
    This message happens if you don't have the Online Subsystem GooglePlay plugin enabled (it moved to a plugin, but should be enabled by default). It would be best to move this to AnswerHub. Attaching your device logcat will help.

    Leave a comment:


  • replied
    Originally posted by Chris Babcock View Post
    [MENTION=32214]KAPA6UH[/MENTION]: 4.13.2 contains the update.
    [MENTION=27036]Nomte[/MENTION]: unfortunately the code needs to be recompiled with the new headers and library. The ZIP patch in post #3 above does work with 4.12.5, but you will need to get the engine source from GitHub, apply it, and compile.
    Yeah it is, but after moving to 4.13.2 I can't login to googleplay services anymore which I have implemented in 4.11 . While compiling I'm getting such a warning LogScriptCore:Warning: Script Msg: ShowLoginUI - Invalid or uninitialized OnlineSubsystem . What have I missed?
    Last edited by KAPA6UH; 11-09-2016, 01:43 PM.

    Leave a comment:


  • replied
    [MENTION=32214]KAPA6UH[/MENTION]: 4.13.2 contains the update.
    [MENTION=27036]Nomte[/MENTION]: unfortunately the code needs to be recompiled with the new headers and library. The ZIP patch in post #3 above does work with 4.12.5, but you will need to get the engine source from GitHub, apply it, and compile.

    Leave a comment:


  • replied
    So 4.13.2 launcher version is allready contains update?

    Leave a comment:


  • replied
    Hi!
    I am using 4.12.5 and I am very close to my release date. Update Unreal is not really a good option for me since I am using third party plugins and last update was a disaster.

    Is there any procedure to fix this problem for 4.12.5 launcher version?

    My project is completely done in blueprints. I am a 3d artist, not a programmer and I've never used UE4 source from github.

    Thank you very much!

    Leave a comment:


  • replied
    hi, i need help with my app. if someone can help me .I would be very grateful. i must finih project today. sms android app. is anyone intrested to help me

    Leave a comment:


  • replied
    4.13.2 includes the update; this would be the preferred way to update 4.13 if you aren't using GitHub.

    Leave a comment:


  • replied
    I tried the QFE patch that was posted, but my app is still being rejected for the same reason. Any help?

    Leave a comment:


  • replied
    Originally posted by Stephen Ellis View Post
    Hi everyone, we have provided the binary fix for this issue as a QFE ("quick-fix") which you can download and run from here: https://forums.unrealengine.com/show...-Fix-Solutions

    Cheers
    Big thanks for the QFE, it will help our project move forward.

    Leave a comment:


  • replied
    Originally posted by Chris Babcock View Post
    libpng is not used for any textures unless you are using ImageWrapper so it should not cause this. Please create an AnswerHub for this issue.
    I'll do that! Thank you!

    Leave a comment:


  • replied
    libpng is not used for any textures unless you are using ImageWrapper so it should not cause this. Please create an AnswerHub for this issue.

    Leave a comment:


  • replied
    Originally posted by Chris Babcock View Post
    4.13.1 was already completing testing when this came up.

    If you have source from GitHub, you can use this ZIP update to get the new libpng version with prebuilt Android libraries:

    Updated (x86 and x86_64 libraries corrected):
    https://epicgames.app.box.com/s/29cq...btgqfrk5f51t4a



    This should work with 4.12.x and 4.13.x as-is; let me know if there are any problems with older releases.

    Hi there! Here's my problem... I publish an android game with this new libPNG with API 19 and I've notice that some textures are not showing during game. Sometimes the texture is loaded, sometimes not. If I use the API 21 all the textures become visible. I've already try to increase the memory poolsize and a bunch of other things. Is there a minimum API to use this lib? It's a bug? I'm stuck here trying to solve this issue. If you have something to help me, I will be thankful.
    By the way, worked for me with 4.13 and 4.11 to.

    Leave a comment:


  • replied
    Hi everyone, we have provided the binary fix for this issue as a QFE ("quick-fix") which you can download and run from here: https://forums.unrealengine.com/show...-Fix-Solutions

    Cheers

    Leave a comment:

Working...
X