Announcement

Collapse
No announcement yet.

Android Marshmallow Permissions Not Requested

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Android Marshmallow Permissions Not Requested

    So I am working on a mobile game for android that requires saving permissions. I use the usual save and load blueprint nodes. Everything has been working up until the other day when I upgraded to android Marshmallow on the phone I use to test. When I install the game on my phone it no longer requests permissions and I manually have to allow saving permissions for that app. It does still work on older android versions, just not the new one.

    My minimum SDK version is 14 and my target SDK is 23. I do have android.permission.WRITE_EXTERNAL_STORAGE under my permissions.

    What could be wrong?

    #2
    Originally posted by walthamMichael View Post
    So I am working on a mobile game for android that requires saving permissions. I use the usual save and load blueprint nodes. Everything has been working up until the other day when I upgraded to android Marshmallow on the phone I use to test. When I install the game on my phone it no longer requests permissions and I manually have to allow saving permissions for that app. It does still work on older android versions, just not the new one.

    My minimum SDK version is 14 and my target SDK is 23. I do have android.permission.WRITE_EXTERNAL_STORAGE under my permissions.

    What could be wrong?
    You should set target SDK to 22 Currently it's a maximum target SDK for UE4.
    Realtime Database Firebase | Ultimate Mobile Kit Firebase | Extended Facebook | Universal Mobile Ads | Google Analytics

    Comment


      #3
      Ahh thanks alot, I will try that out soon But now, for future versions of Android, will I have to update my game in order for it to work 100%?

      Comment


        #4
        gameDNA studio is right; set it to 21 or 22. The min SDK setting is what determines the minimum Android version the APK will install on. The Target SDK is the assumption about support level for API behavior.

        Comment

        Working...
        X