Announcement

Collapse
No announcement yet.

Missing UE4Game binary

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Missing UE4Game binary

    I'm running 4.10.4 with no additional plugins on Windows 7 x64. I downloaded the "Unreal Match 3" demo project from the marketplace and tried to package it to Android (ETC1), but it fails with the following error:
    Error Missing UE4Game binary.You may have to build the UE4 project with your IDE. Alternatively, build using UnrealBuildTool with the commandline:UE4Game <Platform> <Configuration>

    I have followed all the steps for installing the Android SDK in the Android development guide.
    I have no additional plugins in UE4.

    In the output log I can see that the failure happens upon trying to stage the package:

    Code:
    MainFrameActions: Packaging (Android (ETC1)): UE4Editor-Cmd: Execution of commandlet took:  12.20 seconds
    MainFrameActions: Packaging (Android (ETC1)): CommandUtils.Run: Run: Took 15.790005s to run UE4Editor-Cmd.exe, ExitCode=0
    MainFrameActions: Packaging (Android (ETC1)): Project.Cook: ********** COOK COMMAND COMPLETED **********
    MainFrameActions: Packaging (Android (ETC1)): Project.CopyBuildToStagingDirectory: ********** STAGE COMMAND STARTED **********
    MainFrameActions: Packaging (Android (ETC1)): BuildCommand.Execute: ERROR: BUILD FAILED
    MainFrameActions: Packaging (Android (ETC1)): Program.Main: ERROR: AutomationTool terminated with exception:
    MainFrameActions: Packaging (Android (ETC1)): Program.Main: ERROR: Exception in AutomationScripts.Automation: Stage Failed. Missing receipt 'UnrealMatch3-Android-Shipping.target.xml'. Check that this target has been built.
    MainFrameActions: Packaging (Android (ETC1)): Stacktrace:    at Project.CreateDeploymentContext(ProjectParams Params, Boolean InDedicatedServer, Boolean DoCleanStage)
    MainFrameActions: Packaging (Android (ETC1)):    at Project.CopyBuildToStagingDirectory(ProjectParams Params)
    MainFrameActions: Packaging (Android (ETC1)):    at BuildCookRun.DoBuildCookRun(ProjectParams Params)
    MainFrameActions: Packaging (Android (ETC1)):    at BuildCommand.Execute()
    MainFrameActions: Packaging (Android (ETC1)):    at AutomationTool.Automation.Execute(List`1 CommandsToExecute, CaselessDictionary`1 Commands)
    MainFrameActions: Packaging (Android (ETC1)):    at AutomationTool.Automation.Process(String[] CommandLine)
    MainFrameActions: Packaging (Android (ETC1)):    at AutomationTool.Program.MainProc(Object Param)
    MainFrameActions: Packaging (Android (ETC1)):    at AutomationTool.InternalUtils.RunSingleInstance(Action`1 Main, Object Param)
    MainFrameActions: Packaging (Android (ETC1)):    at AutomationTool.Program.Main()
    MainFrameActions: Packaging (Android (ETC1)): ProcessManager.KillAll: Trying to kill 0 spawned processes.
    MainFrameActions: Packaging (Android (ETC1)): Program.Main: AutomationTool exiting with ExitCode=Error_MissingExecutable
    MainFrameActions: Packaging (Android (ETC1)): Domain_ProcessExit
    MainFrameActions: Packaging (Android (ETC1)): copying UAT log files...
    MainFrameActions: Packaging (Android (ETC1)): RunUAT.bat ERROR: AutomationTool was unable to run successfully.
    MainFrameActions: Packaging (Android (ETC1)): BUILD FAILED
    PackagingResults:Error: Error Missing UE4Game binary.You may have to build the UE4 project with your IDE. Alternatively, build using UnrealBuildTool with the commandline:UE4Game <Platform> <Configuration>
    I've tried changing the project settings to package for Development, Shipping, Full Rebuild, but they all end with the same error.

    Can anyone shed light on why this is happening?

    #2
    I'm having the same problem for days.. Couldn't solve it yet.. I assume that you tried to add code to the project?

    https://answers.unrealengine.com/que...for-win64.html

    Comment


      #3
      same problem by me found the fastest and simplest solution. in your epic games launcher right click on the preferd engine -> options -> uncheck android-> confirm. This will delete it. Then the same again and check android for installing it again. like a charm! no worries anymore!

      Comment


        #4
        I facing this problem too.
        I`am copy project folder to my some "archive versions" folder just to be sure if I make some bad changes I always can return to my previos version of my game.
        So solving is a replace binary folder (ProjectFolder/Binaries) from the version of project that I`ve copied earlier.

        Seems like some binary file was crashed because of some of one plug that I`am trying on

        Comment

        Working...
        X