Announcement

Collapse
No announcement yet.

Android Compile Errors

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Android Compile Errors

    Hello, since some time ago i noticed when I compile in visual studio or try to package game on engine i get these errors:

    Visual studio:

    Click image for larger version

Name:	Capture.PNG
Views:	1
Size:	160.7 KB
ID:	1171214

    Ue4 When i try to Package Game [Android All] (not compiling, compile works I can launch game on phone):

    Click image for larger version

Name:	2.PNG
Views:	1
Size:	252.0 KB
ID:	1171215
    Click image for larger version

Name:	3.PNG
Views:	1
Size:	259.3 KB
ID:	1171216

    Hopefully someone could help me, I've tried many things, none worked!

    #2
    Hi Sampuig12,

    Go into your project's Config folder and make an Android folder. Create an AndroidEngine.ini here and put the following in it:

    Code:
    [Advertising]
    DefaultProviderName=AndroidAdvertising
    
    [OnlineSubsystem]
    DefaultPlatformService=GooglePlay
    
    [OnlineSubsystemGooglePlay.Store]
    bSupportsInAppPurchasing=True
    And remove these from the DefaultEngine.ini. This way only Android target will include them.

    Comment


      #3
      Hey there, thank you very much for the answer, my post did not have much succes although compiling for release is a major problem, so thanks for taking the time to help.

      I have done what you said above, and sadly this did not affect compilation.

      The errors that I am currently getting in visual studio :

      Click image for larger version

Name:	1.PNG
Views:	1
Size:	30.6 KB
ID:	1099705

      In editor :
      (Alot of java errors for some reason.
      Click image for larger version

Name:	5.PNG
Views:	1
Size:	89.0 KB
ID:	1099706
      Click image for larger version

Name:	4.PNG
Views:	1
Size:	90.1 KB
ID:	1099707

      Comment


        #4
        Hi Sampuig12,

        Full text logs are more useful than screenshots; I can only see part of the problem. Try Debug or Development, not DebugGame.

        Comment


          #5
          Sure i'll provide you a link ASAP

          Visual studio log:
          http://pastebin.com/P0D5JXqB

          Ue4 Logs:

          http://pastebin.com/kmXjJ7Xb

          Comment


            #6
            Hi Sampuig12,

            Okay, a couple of things I see. Use Development instead of DevelopmentGame for Android. It also looks like you have an odd package name. Usually you would use "com.mycompany.productname", I don't think it likes you naming it ending with .package. Change the name and clear out your project's Intermediate and Build/Android/src directories before trying to package again; this will make sure you don't have duplicates of the generated downloader files with the wrong package name left over.

            Also, it looks like the Victory plugin may be out of date? The line numbers don't match the GitHub version and it likely needs recompiling.

            Comment


              #7
              Alrioght i'll try all of that, be back in 5, thanks alot for the answer.

              And the pluggin should be up to date, I am using :

              http://www.mediafire.com/download/g6...toryPlugin.zip

              for 4.10

              Comment


                #8
                Ok, bad news, sadly, nothing has changed, i don't get it, i've tried alot of things, there must be a way to fix this surely?

                Comment


                  #9
                  Just in case you would need this:

                  Click image for larger version

Name:	environement.PNG
Views:	1
Size:	58.1 KB
ID:	1099753

                  Click image for larger version

Name:	1.PNG
Views:	1
Size:	26.3 KB
ID:	1099754

                  Click image for larger version

Name:	2.PNG
Views:	1
Size:	29.1 KB
ID:	1099755

                  Click image for larger version

Name:	3.PNG
Views:	1
Size:	46.0 KB
ID:	1099756

                  Click image for larger version

Name:	4.PNG
Views:	1
Size:	13.1 KB
ID:	1099757

                  Comment


                    #10
                    oh well i found out something while posting these pics, the environement vars in path, ant.bat path is wrong version, just changing that to see if it works

                    Edit: Did not work.

                    Comment


                      #11
                      Bumping this.

                      Comment


                        #12
                        Hey there, I Reinstalled UE4 + Visual Studio(fixed a bug to generate VS files on right click)

                        I am still getting 1 error, a new one, i can't figure out how to fix it.

                        In UE4 when i want to launch on android:

                        http://pastebin.com/DV2L7zK9


                        And in Visual Studio (2015):

                        http://pastebin.com/NpwzJRfY

                        Thank you.

                        Comment


                          #13
                          Well I fixed it.

                          Repaired visual studio application.
                          Repaired epic games application.
                          Updated rama's plugin.
                          Deleted Intermidiate Folder.
                          Generated Visual Studio Files.

                          This thread AND this one : https://forums.unrealengine.com/show...-Studio-Errors can be closed.

                          Thank you.
                          Last edited by Sampuig12; 02-10-2016, 10:34 AM.

                          Comment

                          Working...
                          X