Announcement

Collapse
No announcement yet.

Android multiplayer wlan: Android as host device problem

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Thanks TheJamsh

    Thank aussieburger
    But to be honest i couldn't figure out how did you fix your problem from that Github page did you copy past the files to your project ? iam not a programmed and if you have tips what change you made in your game in detail i will be very thankful as i'm noob here and my knowledge only restricted in blueprint .
    Last edited by mhnoni; 12-27-2015, 01:16 PM. Reason: change

    Leave a comment:


  • replied
    FYI: I managed to get it working using the pull request from psychogony as mentioned here: https://answers.unrealengine.com/que...t-working.html

    It can be found here: https://github.com/EpicGames/UnrealEngine/pull/1820
    he shouldn't mind me posting it here, but be aware it was tricky (for me at least) to cherry pick this one - but once I got it all compiled the join session blueprint node works flawlessly for me on both normal android app and two gearvr devices

    So yeah it's definitely a bug in the engine with android and multiplayer that is not working by default unless you enter the IP directly but at least I have a workaround for now - it's just annoying there are so many gearvr workarounds needed to be manually compiled every time a new UE4 version comes out...

    Leave a comment:


  • replied
    The last few entries in the log explain some of what's going on.

    Code:
    11-30 19:59:31.126: D/UE4(24913): [2015.11.30-18.59.31:132][64000]LogScript:Warning: Accessed None 'CallFunc_K2_GetPawn_ReturnValue'
    11-30 19:59:31.151: D/UE4(24913): [2015.11.30-18.59.31:158][64000]LogOnline:Warning: NULL: Can't start an online session (Game) in state InProgress
    11-30 19:59:31.161: D/UE4(24913): [2015.11.30-18.59.31:167][64000]LogScript:Warning: Accessed None 'Widget'
    11-30 19:59:31.161: D/UE4(24913): 	MyGameInstance_C /Engine/Transient.GameEngine_0:MyGameInstance_C_0
    11-30 19:59:31.161: D/UE4(24913): 	Function /Game/Blueprints/MyGameInstance.MyGameInstance_C:Hide Widget:000A
    First line indicates that it can't find the pawn for something. I suggest testing Multiplayer in PIE and making sure that 'Break Blueprints On Exceptions' is turned on in editor/project settings so you can fix it.

    Second line indicates that you're trying to start a Game Session while the GameModes Match State is 'InProgress' - which it says you can't do. It seems as though Gameplay has already started before you start the Online Session, or you already have an online session in progress.

    Third/Fourth/Fifth line indicates that the game can't find a 'Widget' to remove in the Game Instance.

    I would suggest fixing these errors and trying again after that. I've found that Android doesn't seem to handle errors as gracefully as Windows does, especially when it comes to Multiplayer. The slightest misdemeanor seems to cause problems. We never tried an Android host for PC client, but all other configurations worked for us without a hitch when we did Cross-Platform multiplayer - so it definitely works. Always check both the Client and the Server logs too.

    Leave a comment:


  • replied
    @ unreal team , any help or tips guys ?

    Leave a comment:


  • replied
    Ok I managed to get it working! By connecting via console commands with "open ipaddressOfMyAndroidDevice" instead of the blueprint node "Join Session"

    So this appears to be a bug with the "Blueprint Session Result" variable not giving/getting the correct IP of the android host?

    Is there anyway to get the server IP address in the client? Currently it seems like it only supports Server Name

    Leave a comment:

Working...
X