Announcement

Collapse
No announcement yet.

Android multiplayer wlan: Android as host device problem

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Wow! I can't believe this I was actually able to get this to work. It sounds like a giant blind alley at first (took me probably around 3 hours), but it worked! This has to be the best instructions/boldest workaround I have ever seen. hahaha Thank you so much for the clear steps and wisdom. I was lost without this. You guys rock!

    I wish I had more to contribute. let's see. umm, I did this on 4.11. Oh there was one other hiccup. in the README.md (be sure to read it!) that comes with the https://github.com/EpicGames/UnrealEngine/tree/4.10 download it says, "Be sure to include C++ support as part of the install, which is disabled by default." Here is a link on how to do that. https://www.youtube.com/watch?v=U1MRUiJAOq0


    Thanks again, guys I can't tell you how relieved I am.

    Leave a comment:


  • replied
    There are many tutorials how to do it for pc on youtube. For android it's exactly the same. So follow one of them on YouTube. Then just hook your create, find and join events to umg buttons or even android buttons for testing.

    Also edit the defaultengine.in file like the op wrote.

    Good luck!

    Leave a comment:


  • replied
    +1 [MENTION=13206]Pabooklas[/MENTION] !

    Now I just need a good tutorial series about MP on PC/Android using BP only and I am good to go

    Leave a comment:


  • replied
    I just tested with two phones and also android server with pc trying to join. Everything works.

    Leave a comment:


  • replied
    4.12 is out now. Has anyone tested this yet?

    Leave a comment:


  • replied
    Originally posted by KillerSneak View Post
    So I have been away for quite some time but does it work now? Is it possible to make multiplayer work with Android?
    it will be with 4.12

    Leave a comment:


  • replied
    So I have been away for quite some time but does it work now? Is it possible to make multiplayer work with Android?

    Leave a comment:


  • replied
    Thanks for a reply. Time to download Visual Studio I guess.

    Leave a comment:


  • replied
    Originally posted by Pabooklas View Post
    Does anyone know if this is still needed in 4.11?
    Yes i think as android still not supported .

    Leave a comment:


  • replied
    Originally posted by aussieburger View Post
    Here's a brief step-by-step for how I got it working. PS: I'm not a C++ programmer either and while the end result of these steps is it all works via blueprints, you do need to mess around with visual studio unfortunately:
    1. link your unreal and github account as per: https://www.unrealengine.com/ue4-on-github
    2. download the zip source code of the engine: https://github.com/EpicGames/UnrealEngine/tree/4.10
    3. have Visual Studio express installed
    4. exact zip and run setup (will take ages)
    5. run GenerateProjectFiles.bat as admin
    6. open UE4.sln which will open UE4 source in Visual Studio
    7. Build windows 64 | Development Editor (will take ages)
    8. replace the two whole files from the pull request: https://github.com/EpicGames/UnrealE...ull/1820/files
    9. Build Android | Development (will take ages)
    10. Build Android | Shipping (will take ages)
    11. Now you can open your freshly built engine with the fix in place. Located: \Engine\Binaries\Win64\UE4Editor.exe (it will take absolutely ages the first time you open and do anything)


    For all that building stuff you can find documentation from Epic games on how to do it on this link: https://github.com/EpicGames/UnrealEngine/tree/4.10

    I actually used branch 4.9 however all branches should work in theory

    Annoying we need to do this - hope Epic can give feedback on putting the fix in for all!
    Does anyone know if this is still needed in 4.11?

    Leave a comment:


  • replied
    OK to close this thread thanks to aussieburger and psychogony fix . android now can act as server and the other phone can find the session when 2 phone connected to a local wifi router but just to be informed that the join fail when you make portable hotspot one of the phone or direct wifi to make a wifi network between the 2 phone so hope Epic can fix this issue .

    Leave a comment:


  • replied
    Hi

    i just downloaded both the file required to be replaced but anyone can tell me pls why do i need to download the source code of the engine to do that ? as i already found and i can replace the 2 files in the engine itself that i download it from the epic launcher.

    I'm in 4.8 Btw does this issue still in 4.10 ?

    Leave a comment:


  • replied
    @ aussieburger thanks a lot man really appreciated , i will try to do your steps and hopefully unreal team can fix the issue .thanks to you i will get back to my lan android game project i was working on it that i left it due to this issue .

    Leave a comment:


  • replied
    Here's a brief step-by-step for how I got it working. PS: I'm not a C++ programmer either and while the end result of these steps is it all works via blueprints, you do need to mess around with visual studio unfortunately:
    1. link your unreal and github account as per: https://www.unrealengine.com/ue4-on-github
    2. download the zip source code of the engine: https://github.com/EpicGames/UnrealEngine/tree/4.10
    3. have Visual Studio express installed
    4. exact zip and run setup (will take ages)
    5. run GenerateProjectFiles.bat as admin
    6. open UE4.sln which will open UE4 source in Visual Studio
    7. Build windows 64 | Development Editor (will take ages)
    8. replace the two whole files from the pull request: https://github.com/EpicGames/UnrealE...ull/1820/files
    9. Build Android | Development (will take ages)
    10. Build Android | Shipping (will take ages)
    11. Now you can open your freshly built engine with the fix in place. Located: \Engine\Binaries\Win64\UE4Editor.exe (it will take absolutely ages the first time you open and do anything)


    For all that building stuff you can find documentation from Epic games on how to do it on this link: https://github.com/EpicGames/UnrealEngine/tree/4.10

    I actually used branch 4.9 however all branches should work in theory

    Annoying we need to do this - hope Epic can give feedback on putting the fix in for all!
    Last edited by aussieburger; 01-08-2016, 03:51 AM.

    Leave a comment:


  • replied
    Thanks TheJamsh

    Thank aussieburger
    But to be honest i couldn't figure out how did you fix your problem from that Github page did you copy past the files to your project ? iam not a programmed and if you have tips what change you made in your game in detail i will be very thankful as i'm noob here and my knowledge only restricted in blueprint .
    Last edited by mhnoni; 12-27-2015, 01:16 PM. Reason: change

    Leave a comment:

Working...
X