Announcement

Collapse
No announcement yet.

Android SDK and API 23

Collapse
This is a sticky topic.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • started a topic Android SDK and API 23

    Android SDK and API 23

    The latest Android SDK API 23 made some changes impacting packaging or launch on for Unreal projects. The AndroidWorks installer included in Engine/Extras/Android should only install up to API 22 by default but if you are using 1R2 from the NVIDIA website it may be pulling down 23 as well.

    API 23 removed org.org.apache.http from the standard package and moved it to optional. Unfortunately, it also removed some depreciated API calls which Google's APK expansion downloader depends on (we use it for OBB download). The best thing to do for now is use no later than SDK API 22.

    The Android SDK section of Project Settings allows setting the SDK API Level and NDK API Level. By default, SDK API Level is "latest" and NDK API Level is "android-19". The NDK API Level should be set to "android-19" if you wish to target devices before Lollipop (5.0). If you set this to "android-21" or higher, your APK will only work on 5.0 devices.

    SDK API Level set to "latest" will use the highest number found installed. If you have API-23 installed, you should change the SDK API Level from "latest" to "matchndk" or "android-21" (check your SDK's platforms directory for which versions are available). It is OK for SDK to be set higher than NDK.
    Last edited by Chris Babcock; 09-08-2015, 02:44 PM.

  • replied
    had same problems. thanx

    Leave a comment:


  • replied
    Hey Cheris,
    I am facing the same problem in android development and after reading your post its clear to me.
    Thanks a lot
    Last edited by rakhimishra239; 02-19-2019, 01:58 AM.

    Leave a comment:


  • replied
    right we will stick to SDK 22 then

    Leave a comment:


  • replied
    I'm having the same problem here but Haven't found an answer:https://forums.unrealengine.com/deve...-on-any-device

    Leave a comment:


  • replied
    Is this easily fixable by gradle? You can conditionally add the implementation of the abb downloader with the same classpath on newer sdk versions while (optionally) excluding any other modules of the library that are not needed

    Leave a comment:


  • replied
    Thanks for sharing your wonderful reviews as I was having the same issues and got it solved. Really appreciate it. As I got it solved with my Android Developer friend but it was a but still left so had it solved over.

    Leave a comment:


  • replied
    am trying to download codeworks Android 1R6u1 but it cant download and install, am using unreal engine 4.19 and visual studio 2017, anyone who has resolved this issue before kindly help

    Leave a comment:


  • replied
    Help please! after open "CodeWorksforAndroid-1R6u1-windows.exe" press next as usaul. it shows "Downloading update lock" and then it shows "error". I even can't select the version i want to download! Any help please. Great thanks

    Leave a comment:


  • replied
    Android 23 and up is not a problem any more. Android 23 is now the minimum required and is installed with CodeWorks for Android 1r6u1 installer in Engine/Extras. It is best to set NDK API Level to "android-19" and SDK API Level to "latest" now.

    Leave a comment:


  • replied
    The original post is from 2015, perhaps a new update?

    Leave a comment:


  • replied
    In fact I tried to reinstall all of it, but didn't help

    Leave a comment:


  • replied
    i have unreal engine 4.16.3 installed via github sources. i already installed latest android works given in extras/android. matchndk,latest. target is set to android-19.but am not able to install apk in android version lower than lollipop.what should i do to make apks for kitkat and lollipop.

    Leave a comment:


  • replied
    4.16 requires android-23. Run android.bat and select Android-23 and install it.

    Leave a comment:


  • replied
    I've done as you said but now I am getting this error: Requires at least SDK API level 23, currently set to 'android-22'
    Program.Main: ERROR: AutomationTool terminated with exception: ERROR: Can't make an APK without API 'android-23' minimum installed (see "android.bat list targets")

    Leave a comment:

Working...
X