Announcement

Collapse
No announcement yet.

Graphics on mobile extremely low compared to scene view

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Graphics on mobile extremely low compared to scene view

    Hello,
    I am having trouble with the graphics quality of my game when I test it on my android device. As you can see by this image ( http://i.imgur.com/EPRZXEf.jpg ) the lighting / texture quality when running the game on the PC looks great, however once I build the project and test it on mobile, lighting becomes very dull and blocky, and the texture quality is greatly reduced.

    I have read over some of the guidelines for mobile games, so am aware that I have to use static lights for my point light, but surely it should look better than this?
    How would I go about improving the graphics on my mobile device so it looks more like it does on the scene view? I do not understand why my game looks so bad, yet games like "Epic Citadel" can look so good.

    I really appreciate any help.

  • replied
    Ok, so first off if your a hardcore gamer you 'prolly know what MSAA is.
    To put it simple, it can increase the visual quality in most apps that use Open GL 2.0.
    Now you want to enable it, don't you?
    1. Go to Settings>About tablet and tap Build number 7 times 'till it says you are a developer.
    2. Then tap Developer options (you may have to restart Settings app to see it)
    3. Fill in the check next to Force 4x MSAA
    4. Restart your favorite high - end game.
    5. Play the game.
    6. Have Fun! (Remember it dosnt work on all games but I know it works on Asphalt 7: Heat for sure

    Leave a comment:


  • replied
    Originally posted by svv3dUDN View Post
    Hi!

    Mobile have many limitation.

    All recommendations about optimisation for mobile you can read in this docs:
    https://docs.unrealengine.com/latest...tforms/Mobile/

    And you have a problem with modular lighting (irregularly shading wall).
    I hope you find solution in this docs:

    https://forums.unrealengine.com/show...ghting-Problem
    https://wiki.unrealengine.com/Lighti...eshootingGuide
    Hi svv3dUDN

    I have the kinda same question I just didn't want to create any more unnecessary topic.

    Opposite to the this topic, I am trying to do the reverse; deploying my project to android with lowest possible graphic settings. But even I set the "Engine Scalability Settings" and "Material Quality Level" to lowest, it seems that my project deploying with high graphics settings, i think it's ignoring no matter what i chose.

    Project is too big, there are many actors assets lights etc but there must be a way to reduce this graphics to a playable level right ? Some related topics I've read says that manually setting gameusersettings.ini in some folder helps ( I honestly didn't understand at all). But it can be done via UE4 toolbar right ? within UE4 editor ?


    I just want to reduce the graphics to lowest that make the game playable but so far i couldn't do it. I will be grateful for any help.

    And it doesn't matter if I package my project with Android ETC1 or Android ATC, they all the same.
    Last edited by finwefeanor; 07-01-2016, 10:32 AM.

    Leave a comment:


  • replied
    Hi TubooBokBok,

    I did a test on a moto X 1st gen. Is this the quality you are getting or trying to achieve?

    Chipset Qualcomm MSM8960DT Snapdragon S4 Pro
    CPU Dual-core 1.7 GHz Krait 300
    GPU Adreno 320
    Memory 2 GB RAM

    still working on the lighting (not using static lighting!) and added a bunch of things in game since the video was taken and my frame rate is still the same.

    Put the quality to 760P in order to get a better idea!

    Last edited by maparizeau; 06-27-2015, 12:58 AM.

    Leave a comment:


  • replied
    Hi!

    Mobile have many limitation.

    All recommendations about optimisation for mobile you can read in this docs:
    https://docs.unrealengine.com/latest...tforms/Mobile/

    And you have a problem with modular lighting (irregularly shading wall).
    I hope you find solution in this docs:

    https://forums.unrealengine.com/show...ghting-Problem
    https://wiki.unrealengine.com/Lighti...eshootingGuide

    Leave a comment:

Working...
X