Announcement

Collapse
No announcement yet.

Android showing only blank sky when launching to device

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Android showing only blank sky when launching to device

    It looks like it is trying to launch the old default level.

    I deleted the default level and set my current level as the default for both game and editor and it appears to work fine when I am running on the PC.

    When I run it from the launcher to my Android device, the logs say it can't find my meshes, which was the same error I used to receive on the PC when launching from the wrong level.

    When I look in the UAT folder, the command line for my Adroid device looks correct.

    I have tried deleting all of my intermediate files, binaries, APK etc and restarted UE4. I am using version 4.8.

    Any help appreciated!

    #2
    Try adding this to your DefaultEditor.ini. If you don't have the file, which is just pure text, add it to your project config folder.

    [AlwaysCookMaps]
    +Map=/Game/Maps/YourMap
    Maps in this example is a folder in the content browser.
    Programmer, Rigger, Animator - Demo Reel 2015 - My RnD / WIP thread - www.dennylindberg.com
    Worked on: Kitten'd - Guardians of Valor (Android, iOS)

    Comment


      #3
      Well, that worked in that I get a new error I imported some assets from another project and then moved them into my normal content area and re-wired up all of the materials and it looks like when it is trying to create the android magic it is still looking in the wrong place. I'll look around and open a new post if I can't find where that is being referenced.

      Thank you much for moving me forward!

      Comment


        #4
        Anyhow, in case anyone is curious, it looks like I caused my own issues. I migrated most of my assets, but a couple I just moved the uasset guy across and it seems you can't actually do that

        Right now everything works except it can't find my my map (it says missing file mymap.uasset) on mobile, but because I buggered everything, I think I will just start over with a new project and try to do things a bit cleaner this time

        Comment

        Working...
        X