Announcement

Collapse
No announcement yet.

My game works on windows but not on android

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    My game works on windows but not on android

    I posted my issue at the answer hub about a week ago but haven't gotten an answer.

    Basically my issue is the game play's flawlessly on windows 7 but if I try to load it onto my android Onetouch C7 (which can play tappy chicken) it comes up with a black screen. I tried the blueprint first person shooter and I get the same issue.

    I'm using Product Version: UE 4.7

    Any Ideas?

    #2
    Okay I just got the first person shooter to run on my phone without the starter content!

    Thank God, I'm really happy. Now I need my game to run, I'm going to try it out and see if I get an error I'll brb.

    Comment


      #3
      Solved! my game is on android now! I need to optimize lots of things because it's running really slow but I can finally test that.

      I think it's a good idea to reset your computer while working on new things because that seemed to do the trick.

      I have to delete the Saved directory in your project directory and Intermediate to stop getting the error

      Comment


        #4
        Originally posted by Jorge Morillo View Post
        Solved! my game is on android now! I need to optimize lots of things because it's running really slow but I can finally test that.

        I think it's a good idea to reset your computer while working on new things because that seemed to do the trick.

        I have to delete the Saved directory in your project directory and Intermediate to stop getting the error
        This is the solution to get pass the "blank screen on android" problem ?
        I have the same issue. I only wish to test an empty map on android before testing my full project.

        Comment


          #5
          Originally posted by VladV View Post
          This is the solution to get pass the "blank screen on android" problem ?
          I have the same issue. I only wish to test an empty map on android before testing my full project.
          Hello VladV!

          At some point the problem was my phone. Check out if your phone is compatible https://docs.unrealengine.com/latest...ity/index.html

          Secondly if your phone is not up to speed try using unlit materials and turning off LDR in the render settings.

          Thirdly delete the Saved directory and Intermediate in your project directory

          I hope this helps.

          JM

          Comment


            #6
            Originally posted by Jorge Morillo View Post
            Hello VladV!

            At some point the problem was my phone. Check out if your phone is compatible https://docs.unrealengine.com/latest...ity/index.html

            Secondly if your phone is not up to speed try using unlit materials and turning off LDR in the render settings.

            Thirdly delete the Saved directory and Intermediate in your project directory

            I hope this helps.

            JM
            Hi

            turning off LDR Or HDR ?!!
            HDR is just here.
            Click image for larger version

Name:	12.jpg
Views:	1
Size:	28.9 KB
ID:	1081811

            Comment


              #7
              Thanks for your reply. It didn't worked to uncheck HDR ...

              Comment

              Working...
              X