Announcement

Collapse
No announcement yet.

APK dont work on Phone

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    APK dont work on Phone

    Hello!

    I create a apk with U4 (4.1.x) and upload this apk on my phone. But when i start this app, i become a black screen for a second and the app closed without any errors.

    When i try to upload this app on "Play Store Publisher" then i become the message the app use the "debug mode" but i select "Shipping"....

    What can i do?

    #2
    What phone do you have?

    Comment


      #3
      HTC One ... I think it's the Snapdragon CPU

      Comment


        #4
        Well, it should work. Did you try using the older engine version?

        Comment


          #5
          The Problem is (what i dont understand) why the APK is in "Debug Mode" when i select "Shipping"?

          //EDIT: When i use the App via "Debugg USB" with the Batch-File then it works on my Phone...

          //EDIT2: How i can disable the Debugg Mode for the APK? Play Store say the App use the Debugg Mode...
          Last edited by Pelix; 04-25-2014, 06:12 AM.

          Comment


            #6
            same for me on Lg G2 snapdragon 800 , i tryed to pacakage my project from 4.0.2(wich worked perfectly with ) with new release 4.1, and apk won't install . do we have to folow our project on older version.

            Comment


              #7
              Originally posted by 84rt-design View Post
              same for me on Lg G2 snapdragon 800 , i tryed to pacakage my project from 4.0.2(wich worked perfectly with ) with new release 4.1, and apk won't install . do we have to folow our project on older version.
              You mean when i use 4.0.2 then i can install the APK and its not in "Debug Mode"?

              Comment


                #8
                I have posted answers to Pelix's questions on his AnswerHub thread here: https://answers.unrealengine.com/que...l#answer-34720
                Adric Worley | Pipeline Dev | Epic Games

                Comment


                  #9
                  Thx a lot

                  And now it works with 4.1.0 and i can upload the APK on Play Store!
                  Last edited by Pelix; 04-25-2014, 09:52 AM.

                  Comment


                    #10
                    Would you please describe the process of exporting and importing into the phone I cant get the bat file to upload to my phone.

                    Comment


                      #11
                      Maybe next days i create a tutorial of this but my english is not so good ....

                      BUT ... i try to help you.

                      You have to activate the "developer" on your smartphone / tablet.
                      Open Settings -> Info -> Software Info -> More -> here you have to click 7 times on the "Build-Number"... dont ask me why but then you become a message "You are an developer now" ... Google is crazy with this tools.

                      After this setup you can see a new function in your Settings "Developeroptions" (dont know the real name in english - its above "Info").
                      There you have to activate your "USB-Debugging". Connect your phone / tablet with your PC (USB), wait for activate the Debugging on your phone and then try the *.bat again.

                      Hope this will help you a lil bit

                      //EDIT: When it works for you and you understand my bad english, maybe you can create the text again with good english

                      Comment


                        #12
                        Thanks for replying.

                        I found the USB debugging in Developer options category. But I am not finding any category called Info. Or Software Info...( first part where you write that it needs to be clicked seven times).....

                        Comment


                          #13
                          Thats on HTC One tha last Point on Settings .... there you can see your software info and something like this

                          Comment

                          Working...
                          X