Announcement

Collapse
No announcement yet.

Black Screen + Crash when deploying and running .APK

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Black Screen + Crash when deploying and running .APK

    I am working on setting up UE4 for Android development. Took some time (due to a boneheaded decision to piece together the Android SDK components instead of via the Nvidia TADP) but I got it to a point where it was successfully compiling. However, using the Tappy Chicken project, when I attempted to launch to my device (description below) via "Cook on the Fly" it results in a black screen and crash on the device. I later attempted the "By the Book" launch, but while it gets past the cooking step (in roughly 2 minutes) it never makes it past Deployment, even after an hour, it seems to simply hang. I tested on several devices and several different USB cables with the same result, attempts made with both MTP, and PtP. In all scenarios, Unreal detects the devices just fine, as does the "adb devices" command.

    Today, I uninstalled the Android SDK, NDK, etc, and reinstalled via TADP 4.0r1 with the Standard preset. Same result on all devices tested. I then attempted to package the .APK and load it on the test devices. The build was successful, and I was able to load and install it on my test devices, but to my surprise, the same black screen and crash happened again, though one crash gave me a "Failed to open descriptor file" message. Perhaps my next step is to see about getting logs from the device and post them here. My hope though is I have some setting wrong, or some other minor fix. Details on all devices, PC, and software involved is below.

    Description
    PC:
    HP DV7-4285dx
    Intel Core i5-460M @ 2.53 GHz
    6 GB RAM
    240GB PNY SSD
    Radeon 6370 (512MB DDR3)

    Windows 7
    Unreal Editor 4.7
    Packages installed via Nvidia TADP (Standard preset)
    Visual Studio 2013 Express (Nvidia Nsight refused to install on Express version of Visual Studio)

    (dev options unlocked on all below devices)
    Device 1:
    LG G2 32GB (T-Mobile)
    Android 4.4.2
    Attempted to launch with ETC_1 and ATC

    Device 2:
    Samsung Galaxy Note 2 (T-Mobile)
    Android 4.3
    Attempted to launch with ETC_1

    Device 3:
    Sony Experia Z3 (T-Mobile)
    Android 4.4.2
    Attempted to launch with ETC_1 and ATC

    Some relevant settings for more information.
    Click image for larger version

Name:	UE4.JPG
Views:	1
Size:	62.9 KB
ID:	1146082

    Click image for larger version

Name:	UE_2.JPG
Views:	1
Size:	74.2 KB
ID:	1146083

    I'll post logs in a bit if/when I find them. Beyond that, if there's any more information I need to provide, let me know. Thanks for your help.

    Edit: Here's the log file from the LG G2 via Logcat.

    https://drive.google.com/file/d/0B7p...ew?usp=sharing
    Last edited by Zodiark1593; 03-14-2015, 06:54 PM.

    #2
    You could just run directly in Android Device. It will run OK.

    I got the same problems like you. But I just run the Deployed App in Android Device, it then runs OK.
    My Github: https://github.com/henrya2

    Comment


      #3
      But I think there must be some bugs in the "Project Launcher" Process.
      My Github: https://github.com/henrya2

      Comment


        #4
        Did you set it to launch the correct starting map? I had this problem when I tried to build a project, it just used some unknown map which happened to be empty instead of the one that I was using as a project basis.

        Comment


          #5
          It's set on the correct starting map.

          And Henry, what do you mean by run directly on the Android Device? I've tried running it via the launcher and by packaging an .apk. Both results end the same way.

          edit: *******, finally got something working. After packaging, I installed it to my device via the batch file. Never thought I'd be so excited to see such a dumb game running on my device. Wished the launcher worked, but if this method works reliably for me, I'm virtually ecstatic. Next up, Mobile temple, I've been really itching to see that run on a phone.
          Last edited by Zodiark1593; 03-15-2015, 05:38 PM.

          Comment

          Working...
          X