Announcement

Collapse
No announcement yet.

UE4 won't find my Android devices?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    UE4 won't find my Android devices?

    Hey fellas!

    Having a blast with the new engine but stumbled upon a problem i can't find anything about!

    Why aren't my Android devices showing up in the Device manager in the editor? I got a Tablet Galaxy Note 2014 edition and a Sony Xperia connected to the PC but it won't find neither of them. Anyone got their android devices working?

    Cheers!
    Johan

    #2
    Have you installed all the Android SDKs and enabled developer mode on your android devices?

    Comment


      #3
      Android SDK's? First time developing for Android device so never done this before! ^^ Hmm can't seem to find how to activate developer mode on my tablet device :S

      EDIT: Found out how to activate Developer mode on my device so that is now activated! Still won't show up tho! Where do i find the android SDK's?
      Last edited by Johan3043; 03-20-2014, 04:38 PM.

      Comment


        #4
        Install the Android SDK, the installer is at: C:\Program Files\Unreal Engine\4.0\Engine\Extras\Android

        After that, do an internet search for the USB drivers for your device, and then make sure your device is developer enabled. I had to install the USB drivers specifically for my Galaxy Note 3

        Comment


          #5
          Its really easy, if you already have android sdk ndk ant and java installed you only need to set up the environment variables. (windows)
          Heres the step by step doc
          https://docs.unrealengine.com/latest...ted/index.html

          Comment


            #6
            Samsung Andorid USB Driver for Windows.

            The USB Driver for Windows is available for download in this page. You need the driver only if you are developing on Windows and want to connect a Samsung android device to your development environment over USB.

            http://developer.samsung.com/android...er-for-Windows

            I used this driver to connect my Samsung Galaxy S4 and UE4 dectected it perfectly. Just follow this info:

            https://docs.unrealengine.com/latest...dtipsandtricks

            http://developer.android.com/tools/device.html

            http://developer.android.com/tools/extras/oem-usb.html

            Hope this help.


            EDIT: I just tested Swing Ninja on my S4 and it runs like a charm, exactly the same as in the editor preview.
            Last edited by Unraul4; 03-22-2014, 03:19 PM.

            Comment


              #7
              To verify that the Android SDK, the USB driver and your Android device has been set up properly for development, open a DOS prompt and type "adb devices". If your device shows up in the list (with some kind of cryptic device ID) you're good to go!

              Comment


                #8
                NO Android Device!

                I can find my device (Huawei G510) by adb devices command in CMD but UE4 Editor CAN NOT find any device in launcher and devices. also I build a sample app with eclipse to my phone and every thing was perfect. Can any one help me?
                My Variables (User & System):
                Android Home: C:\Android\sdk
                Java Home: C:\Program Files\Java\jdk1.7.0_21
                Ant Home: C:\Android\Ant
                Last edited by samkeller; 03-30-2014, 03:51 AM.

                Comment


                  #9
                  Hi samkeller. Did you also install the NDK?
                  Adric Worley | Pipeline Dev | Epic Games

                  Comment


                    #10
                    Originally posted by Adric.Worley View Post
                    Hi samkeller. Did you also install the NDK?


                    I have the NDK installed, doubled checked all environment variables, set up dev mode with USB debugging and verified that my device shows up with the "adb devices" command, still nothing.

                    EDIT:
                    My device also shows up in Visual Studio 2012

                    Double EDIT:

                    Ok, so I just rebuilt the source and now it sees my phone. I recommend doing that after the ADK install and see if that helps.
                    Last edited by M6dEEp; 03-30-2014, 10:38 PM. Reason: Solution

                    Comment


                      #11
                      Originally posted by Adric.Worley View Post
                      Hi samkeller. Did you also install the NDK?
                      Rebuilding the engine resolved my problem too.

                      Comment


                        #12
                        One thing that stumped me for hours after I got everything else right is the fact that my Nexus 5 was in MTP mode when it should've been in PTP mode. MTP mode will only allow Windows to recognize your phone as a media storage device and some Android phones apparently have this mode enabled by default. Just go to Settings -> Storage -> Options (three little dots in the corner) -> USB Computer Connection and set it as PTP.

                        Not sure if it'll affect you but just in case you've tried everything else and it still won't work, this might be the last step.

                        Comment


                          #13
                          Hi I do everything set correctly. I am able to use Unity to directly publish to the device but it is simply not showing up in the device manager in Unreal. Any advice?

                          Have followed your steps.

                          Comment


                            #14
                            Originally posted by M6dEEp View Post
                            I have the NDK installed, doubled checked all environment variables, set up dev mode with USB debugging and verified that my device shows up with the "adb devices" command, still nothing.

                            EDIT:
                            My device also shows up in Visual Studio 2012

                            Double EDIT:

                            Ok, so I just rebuilt the source and now it sees my phone. I recommend doing that after the ADK install and see if that helps.
                            What do you mean rebuild the source i am having this problem also

                            Comment

                            Working...
                            X