Announcement

Collapse
No announcement yet.

Mobile Dynamic Shadows & Movie Playback

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Mobile Dynamic Shadows & Movie Playback

    As our team gets ready for a soft launch next month, there are two main issues that are currently show stopper for us:

    1) Dynamic Shadows won't work correctly on Mobile (as discussed in following threads):

    https://answers.unrealengine.com/que...-lighting.html
    https://answers.unrealengine.com/que...work-on-i.html

    2) Android Movie playback.

    Is there any update, or any plans to resolve these issues in 4.7?

    #2
    According to this thread, startup movie support exists in 4.7.

    https://forums.unrealengine.com/show...-Preview/page3

    Our team is also waiting on mobile movie playback. So far we have hitchiked on the startup movie functionality on PC and hope we can use it on mobile in 4.7.
    Programmer, Rigger, Animator - Demo Reel 2015 - My RnD / WIP thread - www.dennylindberg.com
    Worked on: Kitten'd - Guardians of Valor (Android, iOS)

    Comment


      #3
      1) Should be fixed on 4.7

      Not sure about 2), but if either doesn't work feel free to open a new AnswerHub ticket!

      Comment


        #4
        Hi All,

        I just tried to play a movie using UMG and Media Player on my Nexus 5 and no widget / video is rendered (4.7.2 UE4 Version Packaged to ECT1).

        Does that mean only startup videos have been fixed?

        Cheers

        Greg

        Comment


          #5
          Hi Showster!
          loading movies and startup movies are working, but I'm not sure about movie playback on umg..
          I've tried with widget and all work correctly but I haven't tried video.. can you show what you have done?
          Last edited by Sokom141; 03-08-2015, 09:34 AM.
          Level designer
          Portfolio[WIP]: http://sokom141.carbonmade.com

          Comment


            #6
            Hi Sokom,

            Sure I've attached some editor pics, works fine as a preview.

            What methods are you using to load movies?


            EDIT, If I build for windows it works if I use .wmv format.

            All the best

            Greg


            Click image for larger version

Name:	Credits.JPG
Views:	1
Size:	210.8 KB
ID:	1067955

            Click image for larger version

Name:	Preview.JPG
Views:	1
Size:	134.3 KB
ID:	1067956
            Last edited by PolyMiner; 03-09-2015, 08:19 AM.

            Comment


              #7
              Can you try with .MP4 ?
              For me,last time, it worked

              Cheers
              Mattia
              Last edited by Sokom141; 03-09-2015, 08:13 AM.
              Level designer
              Portfolio[WIP]: http://sokom141.carbonmade.com

              Comment


                #8
                Hi Mattia,

                Yes I've tried with .MP4 720 25FPS no joy still, I'll keep fiddling. Do you place your movies in a specific folder or anything?

                Cheers

                Greg

                Comment


                  #9
                  Originally posted by Showster View Post
                  Hi Mattia,

                  Yes I've tried with .MP4 720 25FPS no joy still, I'll keep fiddling. Do you place your movies in a specific folder or anything?

                  Cheers

                  Greg
                  No,any specific folder
                  I will try today with my own Nexus 5 and I will post any update here, hope it will help!
                  Mattia

                  EDIT:

                  "In order to package correctly, local media files MUST be placed in the Content/Movies/ directory of your project."
                  Last edited by Sokom141; 03-09-2015, 08:56 AM.
                  Level designer
                  Portfolio[WIP]: http://sokom141.carbonmade.com

                  Comment


                    #10
                    Hi Greg,
                    Bad news, I've tried but seems it's not working when deploying on Android..
                    I hope someone will see this thread and post a solution, I'm sorry I can't help you right now.

                    Cheers,
                    Mattia
                    Level designer
                    Portfolio[WIP]: http://sokom141.carbonmade.com

                    Comment


                      #11
                      I did some testing for 4.7.2 on various android devices.

                      1) Dynamic Shadows now work correctly with baked lighting on android devices, but they are very costly. It's almost as costly as running the game on OpenGL ES3.1. I am going to change some values on device profile, see if I can get a better performance.

                      2) Android Startup Movie using (mp4) will work fine on Nexus 7, but on Shield Tablet you can only hear the movie's sound, and you get a black screen.

                      3) Android Movie Playback aside from startup movie doesn't work on any android device as other people also mentioned on this post.

                      RCaloca thanks for your response, I hope Epic will resolve these issues soon! I will go ahead and create AnswerHub ticket for Android Movie playback. but in the mean time, if you can talk to the internal team, and give us any feedback, it would be great

                      Comment


                        #12
                        Hi All,

                        Yup Mattia same for me no shows on android regardless of setup.

                        All the best

                        Greg

                        Comment


                          #13
                          Originally posted by Highbury View Post
                          1) Dynamic Shadows now work correctly with baked lighting on android devices, but they are very costly. It's almost as costly as running the game on OpenGL ES3.1. I am going to change some values on device profile, see if I can get a better performance.
                          When you say it works correctly, did you get it to work with skeletal meshes or just static meshes?
                          Programmer, Rigger, Animator - Demo Reel 2015 - My RnD / WIP thread - www.dennylindberg.com
                          Worked on: Kitten'd - Guardians of Valor (Android, iOS)

                          Comment


                            #14
                            Denny, It does work correctly for Skeletal Meshes!

                            Comment


                              #15
                              Thanks Highbury, I will look into it then and see if we also have bad performance. I don't expect good performance for shadows on mobile to be honest, but it would be nice to have.
                              Programmer, Rigger, Animator - Demo Reel 2015 - My RnD / WIP thread - www.dennylindberg.com
                              Worked on: Kitten'd - Guardians of Valor (Android, iOS)

                              Comment

                              Working...
                              X