Announcement

Collapse
No announcement yet.

Deploy to Android on Windows 7(CHS) failed?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Hi,

    I fixed a bug related to this in Unreal Engine 4.1. Could you please try upgrading and tell me if you still see the problem?

    Thanks

    Leave a comment:


  • replied
    Hi, I've added this to our bug database and I'll see if I can reproduce it tomorrow.

    The ??? string issues are in log file parsing code (which we have a separate bug entry for) but that is a separate issue to the deployment failing.

    Leave a comment:


  • replied
    Originally posted by J.J. Hoesing View Post
    Yep, that definitely looks like some kind of string handling issue. I took a look at the relevant code and nothing immediately obvious jumped out at me, but will take another look. Would you mind posting your ANDROID_HOME environment variable just so I can verify that there isn't something going on with that?
    my ANDROID_HOME = D:\SDK\adt-bundle-windows\sdk, i have an adt-bundle installed.

    Thanks.

    Leave a comment:


  • replied
    Yep, that definitely looks like some kind of string handling issue. I took a look at the relevant code and nothing immediately obvious jumped out at me, but will take another look. Would you mind posting your ANDROID_HOME environment variable just so I can verify that there isn't something going on with that?

    Leave a comment:


  • replied
    Hi jiangweiff,

    Thank you for your post, if you are still having trouble, try posting this on https://answers.unrealengine.com/index.html.

    Have a great day!
    Adam

    Leave a comment:


  • started a topic Deploy to Android on Windows 7(CHS) failed?

    Deploy to Android on Windows 7(CHS) failed?

    When I try to deploy to android on a Windows7(Chinese) it gets failed like this:
    Code:
    LogPlayLevel:Display: Program.Main: ERROR: Exception in mscorlib: δ???ҵ??????D:\SDK\adt-bundle-windows\sdk\build-tools????һ???֡?
    LogPlayLevel:Display: Stacktrace:    ?? System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
    LogPlayLevel:Display:    ?? System.IO.FileSystemEnumerableIterator`1.CommonInit()
    LogPlayLevel:Display:    ?? System.IO.FileSystemEnumerableIterator`1..ctor(String path, String originalUserPath, String searchPattern, SearchOption searchOption, SearchResultHandler`1 resultHandler, Boolean checkHost)
    LogPlayLevel:Display:    ?? System.IO.Directory.InternalGetFileDirectoryNames(String path, String userPathOriginal, String searchPattern, Boolean includeFiles, Boolean includeDirs, SearchOption searchOption, Boolean checkHost)
    LogPlayLevel:Display:    ?? System.IO.Directory.InternalGetDirectories(String path, String searchPattern, SearchOption searchOption)
    LogPlayLevel:Display:    ?? AndroidPlatform.GetPackageInfo(String ApkName, Boolean bRetrieveVersionCode)
    LogPlayLevel:Display:    ?? AndroidPlatform.GetFinalObbName(String ApkName)
    LogPlayLevel:Display:    ?? AndroidPlatform.GetDeviceObbName(String ApkName)
    LogPlayLevel:Display:    ?? AndroidPlatform.Deploy(ProjectParams Params, DeploymentContext SC)
    LogPlayLevel:Display:    ?? Project.Deploy(ProjectParams Params)
    LogPlayLevel:Display:    ?? BuildCookRun.DoBuildCookRun(ProjectParams Params)
    LogPlayLevel:Display:    ?? BuildCommand.Execute()
    LogPlayLevel:Display:    ?? AutomationTool.Automation.Execute(List`1 CommandsToExecute, CaselessDictionary`1 Commands)
    LogPlayLevel:Display:    ?? AutomationTool.Automation.Process(String[] CommandLine)
    LogPlayLevel:Display:    ?? AutomationTool.Program.MainProc(Object Param)
    LogPlayLevel:Display:    ?? AutomationTool.InternalUtils.RunSingleInstance(MainProc Main, Object Param)
    LogPlayLevel:Display:    ?? AutomationTool.Program.Main()
    LogPlayLevel:Display: Program.Main: ERROR: δ???ҵ??????D:\SDK\adt-bundle-windows\sdk\build-tools????һ???֡?
    it feels like a localization issue?

    Thanks for any help
Working...
X