Announcement

Collapse
No announcement yet.

ld.lld: error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    ld.lld: error

    Hi,
    I tried many different project and package type.
    I getting this bad error message when packaging for android.
    (UE version 4.25)

    UATHelper: Packaging (Android (ASTC)): [3/4] KelimelerinGucu3-armv7.so
    UATHelper: Packaging (Android (ASTC)): ld.lld: error: C:/Program Files/Epic Games/UE_4.25/Engine/Source/ThirdParty/GoogleGameSDK/gamesdk/libs/arm64-v8a_API24_NDK21_cpp_shared_Release\libgamesdk.a(SwappyCommon.cpp.o) is incompatible with armelf_linux_eabi
    UATHelper: Packaging (Android (ASTC)): ld.lld: error: C:/Program Files/Epic Games/UE_4.25/Engine/Source/ThirdParty/GoogleGameSDK/gamesdk/libs/arm64-v8a_API24_NDK21_cpp_shared_Release\libgamesdk.a(swappyGL_c.cpp.o) is incompatible with armelf_linux_eabi
    UATHelper: Packaging (Android (ASTC)): ld.lld: error: C:/Program Files/Epic Games/UE_4.25/Engine/Source/ThirdParty/GoogleGameSDK/gamesdk/libs/arm64-v8a_API24_NDK21_cpp_shared_Release\libgamesdk.a(swappy_c.cpp.o) is incompatible with armelf_linux_eabi
    UATHelper: Packaging (Android (ASTC)): ld.lld: error: C:/Program Files/Epic Games/UE_4.25/Engine/Source/ThirdParty/GoogleGameSDK/gamesdk/libs/arm64-v8a_API24_NDK21_cpp_shared_Release\libgamesdk.a(SwappyCommon.cpp.o) is incompatible with armelf_linux_eabi
    UATHelper: Packaging (Android (ASTC)): ld.lld: error: C:/Program Files/Epic Games/UE_4.25/Engine/Source/ThirdParty/GoogleGameSDK/gamesdk/libs/arm64-v8a_API24_NDK21_cpp_shared_Release\libgamesdk.a(swappyGL_c.cpp.o) is incompatible with armelf_linux_eabi
    UATHelper: Packaging (Android (ASTC)): ld.lld: error: C:/Program Files/Epic Games/UE_4.25/Engine/Source/ThirdParty/GoogleGameSDK/gamesdk/libs/arm64-v8a_API24_NDK21_cpp_shared_Release\libgamesdk.a(swappy_c.cpp.o) is incompatible with armelf_linux_eabi
    UATHelper: Packaging (Android (ASTC)): ld.lld: error: C:/Program Files/Epic Games/UE_4.25/Engine/Source/ThirdParty/GoogleGameSDK/gamesdk/libs/arm64-v8a_API24_NDK21_cpp_shared_Release\libgamesdk.a(SwappyCommon.cpp.o) is incompatible with armelf_linux_eabi
    UATHelper: Packaging (Android (ASTC)): ld.lld: error: C:/Program Files/Epic Games/UE_4.25/Engine/Source/ThirdParty/GoogleGameSDK/gamesdk/libs/arm64-v8a_API24_NDK21_cpp_shared_Release\libgamesdk.a(swappyGL_c.cpp.o) is incompatible with armelf_linux_eabi
    UATHelper: Packaging (Android (ASTC)): ld.lld: error: C:/Program Files/Epic Games/UE_4.25/Engine/Source/ThirdParty/GoogleGameSDK/gamesdk/libs/arm64-v8a_API24_NDK21_cpp_shared_Release\libgamesdk.a(swappy_c.cpp.o) is incompatible with armelf_linux_eabi
    UATHelper: Packaging (Android (ASTC)): ld.lld: error: C:/Program Files/Epic Games/UE_4.25/Engine/Source/ThirdParty/GoogleGameSDK/gamesdk/libs/arm64-v8a_API24_NDK21_cpp_shared_Release\libgamesdk.a(SwappyCommon.cpp.o) is incompatible with armelf_linux_eabi
    UATHelper: Packaging (Android (ASTC)): ld.lld: error: C:/Program Files/Epic Games/UE_4.25/Engine/Source/ThirdParty/GoogleGameSDK/gamesdk/libs/arm64-v8a_API24_NDK21_cpp_shared_Release\libgamesdk.a(swappyGL_c.cpp.o) is incompatible with armelf_linux_eabi
    UATHelper: Packaging (Android (ASTC)): ld.lld: error: C:/Program Files/Epic Games/UE_4.25/Engine/Source/ThirdParty/GoogleGameSDK/gamesdk/libs/arm64-v8a_API24_NDK21_cpp_shared_Release\libgamesdk.a(swappy_c.cpp.o) is incompatible with armelf_linux_eabi
    UATHelper: Packaging (Android (ASTC)): clang++: error: linker command failed with exit code 1 (use -v to see invocation)
    UATHelper: Packaging (Android (ASTC)): Took 30,3822358s to run UnrealBuildTool.exe, ExitCode=6
    UATHelper: Packaging (Android (ASTC)): UnrealBuildTool failed. See log for more details. (C:\Users\bayram\AppData\Roaming\Unreal Engine\AutomationTool\Logs\C+Program+Files+Epic+Games+UE_4.25\UBT-KelimelerinGucu3-Android-Development.txt)
    UATHelper: Packaging (Android (ASTC)): AutomationTool exiting with ExitCode=6 (6)
    PackagingResults: Error: C:/Program Files/Epic Games/UE_4.25/Engine/Source/ThirdParty/GoogleGameSDK/gamesdk/libs/arm64-v8a_API24_NDK21_cpp_shared_Release\libgamesdk.a(SwappyCommon.cpp.o) is incompatible with armelf_linux_eabi
    PackagingResults: Error: C:/Program Files/Epic Games/UE_4.25/Engine/Source/ThirdParty/GoogleGameSDK/gamesdk/libs/arm64-v8a_API24_NDK21_cpp_shared_Release\libgamesdk.a(swappyGL_c.cpp.o) is incompatible with armelf_linux_eabi
    PackagingResults: Error: C:/Program Files/Epic Games/UE_4.25/Engine/Source/ThirdParty/GoogleGameSDK/gamesdk/libs/arm64-v8a_API24_NDK21_cpp_shared_Release\libgamesdk.a(swappy_c.cpp.o) is incompatible with armelf_linux_eabi
    PackagingResults: Error: C:/Program Files/Epic Games/UE_4.25/Engine/Source/ThirdParty/GoogleGameSDK/gamesdk/libs/arm64-v8a_API24_NDK21_cpp_shared_Release\libgamesdk.a(SwappyCommon.cpp.o) is incompatible with armelf_linux_eabi
    PackagingResults: Error: C:/Program Files/Epic Games/UE_4.25/Engine/Source/ThirdParty/GoogleGameSDK/gamesdk/libs/arm64-v8a_API24_NDK21_cpp_shared_Release\libgamesdk.a(swappyGL_c.cpp.o) is incompatible with armelf_linux_eabi
    PackagingResults: Error: C:/Program Files/Epic Games/UE_4.25/Engine/Source/ThirdParty/GoogleGameSDK/gamesdk/libs/arm64-v8a_API24_NDK21_cpp_shared_Release\libgamesdk.a(swappy_c.cpp.o) is incompatible with armelf_linux_eabi
    PackagingResults: Error: C:/Program Files/Epic Games/UE_4.25/Engine/Source/ThirdParty/GoogleGameSDK/gamesdk/libs/arm64-v8a_API24_NDK21_cpp_shared_Release\libgamesdk.a(SwappyCommon.cpp.o) is incompatible with armelf_linux_eabi
    PackagingResults: Error: C:/Program Files/Epic Games/UE_4.25/Engine/Source/ThirdParty/GoogleGameSDK/gamesdk/libs/arm64-v8a_API24_NDK21_cpp_shared_Release\libgamesdk.a(swappyGL_c.cpp.o) is incompatible with armelf_linux_eabi
    PackagingResults: Error: C:/Program Files/Epic Games/UE_4.25/Engine/Source/ThirdParty/GoogleGameSDK/gamesdk/libs/arm64-v8a_API24_NDK21_cpp_shared_Release\libgamesdk.a(swappy_c.cpp.o) is incompatible with armelf_linux_eabi
    PackagingResults: Error: C:/Program Files/Epic Games/UE_4.25/Engine/Source/ThirdParty/GoogleGameSDK/gamesdk/libs/arm64-v8a_API24_NDK21_cpp_shared_Release\libgamesdk.a(SwappyCommon.cpp.o) is incompatible with armelf_linux_eabi
    PackagingResults: Error: C:/Program Files/Epic Games/UE_4.25/Engine/Source/ThirdParty/GoogleGameSDK/gamesdk/libs/arm64-v8a_API24_NDK21_cpp_shared_Release\libgamesdk.a(swappyGL_c.cpp.o) is incompatible with armelf_linux_eabi
    PackagingResults: Error: C:/Program Files/Epic Games/UE_4.25/Engine/Source/ThirdParty/GoogleGameSDK/gamesdk/libs/arm64-v8a_API24_NDK21_cpp_shared_Release\libgamesdk.a(swappy_c.cpp.o) is incompatible with armelf_linux_eabi
    PackagingResults: Error: linker command failed with exit code 1 (use -v to see invocation)
    UATHelper: Packaging (Android (ASTC)): BUILD FAILED
    PackagingResults: Error: Unknown Error

    #2
    Merhaba,

    başka bir bilgisayara sıfır kuruluş yaptım.
    Orda çalıştı. (diğerinde neden çalışmıyor, nedenini çözemedim)

    Comment

    Working...
    X