Announcement

Collapse
No announcement yet.

SetupAndroid.bat fails to run in 4.25 when installing everything at default directories

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    SetupAndroid.bat fails to run in 4.25 when installing everything at default directories

    Hi there, I'm sorry if this isn't allowed but I'm really stuck and I don't know what to do to get the SetupAndroid.bat file to run with UE4.25.1, I've followed the instructions to the letter, even going so far as to uninstall and reinstall everything. So I'm making this thread to try and raise visibility for a potential bug I'm coming across. It sounds like at least one other person has been able to repro the issue. It would be really helpful if others could go through the Repro Steps as well and at least help me figure out if it's something unique to my machine or if something is wrong with the setup process as it's currently outlined for 4.25

    Here's a link to my question on AnswerHub: https://answers.unrealengine.com/que...3972/view.html

    Thank you so much for anyone who has the time to check it out!

    #2
    Oh and just would also like to call out that this is not the same issue as that DLL file for which there's a sticky post in the forum and which Epic has done a great job of making note of in the official documentation.

    Comment


      #3
      First of all, Id like to say its a lot easier to use 4.24 if thats an option for you. Recently, they chagned the SetupAndroid.bat Script to an installer for an old version of invidia codeworks, literally everything works flawlessly setting it up, just set the sdk, ndk, and jdk in the project settings, agree to the privacy policy, and youre good. The script is located in C:\Program Files\ EpicGames\UE_4.24\Engine\Extras\AndroidWorks\Win64

      with 4.25, you can try the tutorial i made, https://www.youtube.com/watch?v=4SY2Za6j7UY a lot of people have had success iwth it, but the past couple days poeple have been having gradle issues so cant be 100% sure if its still working, but its worth a try

      Comment


        #4
        Thanks ViceVersa, I'll give your video a try later today when I have the time! I thought about downgrading to 4.24 because I previously had success with that, but with 4.25 none of the official documentation actually shows which version of CodeWorks to install (because I'm a dunce and I forget!). If the video fails I'll try and get it set up with 4.24 again. Thanks again, I'll comment here when I've got an update to share!

        Comment

        Working...
        X