Just in case anyone is having issues with the error "General error during semantic analysis: Unsupported class file major version 57" this can be caused by having JDK 13 installed since UE4 is using gradle 5.

You can either downgrade JDK to 12 or edit this file
Window: C:\Program Files\Epic Games\UE_4.25\Engine\Build\Android\Java\gradle\gradle\wrapper\gradle-wrapper.properties
macOS: /Users/Shared/Epic Games/UE_4.25/Engine/Build/Android/Java/gradle/gradle/wrapper/gradle-wrapper.properties

Change

Code:
distributionUrl=https\://services.gradle.org/distributions/gradle-5.4.1-all.zip
to

Code:
distributionUrl=https\://services.gradle.org/distributions/gradle-6.0-all.zip
That will allow the build to happen at least