Announcement

Collapse
No announcement yet.

Cannot package my game for newer Android versions

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Cannot package my game for newer Android versions

    I'm developing a simple Android game - it's basically finishing up a legacy project, done in UE 4.17. Throughout development, I've been using CodeWorks 1R6 that came with the engine and building it for android-19 - and it all went great. Thing is, now I'm trying to submit my simple game to the Play Store and since now all new games must target API Level 28, I had to change the targets. Problem is, when I change the SDK's, the game does not want to package at all.

    I've tried both uninstalling the old CodeWorks and installing 1R7 from the NVIDIA page and doing the same with 1R8 but this doesn't change anything. I set NDK API to `latest` and SDK to `matchndk` and then minimum SDK to 19/21 (tried both) and target to 26/28 (tried both) but every packaging ends with either:

    Code:
        UATHelper: Packaging (Android (Multi:ASTC,PVRTC,DXT,ATC,ETC2,ETC1)): Program.Main: ERROR: AutomationTool terminated with exception: ERROR: D:/Programy/NVPACK/android-sdk-windows/tools/android.bat failed with args --silent update lib-project --path JavaLibs/common_library --target android-26
        UATHelper: Packaging (Android (Multi:ASTC,PVRTC,DXT,ATC,ETC2,ETC1)): Program.Main: AutomationTool exiting with ExitCode=1 (Error_Unknown)
        UATHelper: Packaging (Android (Multi:ASTC,PVRTC,DXT,ATC,ETC2,ETC1)): BUILD FAILED
        PackagingResults: Error: Unknown Error
    or - when I tried downloading some custom `tools` folder online cause one guy presented it as a remedy:

    Code:
        UATHelper: Packaging (Android (Multi:ASTC,PVRTC,DXT,ATC,ETC2,ETC1)): Program.Main: ERROR: AutomationTool terminated with exception: ERROR: D:/Programy/NVPACK/android-ndk-r18b/ndk-build.cmd failed with args APP_ABI="armeabi-v7a " NDK_DEBUG=1
    So either way, the process goes swell until NDK comes into play (the cmd window appearing). Then, it just breaks.

    How can I solve it? Googled the whole internet but no luck there. Packaging to ETC1 instead of multi also doesn't help. I'm completely stuck and don't even know what to do since neither CodeWorks version does the job and the sdk changes don't, either.

    #2
    Facing the same issue with UE4.21 packaging for ETC2. Did you ever get to the bottom of this?

    Comment


      #3
      WylieModro - I was having some similar issues. It looks like Nvidia Codeworks is no longer bundled with UE4 and has fallen a few versions behind. I downloaded Android Studio from https://developer.android.com/studio and it detected and updated the Nvidia sdk. I also downloaded the latest ndk from https://developer.android.com/ndk/downloads and pointed my project settings to the path for it. This allowed me to package for ETC. Still can't package for ASTC but I think that's because I'm on an old Phenom II processor that doesn't support a necessary instruction set (AVX).

      Comment

      Working...
      X