Announcement

Collapse
No announcement yet.

ANDROID packaging

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    ANDROID packaging

    hello,

    i want first time packaging android but I got:LogPlayLevel: Error: ERROR: Android toolchain NDK r18c not supported; please use NDK r14b to NDK r18b (NDK r14b recommended)

    I downloaded, but how can I use now in UE4 this package?


    #2
    Make sure you are installing the correct Android Works for the specific Engine Version. We have several games that span across several engine versions. When we go to package in Android we have to reinstall Android Works whenever we change Engines. That ERROR looks like one I've had when I tried to package with the wrong version.

    Hopefully that helps.

    Comment


      #3
      Hi, If you have only downloaded the new NDK , unreal will not find them himself.
      You have to open the project setting.
      On the left , search for the Android SDK voice.
      It will open you a panel on the right, with 4 address request. where you have to click the "..." and select the folder of the SDK , NDK, JDK.
      So be sure that you have under the NDK the path that lead to your new NDK just downloaded and installed.

      Comment


        #4
        Hi, I have the same problem. UE 4.24.1, NDK r18b. I have installed NDK r18b, restart the computer, checked the windows environment variables and set the android SDK vars in Unreal.
        Code:
        ERROR: Android toolchain NDK r18c not supported;
        There are others with this problem too. Probably fix here:
        https://www.reddit.com/r/unrealengin..._with_android/

        What else can cause this problem?

        Comment


          #5
          Uninstall your SDK/NDK/NVPACK and install it from within your Engine Folder /Extra/Android/CodeWorks

          Comment


            #6
            Seems that the error should actually be
            Code:
            ERROR: Android toolchain NDK r18b not supported;
            and not r18c.
            Going back to r17c is working for me.

            Comment

            Working...
            X