Announcement

Collapse
No announcement yet.

Android Device Compatibility

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Android Device Compatibility

    Hi,

    I have developed an android game in Unreal engine and i try to run in my phone galaxy j7 prime. My phone is not compatible for that game at all. It is because i have used codeworks 1r6u1, the game only supports for android 5, 6, and 7. My phone was 8.1. So i downgraded my j7 prime to marshmellow which 6.0.1. Still the app is not compatible to run the game in my device. Now I am totally stunned because i badly need that game to submit as software project in my college. Deadline is reaching already.

    Can anyone help me to solve the problem??

    #2
    Although T830 MP1 has low performance, it should run ES3.1. What error message shows the game?

    Comment


      #3
      First try making sure your target and minimum APIs are correct in project settings. Then try enabling Support OpenGL ES2 in your project settings. Next thing you can try is editing your android build settings to support different builds, such as armv7, arm64, etc. If you enable armv7 and arm64, for example, packaging the project will give you two SDKs for each build type.
      Next thing I recommend is packaging your project as ETC1.

      If none of those things worked:

      Uninstall everything codeworks 1R6u1 installed, and install codeworks 1R7u1 instead. Unless of course you are using an older version of the engine which uses an older version of codeworks. 1R7u1 should work fine and bring all the SDKs you need. After 1R7u1 installs everything, make sure the environment variables (if on windows) on your computer are correct. Then in your project settings, ensure that you set the correct target API and minimum API. Android 5.0 is API 21, so your minimum can be 21 and your target can be 25 for android 7.1.
      Last edited by Kuroodo Ditory; 11-11-2019, 05:13 PM.

      Comment


        #4
        thanks bro..will try and let you know

        Comment


          #5
          Click image for larger version

Name:	Screenshot-5.png
Views:	37
Size:	415.2 KB
ID:	1685796

          Comment


            #6
            Install correct CodeWorks and provide correct path in project settings. Android NDK r14b should be used.

            Comment


              #7
              ok...it solved. But one more error. I can package my application but couldnt run in the devices. especially in android 9. it shows the app is stopped. while in android 8.1, it shows app is not installed.
              Can help me in this part please?

              Comment


                #8
                Originally posted by SmgandRifle View Post
                ok...it solved. But one more error. I can package my application but couldnt run in the devices. especially in android 9. it shows the app is stopped. while in android 8.1, it shows app is not installed.
                Can help me in this part please?
                Are you sure you packed OBB inside APK?

                Comment


                  #9
                  yes...i did

                  Comment


                    #10
                    Originally posted by Astartis View Post

                    Are you sure you packed OBB inside APK?
                    yeah...actually i did

                    Comment

                    Working...
                    X