No announcement yet.

Admob Not Working

  • Filter
  • Time
  • Show
Clear All
new posts

    Admob Not Working

    I've posted everywhere else and even messaged people in numerous social platforms for the past 2 weeks. It's as if everyone in the world is out to ignore me with this topic. This is my last try.

    Admob banner ads are not showing up. I have tried 4.21, 4.22, and 4.23, both upgrading my project as well as creating a brand new project. My project is a Blueprint project, no source or cpp. I am using the official google/admob testing ad unit ID's.

    If I use this plugin: The banner ad loads up fine no problem when launching to my phone from the editor. But I have issues packaging my game using that plugin due to an error within the plugin.

    The plugin itself is unrelated to what I am asking. I just want to point out that ads are successfully working when using that plugin, but they do not work when using Unreal Engine's own implementation, ironically.

    When I run the app from the editor onto my phone, the log doesn't show any errors. But when I close the app, these noticeable warnings pop up:

    LogPlayLevel: Warning: 11-01 14:15:07.592 12118 12149 D UE4 : [2019.11.01-18.15.07:592][455]LogAdvertising: Warning: Failed to find Advertising provider named AndroidAdvertising.
    LogPlayLevel: Warning: 11-01 14:15:07.592 12118 12149 D UE4 : [2019.11.01-18.15.07:592][455]LogModuleManager: Warning: ModuleManager: Module 'AndroidAdvertising' not found - its StaticallyLinkedModuleInitializers function is null.
    I also have my app published on a closed alpha branch on the play store. It has been almost 5 days and the banners are still not showing up.