Announcement

Collapse
No announcement yet.

Android Toolchain Error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Android Toolchain Error

    Ive seen questions about this error all over and just now found a fix. When trying to launch my project on any device i get this error LogPlayLevel: Error: ERROR: Android toolchain NDK r12c not supported; please use NDK r14b to NDK r18b (NDK r14b recommended). I went to the NDK Archives and got installed the other versions of NDK for some reason r18b didn't work the engine reconized it as r18c the only one that seems to be working is r17c. Is this a bug with the engine or have i just not been updating things good enough.

    #2
    Same here, having same issue, was working before. reinstalled r18b and it still thinks it is r18c

    Comment


      #3
      No updates here?

      Comment


        #4
        Same problem with UE 4.24.1. ndk r18b is recognized as r18c.

        Comment


          #5
          This One worked for me , i choosed android-ndk-r14b-windows-x86_64.zip


          https://developer.android.com/ndk/do...-14b-downloads

          Comment


            #6
            i think, nobody can help us :s

            Comment


              #7
              I downloaded this version of the NDK and it worked for me after I updated to release (1R8) and I'm on 2.3
              android-ndk-r16b-windows-x86_64.zip

              Comment


                #8

                same problem

                Comment


                  #9
                  i have get solution and complete!

                  1. Download and Unzip r14b version(it is recommend version)
                  2. Edit > Project settings.. > Platforms > Android SDK > Location of Android NDK > {your unzip directory)

                  happy nice day!

                  Comment

                  Working...
                  X