Announcement

Collapse
No announcement yet.

Strange issue launching on android, landscape doesnt seem to render.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Strange issue launching on android, landscape doesnt seem to render.

    Ive got a very simple landscape using world composition. Its fairly large but I have very low poly LOD's and pretty short LOD distances. The level plays fine in the editor but when I try to publish or launch on my android tablet the player (third person project) appears but there is no sign of the landscape and the player just falls and falls and eventually you start to see the landscape from beneath. Im not sure if somehow my players starting point is below the landscape somehow but I dont see this behavior when playing in the editor. Any ideas, help, magic words, potion recipes, incantations or talismans to try would be greatly appreciated.

    Kat.

    #2
    So update on this issue, really weird. I added an event tick to my third person character BP to check its location every 2 seconds. If that location ever dropped below 0 in the Z I reset the location to the same X & Y with a Z of 10,000. So after the game starts on my samsung galaxy tab 3 my character falls and falls and every 2 seconds it resets to a z of 10,000. After 6 or 8 seconds the landscape finally appears and my character falls and lands on the landscape. From that point on I can run around, jump, whatever. Just really weird behavior.

    Id love to know what the cause is but this was just a test project to see how a large landscape might run on android devices and I think its just more than this poor tablet can handle..

    Comment

    Working...
    X