Announcement

Collapse
No announcement yet.

VR App connection to Websocket

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    VR App connection to Websocket

    Dear community,

    I already have a functioning build on the computer (windows) using the socketio-client-ue4 plugin. It is a VR application in which a 360° video is displayed starting upon a signal from a websocket.
    The websocket is written in node.js and works fine, the connection from the client (the VR build on the computer) to the server as well. Now the goal is to run the application on an oculus go. The oculus has android as its operating system.

    The Problem is:
    As soon as I try to build an android application from it, the connection does not work anymore. No matter if I connect the oculus go to unreal and launch the application directly onto the device, if I build an .apk and install that on the oculus or on my smartphone. Nothing seems to work. No crashes, but there is no connection from the app to the websocket.

    Already tried Target SDKs 21 and 19, didn't change anything. All devices are in the same WIFI. Unreal Version is 4.21.2, OS Windows 10, we built the app as ASTC.

    I also tried adding the internet permission, dont know whether that is done correctly, maybe there is the mistake (picture attached).

    I would greatly appreciate any help, my colleague and I are clueless how to proceed from here. Maybe some tinkering with the android manifest? (No idea though how exactly...).
    Other ideas on how to remotely start the video in the app would also help, in case we cannot get the connection to the websocket to work. Our goal is to have 20 Oculus starting the video on one buttonpress at the same time (e.g. on a tablet, smartphone).


    Best regards
    David
    Attached Files

    #2
    Hello,

    WS is working on a specific port maybe it could be caused by network policies? Take a look at: https://developer.android.com/traini...ecurity-config

    Cheers!
    Unreal Engine Meetup Grand-Est
    All The Stuff for Your Console!

    Comment

    Working...
    X