Announcement

Collapse
No announcement yet.

I am at a loss about getting depth of field to work for android test level deployment...

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    I am at a loss about getting depth of field to work for android test level deployment...

    Hi.
    I started using Unreal about a week ago. I am planning to port over from Unity with a project that I have been developing for around 3 years. I had to learn modelling, texturing and everything else from scratch so if I am not very good at technical stuff, please bear with me.
    My background is in film so everything I do has to in some way correspond to the vision I have in my mind. For this particular project it is essential to have depth of field. I have studied the documentation on unreal engine rendering capabilities and building for Android... I think my settings are correct, but for some reason depth of field never works in the levels that I deploy to my phone for testing.
    I am working on a late 2014 Macbook pro Retina with Unreal engine 4 version 4.21.1.
    The phone that I deploy to is a Samsung S8 plus.
    Can someone please help me to get this working...?
    Last edited by Bernessas; 01-14-2019, 12:18 PM.

    #2
    Just in case, I had similar problem with no DoF working on mobile, it was because the mobile profile:

    https://forums.unrealengine.com/deve...f-android-4-19

    Comment


      #3
      Thank you very much... I will try that tomorrow...:-)

      Comment


        #4
        Originally posted by Naitguolf View Post
        Just in case, I had similar problem with no DoF working on mobile, it was because the mobile profile:

        https://forums.unrealengine.com/deve...f-android-4-19

        Hi Naitguolf. Can you please tell me specifically what to do? I have been trying and tweaking all morning and it still isn't working.

        Comment


          #5
          Hi.

          Go to \ProjectName\Config

          Open DefaultDeviceProfiles.ini

          add this file (or edit to match)

          +CVars=r.DepthOfFieldQuality=1

          Regards

          Comment


            #6
            Thank you very much...:-) I will let you know when I have success...

            Comment


              #7
              Hi anyone...
              I have not had any success with this yet. All other post processing effects work, except the one I want the most. I have enabled depth of field on all of the device profiles that I could and still it is non existent when I deploy a level to my phone. The documentation is also confusing, or else I am a bit slow... I have no idea how to know, or specify which device profile to use when deploying my level. This is driving my crazy. Please help me.

              Comment


                #8
                I dont know what might be, but also, remember, Mobile Tonemapper must be disabled in the post processing settings. Only GaussianDOF is working (at least for me).

                Also in order to know the Profile loaded, you can use Get Active Device Profile Name function. It will tell you if you are using MED or LOW profile (those profiles will not have the DoF available)

                Last edited by Naitguolf; 01-16-2019, 08:01 AM.

                Comment


                  #9
                  Ok thanks... I will look into this as well...

                  Comment

                  Working...
                  X