Announcement

Collapse
No announcement yet.

Building APK to support older versions of android

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Building APK to support older versions of android

    Hey everyone,
    I have problem building game for older versions of android. I setup SDK min support for 21 and installed SDK on Codeworks (1R6u1). When i build APK for shipping it uses android-21 NDK but after APK is built only on 8.0 android it can be installed. On older versions of android I get "App not installed - phone does not support this version" (Android 7 and 6). Any suggestions in which direction to look or what to test? I use UE 4.19 for this build.

    Thankkkkksssssss!

    #2
    In project settings under Android you should set your target SDK to 26 and your minimum SDK to the lowest level you want to support.

    Then in project settings under Android SDK you should set your NDK API level to the lowest level supported.

    For example my projects minimum SDK is set to 14 so the NDK API level is android- 19.

    Comment


      #3
      Also, what kind of device are you testing on? Does it support opengl es3.1? You may need to enable support for opengl es2.

      Comment

      Working...
      X