Announcement

Collapse
No announcement yet.

Packaged build lag, for others not me

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Packaged build lag, for others not me

    Hi,

    I am near to the end of production for my android game, I put it up on the store to test it, on my phone (sony xperia xz2) everything works fine, just like in editor, but when I asked a tester to play it, it was very laggy, and some meshes where missing in game(roads, cars etc..) his phone (galaxy s8) and also is very low fps.

    These two phones are very similar and equaly powerful, I don't understand why I do not get the same result on both?
    Last edited by Sampuig12; 12-12-2018, 02:27 PM.

    #2
    i get the same problem sometimes, and that sometimes is when i use instances
    some mobile phones seem to have a problem with instances, sometimes rendering them(but not in the currect spot) and sometimes not even rendering them.

    Comment


      #3
      Thanks for the answer, I was thinking it has something to do with vulkan support checked and also came across a post saying I should you commands when I launch app to make sure everyone has the same quality? I will try this later and update, hope it works.
      ​​​​​​
      ​​​So what do you do when this happens?

      Comment


        #4
        i havent found a fix yet had to remove that level temporarily from my android game.

        i'm still trying to fix it sometimes (most of the times actually working on my pc version of the game) but i hope it DOES have a actual fix

        Comment


          #5
          Ok, thanks, I am also working on it,
          If i find a fix I will post here.

          Comment


            #6
            Ok so I was able to improve a bit by disabling vulkan and packaging only ETC1 not multi, no missing meshes , but other people who download the game say it lags and crashes when they press play(which brings them to the main map)
            ​​​​​​On my phone it works absolutely smooth, again i have a sony xperia xz2 and the person in question had a samsung galaxy s9, so again im confused why 2 powerful phones, 2 different results.

            Comment


              #7
              huh for me etc1 works for xiaomi phones and lg/samsung phones but not for my own phone (huawei g700-u10) it even works for my dads phone (huawei honor 3c)
              i have no idea what else can be changed here to improve performance and fix the missing instances

              Comment


                #8
                slabs37 Thanks for the answer, maybe could you try to install my game see if it lags? I tried ASTC now with vulkan support enabled. as always it works for me but I have no idea if it works for others.

                Comment


                  #9
                  https://play.google.com/store/apps/d...Games.Projectz

                  Comment


                    #10
                    small question : are you using any physX in the game?
                    if not you can turn it off
                    for less game size and also for older phone support (my huawei g700 doesn't support physX so i can't play it on my phone but i can still play it other phones to try it out)
                    i'll be trying it with xiaomi HM note 1LTE

                    EDIT: on every device i tried to download your game at, none of them were compatible sorry

                    how is the game 29mb? the engine files ALONE are 29mb how small can your .pak file be?
                    Last edited by slabs37; 01-09-2019, 12:17 PM.

                    Comment


                      #11
                      Apk is 140 something mb, + 29mb,

                      The new version if you update is ETC2 Whivh should work? Otherwise it is ue4 problem because you can o ly release game api26 or more if i am not mistaken, I cannot download on my older motorola phone nor my old LG.

                      Physix not sure i will check thanks

                      Comment


                        #12
                        By the way ASTC worked also BUT missing textures in User Interface so I will not be using that one.

                        Comment

                        Working...
                        X