Announcement

Collapse
No announcement yet.

Screen resolution on mobile (android)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Screen resolution on mobile (android)

    Screen resolution on mobile (android)

    Hi! I have suspicions about real screen resolution used in postprocessing on mobile.
    It may be device specific, but I dont have more phones to check.
    Im using cutom postprocess material for CRT look, it works fine on PC.

    https://www.mediafire.com/file/ypmpu..._a.uasset/file

    On mobile it looks OK with "fully" 3D objects, like template FPS.
    But when I use it for primitive stuff where each pixel is important I notice
    more red pixels on bottom (right landscape) of the screen, so for example monochorome green - blue objects are blurred out.
    It looks like final image of "engine" is scaled again or something.
    May it be IPS issue as I test it on PC with standart LCD?

    Its better to turn off any blurr, eye-adaptation and smothing if you want to test this asset.

    #2
    tried using r.MobileContentScaleFactor in the device profiles.ini ?
    https://answers.unrealengine.com/que...on-mobile.html
    Headgear - VR/AR solutions

    Comment


      #3
      Saw that topic earlier but did not think that it might have an effect. Yes, it affects my problem, but apparently something else is wrong.
      First picture is with standard settings; second one is after I put 1 in all "not 1" MobileContentScaleFactor in all profiles where "android" word was.
      By editing ini I understand "Windows > Developer Tools > Device Profiles > Open Device Profile > Rendering > r.MobileContentScaleFactor"; do I need to edit ini manually on android device?
      Last edited by GIRATOR; 11-12-2018, 05:55 PM.

      Comment


        #4
        mobile scale factor has no effect on that since it control the resolution of your game. I face the same issue on only default map if I put my app on background while loading . try to make new map check it out

        Comment


          #5
          No, new map also does not help. I used template just for reference, the map on which I have this problem is created from scratch, since I followed the guidelines for reducing app size. Scale factor affects somehow, as you can see after I changed it artifacts also changed to more random.
          My material relies on accurate pixel data, can this be due to the less accurate calculation on mobile? UV are given like float values not integer-pixels, and mobile is 32bit in compare to 64bit PC.

          Comment


            #6
            Do you have mobile hdr on or off? try turning it off to see if you have the same issue
            Headgear - VR/AR solutions

            Comment


              #7
              If I turn off mobile HDR I have no post process at all, even standard bloom/jitter in post process volume doesn't work. Seems its common: https://answers.unrealengine.com/que...r-enabled.html
              More info! On 32bit PC system all works fine, so its android related. Tried to launch this on some android emulators. Here familiar results for bluestacks, pattern depends on window size.
              ---------------------------------------------
              BTW erlier I had issue with "non-square" "non-power_of_2" textures doesn't work on mobile (like not 256x256 or 1024x1024). As I remember it was no way for PC in UE2 so I figured it out. Maybe this postprocess is same situation and I should givup and just dont use it, as target device is mobile only?
              Last edited by GIRATOR; 11-14-2018, 07:09 AM.

              Comment


                #8
                mobile hdr is very heavy performance wise and only a few devices and projects are suited to use it at the moment. Best to have no post process and simulate your effects using other low tech tricks (doesn't look as good but at least the performance is there).

                You'll want to read articles like:

                https://docs.unrealengine.com/en-us/...le/Performance
                &
                https://docs.unrealengine.com/en-us/.../TipsAndTricks
                Headgear - VR/AR solutions

                Comment


                  #9
                  I did not notice better performance when HDR was not turned on, plus I dont use any lighting in my project. Basicly how I imagine the way to fake it is to take image from regular camera, do with it what pp-material does and output it to other texture. Then player camera just sees SM plane with processed texture applied to it. But this solution feels so ugly and I dont believe it will cause less load (at least in UE2 it was hell in terms of performance).

                  So, I guess, case closed? Engine simply cant work "as I want" on mobile?

                  Comment


                    #10
                    Originally posted by GIRATOR View Post
                    I did not notice better performance when HDR was not turned on, plus I dont use any lighting in my project. Basicly how I imagine the way to fake it is to take image from regular camera, do with it what pp-material does and output it to other texture. Then player camera just sees SM plane with processed texture applied to it. But this solution feels so ugly and I dont believe it will cause less load (at least in UE2 it was hell in terms of performance).

                    So, I guess, case closed? Engine simply cant work "as I want" on mobile?

                    Try your idea out - I think it should offer much better performance than mobile HDR on which takes a big hit. Perhaps even add it as a UMG image with transparent background?
                    Headgear - VR/AR solutions

                    Comment

                    Working...
                    X