Announcement

Collapse
No announcement yet.

dynamic shadow under stationary light on android

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    dynamic shadow under stationary light on android

    Hello everyone.
    I have a android project use stationary light.
    When i read stationary light document, i found there have a section called "Dynamic Shadowing" https://docs.unrealengine.com/en-us/...ationaryLights give us a solution to resolve the shadow's blend between static and dynamic. This call per-object shadow.
    To use this feature we must use CSM frist.
    So I found another document about "Cascaded Shadows"https://docs.unrealengine.com/en-us/...CascadedShadow
    Follow this document, I get the same effect on mobile preview.
    Although this CSM document's solution can cast correct shadow on static shadow but movable object can't receive shadow from static object.
    Switch to SM5 mode all is good.
    So, is there some step i missed on android? Or Per-Object Shadow can't work on android?

    #2
    If I understand you, in your project movable objects receiving light incorrect. I ran into same issue yesterday. I think movables can't receive shadows from static meshes on Android (In my case character was receiving light even in completely closed dark room).
    You can select your movable mesh, go to details panel, found lightning, open it fully (click on arrow in the bottom of the lightning), then check "Single sample Shadow from Stationary Lights" option. Mesh still can't receive detailed shadows from static meshes, but now it should recieve lightning correct
    ​​​​​​​P.S Sorry for my eng)

    Comment


      #3
      Originally posted by Vefery- View Post
      If I understand you, in your project movable objects receiving light incorrect. I ran into same issue yesterday. I think movables can't receive shadows from static meshes on Android (In my case character was receiving light even in completely closed dark room).
      You can select your movable mesh, go to details panel, found lightning, open it fully (click on arrow in the bottom of the lightning), then check "Single sample Shadow from Stationary Lights" option. Mesh still can't receive detailed shadows from static meshes, but now it should recieve lightning correct
      P.S Sorry for my eng)
      Yes, you really understand what i want.
      Now time, the important is shadow, not character's light. And even not select the "Single sample Shadow from Stationary Lights", character in my project will accept lighting correct in dark room.
      Last edited by 0xcdafd0f1; 11-05-2018, 12:38 AM.

      Comment

      Working...
      X