No announcement yet.

Android Publish - Black Screen on Distribution Build

  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    @Thokash I'm getting similar fatal errors to what you had. Do you remember exactly what you did with your NDK and SDK versions?

    Leave a comment:

  • replied
    Ridiculous oversight on my part but all it took was to set the default game map. Worth noting, though, that the default map is the editor default until the game is packaged.

    Leave a comment:

  • replied
    Just to add to the above - I modified some settings (specifically NDK and SDK versions) and the fatal exception above no longer occurs but I'm still getting the black screen on ALL devices

    Leave a comment:

  • started a topic Android Publish - Black Screen on Distribution Build

    Android Publish - Black Screen on Distribution Build

    I have a game I'm trying to get into alpha testing on Google Play. When I publish straight to my phone from the editor it works fine. But when I build for Android I get my splash screen and then just black.

    My game is small enough that I don't need an OBB but I have tried generating and uploading the OBB in addition to the APK. Neither work, same black screen.

    Installing via the generated batch file or by downloading from Google Play doesn't seem to make a difference, both give me the black screen.

    I have the NDK set to android-19 and the SDK set to latest. I've flipped on and off about every option I can think without luck. I have Google Play support checked. I'm pretty sure I have my app ID and license key both in correctly but I could be wrong about that. Not sure if that would cause this black screen issue, though.

    I ran the NVPACK monitor.bat when trying to install/run my game and I didn't see any errors but I'm also not super familiar with how to work that - I just selected all logs during my testing and then searched for "error".

    I can't think of what else it could be but this is my first time publishing a game. I've found a few posts about similar errors but all were resolved with methods I tried and none of them worked. I'd be happy to post any logs/screenshots to help determine if this is a bug or something on my end.

    One thing I saw - every time I uploaded a new version to Google Play some tests were run, I guess this is done automatically so that developers can get an idea of how their app might perform on several devices. On 3 different test devices (3 out of 10) I'm getting the following error that causes a crash - note that the other 7 devices no crash but still the black screen:
    1. FATAL EXCEPTION: main
    2. Process: com.thokash.sleepysheep, PID: 12700
    3. java.lang.UnsatisfiedLinkError: dlopen failed: cannot locate symbol "__aeabi_memcpy" referenced by "/data/app/com.thokash.sleepysheep-1/lib/arm/"...
    4. at java.lang.Runtime.loadLibrary(
    5. at java.lang.System.loadLibrary(
    6. at com.epicgames.ue4.GameActivity.<clinit>(Unknown Source)
    7. at java.lang.Class.newInstance(Native Method)
    8. at
    9. at
    10. at
    11. at
    12. at$H.handleMessage(
    13. at android.os.Handler.dispatchMessage(
    14. at android.os.Looper.loop(
    15. at
    16. at java.lang.reflect.Method.invoke(Native Method)
    17. at$
    18. at
    I submitted this as a bug report/question but I figured I'd post here, too. Hoping to get a quick reply, this is giving me an actual headache.