Announcement

Collapse
No announcement yet.

4.20.2 - Can't make APK without compiled .so - for all 4.20 projects

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    I'm not sure if this helps anyone, but I'm experiencing the same error as soon as I disable any plugins and try to launch the project (see my other thread here)

    Comment


      #17
      Hey All,

      I have reproduced this issue and logged a report for it here https://issues.unrealengine.com/issue/UE-63725 . You can track the report's status as the issue is reviewed by our development staff.

      Comment


        #18
        Originally posted by Alex O View Post
        Hey All,

        I have reproduced this issue and logged a report for it here https://issues.unrealengine.com/issue/UE-63725 . You can track the report's status as the issue is reviewed by our development staff.
        Alex I am also having this issue when trying to launch to my Oculus Go, I haven't disable any plugins at all. Will this also be fixed with the bug report you logged?

        Comment


          #19
          Originally posted by Three65 View Post

          Alex I am also having this issue when trying to launch to my Oculus Go, I haven't disable any plugins at all. Will this also be fixed with the bug report you logged?
          Hello, I can't reproduce this on my Go without disabling plugins, however I'd imagine a fix for this would encompass all Android based devices.

          Comment


            #20
            Thanks for the update Alex. Any idea if there is a workaround for now? Or will we just have to wait for 4.21?

            Comment


              #21
              Thanks for the update Alex, I was able to get the "Sun Temple" to launch on my go. However when I am looking around geometry is flickering and disappearing and reappearing when I am looking. I am also experiencing little Red/Green/Blue reflective dots on everything in the scene. Do you happen to know what would be causing this?

              Comment


                #22
                Hello, same problem, after some tests and read this post, just disable the substance plugin and the problem disappeared, hope this could help to someone.

                Comment


                  #23
                  is there any fix for this atm?

                  Comment


                    #24
                    updated to 4.20.3 yesterday and now the same error is back again when packaging the project for android ASTC (Oculus-GO).
                    Edit: tried a few things to get it working again;
                    1. delete NVPack directory
                    2. re-install default AndroidWorks from Epic-directory.
                    3. reboot - same error when building
                    4. copy the .so and .target file (see my first post) - same error
                    5. gradle-error -> run NVPACK/android-sdk-windows/tools/android.bat, click on "Deselect All", update Extras/Android Support Repository
                    6. reboot - same error.
                    7. deleted the .so and .target -> same error
                    8. from UE, launched the project on the GO -> works
                    9. changed SDK Android version to 27 in project settings-Android
                    Now it seems to work again. No idea if it was step 9, or another step/combination. Crossing fingers (again)....
                    Last edited by maxbrown; 09-20-2018, 07:44 AM.

                    Comment


                      #25
                      getting the error after disabling either Oculus VR or Steam VR plugins before building an APK. 4.20.3,

                      Comment


                        #26
                        i cant do anything now is there please any fix for this isue?

                        Comment


                          #27
                          I am also have this issue.

                          I have tried it with UE 4.20.3, on both windows 10 and OS X.
                          I have tried referring to android/sdk/ndk/java/ant dependencies, both from copies installed by NVPack, as well as those that get installed with Android Studio.
                          I have tried using Android SDK version 19, 25, and 27.
                          I have tried disabling all plugins except for the OculusVR one
                          I have tried reinstalling UE

                          On both platforms (os x and windows), i get the same error:

                          "Can't make APK without the compiled .so"

                          Is this still a nagging issue for people?

                          Comment


                            #28
                            Hi
                            I tried this with UE 4.20.3 incl. binaryAndroidSDK of the Engine version. It works fine with my Oculus Go- I hope it helps someone ;-)
                            Attached Files

                            Comment


                              #29
                              I have the same issue, and I'm wondering if it has something to do with the Visual Studio path
                              Attached Files

                              Comment


                                #30
                                Originally posted by ddutta View Post
                                I have the same issue, and I'm wondering if it has something to do with the Visual Studio path
                                Hi. The way I solved this problem was just by eliminating the project and creating a new one, you can try that way. Hope
                                I hope that resolves yours

                                Comment

                                Working...
                                X