Announcement

Collapse
No announcement yet.

Cannot build for android on UE 4.20

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Cannot build for android on UE 4.20

    I keep getting this in my error log while packaging for Android:

    `UATHelper: Packaging (Android (ASTC)): ---------------------- Done ----------------------
    UATHelper: Packaging (Android (ASTC)):
    UATHelper: Packaging (Android (ASTC)): Rebuild All: 0 succeeded, 1 failed, 0 skipped
    UATHelper: Packaging (Android (ASTC)):
    UATHelper: Packaging (Android (ASTC)): 1 build system warning(s):
    UATHelper: Packaging (Android (ASTC)): - License is invalid
    UATHelper: Packaging (Android (ASTC)):
    UATHelper: Packaging (Android (ASTC)): Took 2218.2097164s to run xgConsole.exe, ExitCode=10001
    UATHelper: Packaging (Android (ASTC)): ERROR: Command failed (Result:10001): C:\Program Files (x86)\Xoreax\IncrediBuild\xgConsole.exe "C:\Users\kelec\AppData\Roaming\Unreal Engine\AutomationTool\Logs\C+Program+Files+Epic+Games+UE_4.20\UAT_XGE.xml" /Rebuild /MaxCPUS=200 /no_watchdog_thread. See logfile for details: 'xgConsole-2018.08.21-17.45.45.txt'
    UATHelper: Packaging (Android (ASTC)): (see C:\Users\kelec\AppData\Roaming\Unreal Engine\AutomationTool\Logs\C+Program+Files+Epic+Games+UE_4.20\Log.txt for full exception trace)
    UATHelper: Packaging (Android (ASTC)): AutomationTool exiting with ExitCode=1 (Error_Unknown)
    UATHelper: Packaging (Android (ASTC)): BUILD FAILED
    PackagingResults: Error: Unknown Error`

    And I am not sure what to do about it. Only one person has posted anything about this error, and the post has been removed for some reason. This person had the error in UE 4.20 also, so I am lead to believe that it is something to do with this version of the engine. I have tried using:

    `<bXGENoWatchdogThread>true</bXGENoWatchdogThread>`

    and

    `<bXGENoWatchdogThread>false</bXGENoWatchdogThread>`

    but no luck. I am really stuck with this and it is just as I was about to release to the google play store. None of my google play or android settings are wrong, it has something to do with updating to UE 4.20
Working...
X