Announcement

Collapse
No announcement yet.

Android Packaging isn't working because of Gradle

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Android Packaging isn't working because of Gradle

     
    Spoiler


    I don't know why it isn't working. With Apache Ant it also doesn't package.

    #2
    Go to Project Settings -> Android -> and click on button "Accept SDK License".
    Realtime Database Firebase | Ultimate Mobile Kit Firebase | Extended Facebook | Universal Mobile Ads | Google Analytics

    Comment


      #3
      Originally posted by gameDNA studio View Post
      Go to Project Settings -> Android -> and click on button "Accept SDK License".
      I have accepted it already.

      Comment


        #4
        Originally posted by Christäleon View Post

        I have accepted it already.
        Try deleting the Saved and Intermediate folders in your project and then building your project again and see if it builds.

        Comment


          #5
          It isn't working anyway. It shows the same error when I try to build a new project.

          Comment


            #6
            Go to NVPACK/android-sdk-windows/licences, delete android-sdk-license and Accept SDK License in UE4 again.
            Realtime Database Firebase | Ultimate Mobile Kit Firebase | Extended Facebook | Universal Mobile Ads | Google Analytics

            Comment


              #7
              Everyone is wrong here; the module has updated. I had the same problem. While you install SDK there is one updated module you have to unselect all first and only select Updated module and update it, then Gradle is going to work, nothing else will help, I surprised Epic Developers are not aware of such an issue.

              Comment


                #8
                Gradle will always fail either build or run if you do not update the internal module. This setting is outside the UE4 and you have to find it somewhere in NVPACK installed.

                Comment


                  #9
                  I have that wrong here too!!!!!!
                  UE4.18 , I can't build apk now................

                  Comment


                    #10
                    update the SDK in NVPack folder, deselect all and select only updated module and hit Next, it will update it, EPic doesn't aware of this issue and just suggesting either turn off Gradle or follow the instruction where some steps are not correct, for instance, they have forgotten entirely about modules and updates, if you don't update it you can't compile.

                    Comment


                      #11
                      How to update the modules through codeworks window?

                      Comment


                        #12
                        Run it C:\NVPACK\Chooser.exe and follow my instruction above.

                        Comment


                          #13
                          Is this anything to do with the reason you can't see '1R6u1' in the installer, only '1R6'? I've tried to install codeworks on 2 machines and it's the same.

                          Any help would be great!

                          Comment


                            #14
                            Because you need to download it from the internet.

                            Comment


                              #15
                              Dannington smbv1 I'm encountering the same error where I can't see 1R6u1 in the installer, just 1R6. Were you able to get this working? I'm on 4.18. And smbv1, mind clarifying what you mean by download it from the internet? What am I trying to download? Is it possible to correct through just the provided installer? Thanks!

                              Comment

                              Working...
                              X