Announcement

Collapse
No announcement yet.

Empty Project won't run in Genymotion..

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Empty Project won't run in Genymotion..

    Hi everyone, this problem is driving me mad I really hope someone help me, because really...
    I also posted on answerHub without success: (i added the link in the post, I included also the logcat).
    Basically I almost complete my first game for IOS and Android,and now I would like to test it on my available devices.
    On IOS there's no problem, on my Ipad the game works very well.
    On Android for me, it is still open war!at the moment I'm using Genymotion emulator because I don't have any Android device.
    I searched a lot here and thru Google for this problem and tried a lot of methods but nothing works.
    In Genymotion I'm trying 3 different devices: Nexus 7 2013 5.1.0 Api 22, Nexus 9 7.0 Api 24, CustomTablet 7.0 Api 24.
    Inside Unreal I'm using Gradle, Minimum and target 21, the build is successful but it doesn't work,
    I tried also Complete Empty project(only one empty map), disabling VR plugins, packing OBB inside apk, disable OBB verify on first start...nothing works for me....
    I tried also another emulator, Bluestacks, it does not work...is it a problem of these emulators or I am missing something?
    I hope someone can help me with this, also because now I want to resolve it!

    Edit.ue ver 4.17 and 4.18, ndk r12b.
    Last edited by syq; 12-06-2017, 07:37 AM.
    Dungeon Chaos:
    http://forums.unrealengine.com/showt...-Dungeon-Chaos

    Greenlight support:
    http://steamcommunity.com/sharedfile...=dungeon+chaos

  • #2
    ...I uninstalled codeworks which had only some components installed, now I´m doing a full installation,
    I hope this fix my problem, will keep you updated...
    Dungeon Chaos:
    http://forums.unrealengine.com/showt...-Dungeon-Chaos

    Greenlight support:
    http://steamcommunity.com/sharedfile...=dungeon+chaos

    Comment


    • #3
      The APK is built with ARMv7 native code which is why it isn't working (the emulator wants to use Intel x86):

      java.lang.UnsatisfiedLinkError: dlopen failed: "/data/app/com.indiependentgames.dojogarden-1/lib/arm/libgnustl_shared.so" has unexpected e_machine: 40

      Comment


      • #4
        Hi Chris, thx for your reply, this is correct, but I installed the Genymotion arm translator inside the device and the apk installs without errors but when I try to run the app installed in the device then it says Appname has stopped...
        In fact I had not been able to install the app on the device before I installed the arm translator, but now they install well...
        So what I understood is, if I compile in armv7 I can install it on x86, but I can't run it...is it right?If I use a real device would I have the same problem?

        edit:yeah I did not thought about the armv7 and x86 thing,I think that Genymotion arm translator permits me only to install the app, but obviously
        if it's done in armv7 it can't run...and probably it works on a real device because is armv7 native right?I hope I understood well, now I just need to buy
        an android device...

        thx again Chris
        Last edited by syq; 12-06-2017, 03:46 PM.
        Dungeon Chaos:
        http://forums.unrealengine.com/showt...-Dungeon-Chaos

        Greenlight support:
        http://steamcommunity.com/sharedfile...=dungeon+chaos

        Comment


        • #5
          Yes, you need to run it on a real device.

          Comment


          • #6
            finally I've been able to test the launch on a real device(nexus 7 6.0) but right before it starts on the tablet
            Unreal gives me this:

            Fatal error: [File:\Build\++UE4+Release-4.17+Compile\Sync\Engine\Source\Runtime\CoreUObject\Private\Serialization\AsyncLoading.cpp] [Line: 6584]

            LoadPackageAsync failed to begin to load a package because the supplied package name was neither a valid long package name nor a filename of a map within a content folder: ''

            Build is successful and installs on the tablet then when it starts it gives this Async error...it seems it can't load something because the filename is not valid...
            Mine is a blueprint only project and I'm working on Unreal 4.17.1..

            Edit:complete migration to a new project fixed the problem!
            Last edited by syq; 12-10-2017, 03:00 PM.
            Dungeon Chaos:
            http://forums.unrealengine.com/showt...-Dungeon-Chaos

            Greenlight support:
            http://steamcommunity.com/sharedfile...=dungeon+chaos

            Comment

            Working...
            X