Announcement

Collapse
No announcement yet.

google play service does not connect

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    google play service does not connect

    Hello,
    I tried everything but nothing works
    I also tried this:
    https://forums.unrealengine.com/comm...with-blueprint

    After several tests I see that the blueprint element "show external login ui" executes the output "on failure" instead of "on success"
    I filled all the boxes (distribution signing, google play services)
    My game is in beta, it is in published status and the google services are also in publisher status.

    What can I do? please

    #2
    please help me

    Comment


      #3
      Here are the steps you should do:
      1) Configure project for Google Play Services if you haven't
      2) Enable Google Play Support
      3) Enter your app id which matches the package name from Google Play developer console
      4) Enter Google Play license key from developer console
      5) Fill in distribution signing information; place the keystore file in your project's Build/Android
      6) In Packaging project settings turn on For Distribution (you can't connect without a signed distribution build)
      7) Use "Show External Login UI" node in blueprint

      You can enable extra logging in the logcat to help diagnose issues; see here: https://developers.google.com/games/...ndroid/logging

      Comment


        #4
        hello, thanks for answering
        1, 2, 3, 4, 5, 6, 7 all your suggestions as I explained were already implemented.
        Also my game is already on the playstore in beta version for the testers. (so my signature key is already filled in)

        the blueprint element "show external login ui" executes the output "on failure" instead of "on success"
        I do not understand why?

        I tried the link: https://developers.google.com/games/...ndroid/logging
        But then I really do not understand how I can fix my problem with its data (sorry)

        Comment


          #5
          Enable logging, run your app and capture the logcat, then look for any errors it reports with the login.

          Comment


            #6
            thank you
            With adb logcat I saw that there was a problem with: ID clients OAuth 2.0

            (the link did not happen, no authorization. Weird)
            I created a new application on playstore and it all works
            thank you

            Comment


              #7
              I am currently having the same issues logging into google play services. i did a log and i found this "External UI not supported by the current online subsystem" any idea what that means?

              Comment

              Working...
              X