Announcement

Collapse
No announcement yet.

DefaultBloomKernel.uexp - What is it and is there any way to reduce its size?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    DefaultBloomKernel.uexp - What is it and is there any way to reduce its size?

    Basically, I'm trying to figure out how to reduce the size of the project files in an android project and the biggest file is one called "DefaultBloomKernel.uexp" weighing in at over 32MB out of 45MB overall. Googling this file yields 0 results. What is it, what does it do, and more importantly is there a way to make it smaller?

    I'm using UE4 4.16.0 on a C++ template with nothing in it besides the default floor.

    #2
    It is used for FFT bloom. It shouldn't be needed for mobile. You can create a blacklist file to remove it; see here: https://docs.unrealengine.com/latest...ckageblacklist.

    I'll look into why it is being included.

    Here is an example PakBlacklist-Shipping.txt you can put in your project's Build/Android and Build/IOS directories for shipping:

    Code:
    ../../../Engine/Content/EngineMaterials/DefaultBloomKernel.uasset
    ../../../Engine/Content/EngineMaterials/DefaultBloomKernel.uexp
    Note both must be removed since the uasset references the uexp.
    Last edited by Chris Babcock; 05-31-2017, 02:36 PM.

    Comment


      #3
      I tried add to blacklist, but it's not working at all,
      the apk file too huge.

      I googled this problem, no one asked...
      does anybody really use unreal engine 4 develop for mobile?
      Last edited by feiwu; 07-03-2017, 11:00 AM.

      Comment


        #4
        I found the solution, unchecked the bloom setting in rendering will not cook DefaultBloomKernel,
        but the package is still too huge, the libUE.so is too huge.

        Comment


          #5
          Hello,
          I'm having the same problem, but unchecking Bloom doesn't work.

          See here for a more detailed explanation: https://forums.unrealengine.com/show...l=1#post732034

          Comment


            #6
            The DefaultBloomKernel should be excluded automatically in 4.16.2; it is automatically blacklisted.

            The other thing you can try is to remove the dependency by making an AndroidEngine.ini in your project's Config/Android directory containing:

            Code:
            [/Script/Engine.Engine]
            ; DefaultBloomKernel is not used on mobile
            DefaultBloomKernelTextureName=/Engine/EngineResources/DefaultTexture.DefaultTexture

            Comment


              #7
              Originally posted by Chris Babcock View Post
              The DefaultBloomKernel should be excluded automatically in 4.16.2; it is automatically blacklisted.

              The other thing you can try is to remove the dependency by making an AndroidEngine.ini in your project's Config/Android directory containing:

              Code:
              [/Script/Engine.Engine]
              ; DefaultBloomKernel is not used on mobile
              DefaultBloomKernelTextureName=/Engine/EngineResources/DefaultTexture.DefaultTexture
              Alright, i'll give it a shot. Thank you for your reply.

              Comment


                #8
                Thanks for you help!

                The 4.16.2 update didn't fix this for me. Tried turning bloom on and off. Tried a few other things, no luck. I tried your suggestion of creating an AndriodEngine.ini file and it seems to have worked:

                UATHelper: Packaging (Android (ETC2)): Cook: LogCookisplay: Forcing save package ../../../Engine/Content/EngineMaterials/DefaultBloomKernel.uasset because was already requeued once
                UATHelper: Packaging (Android (ETC2)): Cook: LogCookisplay: Cooking /Engine/EngineMaterials/DefaultBloomKernel -> d:/Documents/Unreal Projects/.../Saved/Cooked/Android_ETC2/Engine/Content/EngineMaterials/DefaultBloomKernel.uasset
                UATHelper: Packaging (Android (ETC2)): Cook: LogSavePackageisplay: Finished SavePackage d:/Documents/Unreal Projects/.../Saved/Cooked/Android_ETC2/Engine/Content/EngineMaterials/DefaultBloomKernel.uasset
                UATHelper: Packaging (Android (ETC2)): Cook: LogCookCommandletisplay: BlockingTimeSec=0.000001
                UATHelper: Packaging (Android (ETC2)): Project.CreatePakResponseFileFromStagingManifest: Excluding d:\Documents\Unreal Projects\...\Saved\Cooked\Android_ETC2\Engine\Content\EngineMaterials\DefaultBloomKernel.uasset
                UATHelper: Packaging (Android (ETC2)): Project.CreatePakResponseFileFromStagingManifest: Excluding d:\Documents\Unreal Projects\...\Saved\Cooked\Android_ETC2\Engine\Content\EngineMaterials\DefaultBloomKernel.uexp

                I guess this means it's packing it, but excluding it from the final build?

                Comment


                  #9
                  4.18 - still same problem
                  DefaultBloomKernel.uexp is not blacklisted automatically
                  and it have size 32mb instead of original 5mb in Engine folder

                  Windows cooked project (not android)
                  Last edited by ScorpyX; 01-06-2018, 09:38 AM.

                  Comment


                    #10
                    Hey guys, not showing android much love I see. In 4.22 that DefaultBloomKernel.uexp is still sitting there taking up half the file size.

                    Comment


                      #11
                      I don't think it's included in apk file, but if you want to reduce it's size - you could easily do it.
                      1. Show Engine Content in Content Browser
                      2. Find Engine Content\EngineMaterials\DefaultBloomKernel texture and change it's maximum texture size in properties.

                      Comment


                        #12
                        Strugling with the same problem. Resaving the DefaultBloomkernel doesn't work, as you can't resave this file as it's used by the engine.

                        Comment


                          #13
                          I'm using 4.24 and still have the same issue.

                          Tried adding PakBlacklist-Development.txt and PakBlacklist-Shipping.txt to \Build\Android
                          Unchecked Bloom attribute in properties
                          Add the AndriodEngine.ini

                          Nothing worked.

                          Change the content from Content\EngineMaterials\DefaultBloomKernel is not a good idea as it will affect any other project because you are changing the engine content directly.

                          Anyone got any new ideas to try?

                          Comment

                          Working...
                          X