Announcement

Collapse
No announcement yet.

4.16 issue.. Can't make an APK without API 'android-23' minimum installed

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    4.16 issue.. Can't make an APK without API 'android-23' minimum installed

    When packing a mobile project, I get this

    Can't make an APK without API 'android-23' minimum installed

    I installed the CodeWorksforAndroid-1R5-windows.exe that was in the directory no luck

    this was working in 4.15 what to do? thanks!


    sorry i reposted this here since it got buried in the sticky under 4.16 how do i fix this need easy steps layed out not familiar with it.

    #2
    Originally posted by rich0550 View Post
    When packing a mobile project, I get this

    Can't make an APK without API 'android-23' minimum installed

    I installed the CodeWorksforAndroid-1R5-windows.exe that was in the directory no luck

    this was working in 4.15 what to do? thanks!


    sorry i reposted this here since it got buried in the sticky under 4.16 how do i fix this need easy steps layed out not familiar with it.
    In 4.16 changelog you can find info about this issue:

    4.16 requires Android SDK 23 or higher to be installed. Please use the SDK manager to install it if you have an earlier install. Also, in Android SDK project settings, please change your Android SDK API Level from “matchndk” to “latest”. This will use the newest installed SDK found in your Android SDK platforms directory. There is no need to change the NDK API Level; “android-19” is correct to allow installing your APK on Android version prior to Lollipop (Android 5.0); setting this higher will require Android 5.0+.
    Realtime Database Firebase | Ultimate Mobile Kit Firebase | Extended Facebook | Universal Mobile Ads | Google Analytics

    Comment


      #3
      Thanks I read that but did not understand it. Should i install CodeWorksforAndroid-1R6-windows.exe? or ? can you give me some details on what to do? sorry

      I opened the Andriod SDK manager it has Adriod SDK Tools 241.1 installed, and Android SDK Platform-tools installed 24

      Android 72.2.2 (API 25) all checked
      Last edited by rich0550; 04-26-2017, 10:05 PM.

      Comment


        #4
        We will be including a custom 1R6 with final 4.16 which will install Android SDK 23.

        Comment


          #5
          Originally posted by Chris Babcock View Post
          We will be including a custom 1R6 with final 4.16 which will install Android SDK 23.
          Could the documentation be updated to reflect these changes? And with that update could it also be noted that Visual Studio itself can install the Android SDK, JDK, ect. and thus you don't have to install both VS 2013 and 2015/2017 ? I think a lot of people would be helped by not having to spend so much time using CodeWorks, installing another VS (although the 2015 and 2013 Compilers can be installed in VS 2017 so maybe it's not an issue), ect.

          Edit: As an aside, those are installed in the C > Program files x86 > JDK / SDK / Android folders ; I just copied them into my NVPACK folder and pointed UE4 at them.

          Comment


            #6
            Documentation will be updated after 4.16 is out.

            Comment


              #7
              i am unable to build game for android jellybean in unreal engine 4.16.3. apk didnt install in android lower than marshmallow. i have already installed latest version of android works.where is the problem??in unreal 4.15 everything works fine.

              Comment


                #8
                Originally posted by satnam2g View Post
                i am unable to build game for android jellybean in unreal engine 4.16.3. apk didnt install in android lower than marshmallow. i have already installed latest version of android works.where is the problem??in unreal 4.15 everything works fine.

                you can solve the error "ERROR: Can not make an APK without SDK API 'android-23' minimum installed"? I have the same problem.

                Comment


                  #9
                  Originally posted by numseii View Post


                  you can solve the error "ERROR: Can not make an APK without SDK API 'android-23' minimum installed"? I have the same problem.
                  After 3 days i solve this problem ones for all
                  if u go to c/NVPACK you can see Android-sdk-windows if u open this folder u can see Android-sdk-windows again unreal search for api 23 in the first folder but Androidworks install apis in the second one !! You dont have to set unreal to see api in the second one becouse if you do this after your apk is done you cant install it in your device becouse it continues to search Android stuff in wrong place . SOLUTION: copy all the content of the second windows folder in the first one . ☺

                  Comment


                    #10
                    is there anyone who can help me to get the api 26 in the nvpack? I have no clue anymore, and i am not able anymore to upload my app tot he google playstore, since they ask for api 26!

                    Comment


                      #11
                      Click image for larger version

Name:	maxTARGETversionsdk_22.jpg
Views:	221
Size:	37.4 KB
ID:	1481974 I solved the problem by downlaoding the codeworks 1r7. Finally i got the needed api 26 for the google playstore! But now,... i encountered a new problem! I have to use TARGET SDK VERSION 26 in order to upload it to the playstore,... but the app crashes then. Anybody an idea whu this is? If i use TARGET SDK VERSION 9 it still works. weird isnt it? max target version is 22. 23-26 crashes
                      Last edited by wontonanimalchin; 05-29-2018, 02:18 AM.

                      Comment

                      Working...
                      X