Announcement

Collapse
No announcement yet.

A different kind of cel shader

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Just another small update to the sample content that will be available in the marketplace:

    Leave a comment:


  • replied
    I've submitted the cel shader for marketplace inclusion: https://forums.unrealengine.com/show...Pack-Submitted

    Feel free to vote for it on the Trello Submissions board once it appears if you'd like to see it on the marketplace by going here and signing up: https://trello.com/b/x2AEJP0x/unreal...ce-submissions

    The earlier version will continue be available in this thread and on GitHub but if you want the latest and greatest, please visit the marketplace as it has a number of improvements and some great sample content.

    And last but not least, thanks everyone who has provided feedback, sent me screenshots and helped track down issues!

    Leave a comment:


  • replied
    It turns out there's a bug with switches in post-process blendables, so the next release will have to wait a bit! There's also another few improvements coming, such as the ability to flatten out the shading to give the scene a low-fi Disney look.

    I've also created some nicer, smaller sample content that better demonstrates how to use the cel shader, terrain shader and water shader. It takes some inspiration from Jean Giraud:





    Last edited by Antidamage; 09-13-2014, 09:04 AM.

    Leave a comment:


  • replied
    Success

    I'll get those branches into switches ASAP.

    Leave a comment:


  • replied
    We're almost there, I think ^^
    The problem is confined only to the effect "NewSprint" with others seems to give no problem. The error it also does it with a new map, just put a postprocess.

    Edit: Yeahh now is work, are always the easiest things to mess up everything thank you very much again for your help, and yet your work is great
    Last edited by Abyssus; 09-07-2014, 09:24 AM.

    Leave a comment:


  • replied
    That's extremely odd. Is there any chance I can get you to send me a cut down example project where it's happening for you? The screen-space texture doesn't compensate for resolution changes like the cel lines do, so resolution changes shouldn't do anything to it. I'd definitely like to fix it.

    Edit: I think I might know what may help. Where you have "Print dots opacity" unchecked, you need to check it and enter "0". The unchecked value is probably 1.

    Leave a comment:


  • replied
    Thank you so much, however do not lose too much time, from what I understand it is just a matter of resolution. I did some other tests and decreasing the resolution change, the effect increases http://i.imgur.com/GvnJxC5.jpg
    The strangest thing is that it looks like a "virus" to make it go away I'm forced to close the editor.
    Today I try a little bit on the forum if I find some similar error.

    P.S. I tried to disable the other effects one by one, but the problem remains, of course if I disable the PostProcess the error disappears.
    Last edited by Abyssus; 09-07-2014, 08:50 AM.

    Leave a comment:


  • replied
    I see you're running a vignette as well - I haven't tried many other post-processing effects in combination with the shader - could that be causing it?

    I'm quite curious to get to the bottom of it so I'll make a new level and try to recreate your scene and get back to you. Thanks for the feedback!

    Leave a comment:


  • replied
    Nothing to do, while changing those options the problem remains:

    http://i.imgur.com/M1yp8NX.jpg

    The weird thing that if I do not change the resolution or I enlarge the viewport, is perfect without any kind of error. Maybe it's a problem of my monitor, my maximum resolution is 1600x900.

    Leave a comment:


  • replied
    That's the print dot part of the shader - it shades dark areas with a screen-space texture. You can adjust it and turn it off here:



    Drop the opacity to 0 to disable it, or adjust the darkness threshold of the area shaded by editing the density value. In this case your scene looks quite dark so I'd try lightening it a bit perhaps, or it won't find anything to shade.

    Leave a comment:


  • replied
    Hi Antidamage, you make a very good work with this effect
    I've tried but I found an error, when I change resolution or I enlarge window jumps out something.

    This is the normal version without error:
    http://imgur.com/q5dCUGJ,sXzqJTK#0

    Here instead is the error:
    http://imgur.com/q5dCUGJ,sXzqJTK#1

    What could cause this?

    Thx.

    Leave a comment:


  • replied
    A few new things, like a 3d targeting reticle and some decent aimoffset blends.

    Leave a comment:


  • replied
    Originally posted by dannyboy View Post
    you are just amazing, i am currently still building my models, i would love to use your shader. how do you think it will look in a space scene?
    It'll look great! The sky is excluded from shading so your stars will look nice.

    Try to get lots of subtle detail in your textures so it generates those soft lines everywhere - space things tend to have lots of mechanical, geometric edges and you want to pick those up. Try loading in your in-progress models and see how it looks, post some screenshots!

    Leave a comment:


  • replied
    you are just amazing, i am currently still building my models, i would love to use your shader. how do you think it will look in a space scene?

    Leave a comment:


  • replied
    You know what's cool? Lasers are cool.

    Leave a comment:

Working...
X