Announcement

Collapse
No announcement yet.

Augmented Reality for UE4

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Hi Ivankio,

    You can find an android demo on google play:
    https://play.google.com/store/apps/d...unreal4ar.demo

    What do you mean by misleading and evasive support? Did you write me to info@unreal4ar.com ? I am sorry if I could not help with your issue.

    Thanks,
    Adam

    Originally posted by ivankio View Post

    Google Play? So you are on android and managed to deal with all the crashes, constrains and bugs? Please share once you publish it. I haven't seen this plugin working well on android and regret spending the money as support was also misleading and evasive.
    AR plugin for UE4
    AR Virtual Mirror plugin for UE4
    Red Alert 2 VR remake
    Armed Island VR RTS

    Comment


      Hi Bruno,

      Can you send me your build log ? I haven't seen this error before, nor reported by others. Do you have multiple versions of libPNG.a ?

      Thanks,
      Adam

      Originally posted by BrunoMS View Post
      Hi guys,

      I'm having some issue trying to export the app to google play.
      I can't fix the LibPNG vunerability error, even following every tutorial found in internet.
      Some things i`ve already tried:
      -Deleted the libpng.a in the plugin folder but didin't work.
      -Updated the plugin to UE 4.15, did not work too.

      Thanks in advance.
      AR plugin for UE4
      AR Virtual Mirror plugin for UE4
      Red Alert 2 VR remake
      Armed Island VR RTS

      Comment


        Hi,

        iPads are all 4:3 ? Why do you want to use a non 4:3 resolution ? The plugin won't work well with other aspect ratios, that is why you have tracking issues.

        "The last issue was with the 3x3 matrix markers. I added a Get Marker MATRIX block after the Offset for NFT Marker section and connected a slider output to drive the Marker Id input so the target marker can be changed from the UI. However, regardless of what the input is, the bike always seems to lock onto marker 8. Any thoughts?"

        Can you please post a screenshot of your blueprint ?

        Thanks,
        Adam




        Originally posted by Dr. Widgit View Post
        Hi Adam,

        I've got a few tracking issues I've been trying to figure out.

        First, I've been playing with different resolutions on the iPad (this iPad is quite capable of running at the highest resolutions at good fps.) I've read that the plugin is designed for a 4:3 aspect ratio, but that pretty much negates anything above 640x480 on the iPad. When running on a non-4:3 resolution, the math to dictate the rotations appears to have issues. When looking from the side, the bike looks reasonably grounded on the marker:
        Click image for larger version Name:	Side.jpg Views:	1 Size:	106.5 KB ID:	1360869

        But when viewed from the top, the tail of the bike "lifts" up:
        Click image for larger version Name:	Top.jpg Views:	1 Size:	115.6 KB ID:	1360870
        Could you give me any guidance on where the math can be modified to accommodate a different aspect ratio?

        The second issue when running at higher resolutions is that it just can't find the marker. I often find that by backing away (effectively reducing the number of pixels for the marker), it can locate it, and then I can move closer again. The image appears to be clean in the debug view of your example. Can you offer any hints as to what would be affecting the tracking?

        The last issue was with the 3x3 matrix markers. I added a Get Marker MATRIX block after the Offset for NFT Marker section and connected a slider output to drive the Marker Id input so the target marker can be changed from the UI. However, regardless of what the input is, the bike always seems to lock onto marker 8. Any thoughts?

        Thanks!
        AR plugin for UE4
        AR Virtual Mirror plugin for UE4
        Red Alert 2 VR remake
        Armed Island VR RTS

        Comment


          Originally posted by AdamHorvath View Post
          Hello,

          Did you follow the the Getting Started tutorial ?
          http://www.unreal4ar.com/getting-started-full-version/

          You need to compile the plugin first for your installed Unreal Engine version .

          If you still get this message click on the non disable option. (The 1.9 version is set to ue4.17 by default, you can change that in the uplugin file.)
          Works on both 4.16 and 4.17.
          Hi Adam,

          we had some more detailed discussions offline, but here is the result for anyone having issues running Unreal4AR. As a reminder, I got Unreal4AR working, but the moment I would start the project, the whole thing would crash without clear error message. I could however run it on other PCs, so the problem seemed to be located on one PC.

          After a long time, I finally found out what was the problem with this PC.

          This PC has installed Windows 10 Enterprise N. The N means that certain packages do not come preinstalled. Apparently, Windows Media Pack does not come preinstalled, which means that for example, a smartphone connected to the PC will not show up in Explorer. This is to enable enterprises to disable access to USB devices.

          As a result, the project naturally got into trouble finding the camera. Now that I installed this Windows Media Pack, all works fine!

          The learning for me also is that if I have specific issues on any PC, I need to double check it has nothing to do with packages not installed due to the version of Windows.

          Thanks again for your help! It's a great project!

          Comment


            Hi Evarest,

            Thank you for the info! I had no prior experience with Windows 10 N.



            Originally posted by evarest View Post

            Hi Adam,

            we had some more detailed discussions offline, but here is the result for anyone having issues running Unreal4AR. As a reminder, I got Unreal4AR working, but the moment I would start the project, the whole thing would crash without clear error message. I could however run it on other PCs, so the problem seemed to be located on one PC.

            After a long time, I finally found out what was the problem with this PC.

            This PC has installed Windows 10 Enterprise N. The N means that certain packages do not come preinstalled. Apparently, Windows Media Pack does not come preinstalled, which means that for example, a smartphone connected to the PC will not show up in Explorer. This is to enable enterprises to disable access to USB devices.

            As a result, the project naturally got into trouble finding the camera. Now that I installed this Windows Media Pack, all works fine!

            The learning for me also is that if I have specific issues on any PC, I need to double check it has nothing to do with packages not installed due to the version of Windows.

            Thanks again for your help! It's a great project!
            AR plugin for UE4
            AR Virtual Mirror plugin for UE4
            Red Alert 2 VR remake
            Armed Island VR RTS

            Comment


              Originally posted by AdamHorvath View Post

              Traditional shadow, but it's a little tricky. Everything can be created with standard UE4 blueprints.
              I am planning to do a tutorial about it.
              Hi Adam, any news about that tutorial?

              Comment


                Originally posted by AdamHorvath View Post
                Hi Bruno,

                Can you send me your build log ? I haven't seen this error before, nor reported by others. Do you have multiple versions of libPNG.a ?

                Thanks,
                Adam


                Hi Adam, i solved my problem, thank you for the attention
                I deleted all LibPNG.a file in my engine folder and it worked.
                Don't know if this is right but i've managed to publish in the Google Play.

                But now i have a second problem:
                When i open the app, the screen is white and the camera does not work.
                Do I need to "ask" permition to use it, change the Android Manifest, or something like that?
                Thanks again and sorry to bother.

                Comment


                  Originally posted by ivankio View Post

                  Google Play? So you are on android and managed to deal with all the crashes, constrains and bugs? Please share once you publish it. I haven't seen this plugin working well on android and regret spending the money as support was also misleading and evasive.
                  It is working great when i launch the app directly on the phone, 0 crashes.
                  The camera isn't working right know, so i've posted a topic a few minutes ago. Hope to solve the problem soon.

                  Comment


                    Hi adam

                    I have an inconvenience,

                    When I test the application on the phone from Unreal Engine, everything works fine and the application is installed on the device and works well. but

                    The problem is that when I package the project for Android, and the APK and OBB files are generated. install them on the cell phone but do not load the markers and the camera does not work, it looks white.

                    I have modified the file
                    Plugins \ ARToolkitPlugin \ Source \ ARToolkitPlugin \ ARToolkitPlugin_APL.xml
                    ("/ Android / obb /"

                    but the screen remains white and does not load the markers on the Android device.

                    I've packed for Android ETC1

                    Please Help

                    Regards

                    Mauricio

                    Comment


                      Hi Mauricio,

                      The modification is only required before you upload your app to the google play store.
                      To troubleshoot your problem, please run the generated installation .bat file in a command prompt so you can see the output of the installation script.

                      Also try to remove sdcard from the phone, and try again.

                      Best Regards,
                      Adam



                      Originally posted by amauricio3d View Post
                      Hi adam

                      I have an inconvenience,

                      When I test the application on the phone from Unreal Engine, everything works fine and the application is installed on the device and works well. but

                      The problem is that when I package the project for Android, and the APK and OBB files are generated. install them on the cell phone but do not load the markers and the camera does not work, it looks white.

                      I have modified the file
                      Plugins \ ARToolkitPlugin \ Source \ ARToolkitPlugin \ ARToolkitPlugin_APL.xml
                      ("/ Android / obb /"

                      but the screen remains white and does not load the markers on the Android device.

                      I've packed for Android ETC1

                      Please Help

                      Regards

                      Mauricio
                      AR plugin for UE4
                      AR Virtual Mirror plugin for UE4
                      Red Alert 2 VR remake
                      Armed Island VR RTS

                      Comment


                        Hey Adam,

                        I'm sure you noticed ARkit and ARcore. Even though it's still really early in development, are you planning to support these technologies, or even switching to them? Will we even need to have an implementation besides those of Google/Apple?

                        Also, Epic implemented a new functionality regarding realtime video compositing: https://www.youtube.com/watch?v=MttCqAGYy0Q
                        I guess the same questions go for this as well.

                        Thanks for your time!
                        Maurice
                        Maurice de Koning
                        3D visualiser at HFB

                        Comment


                          Hello Adam


                          I have not been able to load the markers in a dynamic way to load them in parts in the same camera .. but I have chosen to put a preloader.

                          The problem is that when I load the markers, everything freezes, does not allow to do any action, it would be ideal that the load of the markers did not take the whole process.

                          How can I perform other processes while loading the markers?

                          any solution??

                          stay tuned

                          regards

                          Mauricio

                          Comment


                            Hi Adam

                            Other question

                            I see that the tracking of the marker is horizontal, ie the markers should be on a table, but when the marker are vertical, that is. for example glued to a wall. The models are seen in top view and that is logical.

                            My markers should be displayed vertically.


                            I've tried putting 3D models vertically, but this does not work very well as it does not match the tracking. so this should not be so.

                            My question, is .. how can I change the meaning of the markers so that 3D models are seen in front position?

                            stay tuned

                            regards

                            Comment


                              Hi Mauricio,

                              I think you just need to rotate your model by 90 degrees. You can do that by using the combine rotators node.

                              Originally posted by amauricio3d View Post
                              Hi Adam

                              Other question

                              I see that the tracking of the marker is horizontal, ie the markers should be on a table, but when the marker are vertical, that is. for example glued to a wall. The models are seen in top view and that is logical.

                              My markers should be displayed vertically.


                              I've tried putting 3D models vertically, but this does not work very well as it does not match the tracking. so this should not be so.

                              My question, is .. how can I change the meaning of the markers so that 3D models are seen in front position?

                              stay tuned

                              regards
                              AR plugin for UE4
                              AR Virtual Mirror plugin for UE4
                              Red Alert 2 VR remake
                              Armed Island VR RTS

                              Comment


                                Hello Adam

                                Please

                                I have not been able to load the markers in a dynamic way to load them in parts in the same camera .. but I have chosen to put a preloader.

                                The problem is that when I load the markers, everything freezes, does not allow to do any action, it would be ideal that the load of the markers did not take the whole process.

                                How can I perform other processes while loading the markers?

                                any solution??

                                stay tuned

                                regards

                                Mauricio

                                Comment

                                Working...
                                X