Announcement

Collapse
No announcement yet.

Ledge Climbing System guide

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #31
    Ok so it seems like the program is recognizing the "Grab" file as a modified version of the skeleton. I tried changing all the bone names but after I import it into unreal it crashes. Not really sure what to do at this point

    Comment


      #32
      Hello Crocopede,

      Thanks a lot for the tutorials! I've followed it all (except the wall running and sliding, I don't need those for what I'm doing) but I'm running into a weird issue.
      If I jump around and climb, everything works fine, but I tried going crazy and jump > crouch to go down > jump > crouch > run around for a second > jump > crouch, etc.. and after a bit, my character will end up teleporting to different areas of the climbable wall. Have you tried doing that kind of debug, and if so, any suggestion for how to fix it? I'm not a blueprint expert really, so I'm kind of lost on trying to fix this one.

      If you want a video to see better what's going on, I can get one.

      Comment


        #33
        Hi, I'm follow the ledge climbing tutorial and I'm running in to a problem on the first video. For some reason when I approach the ledge my character gets moved to the underside of the object instead of to the top. Here is a video displaying the issue.


        Have you encountered this issue before?
        I've been through the video a couple of times now and I don't think I've missed anything.

        Thanks!


        * EDIT - How Accidentally set the ledge height to Impact Normal instead of Impact Point.
        Last edited by AutoLiMax; 11-04-2015, 03:17 PM.

        Comment


          #34
          Hi great tutorial learned a lot. I am having odd issue hope I not only one so I can get it solved. but in regards to the move to location. my character does not move to the proper location (to hang from ledge) it instead always moves to the 0,0,0 point of the map. ... not sure what to do. have done the tutorial multiple times. am using 4.8.3 of the engine.

          Comment


            #35
            Originally posted by McTune View Post
            Hi great tutorial learned a lot. I am having odd issue hope I not only one so I can get it solved. but in regards to the move to location. my character does not move to the proper location (to hang from ledge) it instead always moves to the 0,0,0 point of the map. ... not sure what to do. have done the tutorial multiple times. am using 4.8.3 of the engine.
            after investigating, I found that the "wall go to location" macro always fires off 0,0,100 the first shot. after the first one it starts doing the properly but first one always wrong. so is there any way to make it not mess up right off ??
            Last edited by McTune; 11-10-2015, 02:31 AM.

            Comment


              #36
              ledge climbing

              Originally posted by Crocopede View Post
              Hi everyone. I am busy working on a tutorial series covering the creation of a ledge climbing / grabbing system.
              Currently on part 3 and hoping to wrap it up with part 4. But it might extend to part 5.

              I am trying to keep one session below 30 minutes but cannot always manage that.

              Please have a look and give any critique on how i can improve the videos and or sessions.
              Thank you.

              https://www.youtube.com/c/CrocopedeS
              hey i followed your tutorial and for some reason when you press space bar when the player is on the ledge it just goes off the wall and stands and can walk in thin air and dont know why here are the blueprints:
              Attached Files

              Comment


                #37
                Ok so I have put a ton of work into this, I used this system as a base of my mechanics and I have updated and it upgraded to 4.10, I only needed to change a few things and they weren't a big deal. It works fine with that stupid, dumb UE mannequin. I retargeted and had a few issues, but all the animations are working now with a fuse/mixamo the UE4 fbx skeleton. I had to adjust the pose which was aggravating, but that isn't your fault... that is epic's... Anyway everything appears to be working but the character (with the new skeletal mesh) won't ledge grab and won't continue up a wall if there are two placed on top of each other. The model is slightly smaller than the retardedUEman... but it is lined up exactly the same in the collision cap.. . If I switch back to the retaredUEman it works fine. I have been scratching my head for two days now and I am afraid to move on to combat until that is solid...

                Any idea's I have tried it with two different skeletal meshes...

                Basically it isn't locking in anyway on the ledge. It does however allow for left and right movement on the ledge but after the ledge is gone it flys all over the place
                Last edited by Drixil; 12-12-2015, 11:36 AM.

                Comment


                  #38
                  Hello Crocopede!

                  I tried to apply this systems first part (first video) to the sidescroller template, but encountered with errors:
                  1. If I implement ledge detection when jump, the character instead jump further from the camera
                  2. Animation not played

                  What can I do? thanks for your help!

                  Comment


                    #39
                    Hi,

                    I know this thread is a little old but when I saw your tutorial and the results it gave along with the free stuff, well I had to try! (sick tutorial by the way man your one really cool guy).

                    However,

                    I have a problem

                    I have followed your first tutorial for the ledge grab system, I downloaded the new animations on your website rather than the old placeholder animations, I've imported them into UE4 and all looks good!

                    Here is a video though showing you my problem, I go through the graph in the video (video quality is a little bad, hopefully you can see the graph though) and right at the end of the video I show what is happening with my character. I followed the tutorial all the way through and haven't gone away from the methods you show in the tutorial, the only difference between my project and the one in the tutorial is that I have moved the camera and attached it to the characters head socket, all values for the tracers are as they are in your video (I started with the 3rd person BP template).

                    https://www.dropbox.com/s/mvkh0l3umt...3_00-56-30.mp4

                    If you need access to the project I can upload to Dropbox so you can see what I have done, I've been scratching my head over it, I don't know whether the values for the tracers in my project need to be different, or whether there is something wrong with the animations and their states. I would really love your help debugging this though as its killing me

                    Keep up the great work though bro, would love to see more tutorials and if you haven't already got a hard drive then drop me a PM, I will gladly buy you one

                    Cheers,

                    Dave.

                    Comment


                      #40
                      Originally posted by ScrotieFlapWack View Post
                      Hi,

                      I know this thread is a little old but when I saw your tutorial and the results it gave along with the free stuff, well I had to try! (sick tutorial by the way man your one really cool guy).

                      However,

                      I have a problem

                      I have followed your first tutorial for the ledge grab system, I downloaded the new animations on your website rather than the old placeholder animations, I've imported them into UE4 and all looks good!

                      Here is a video though showing you my problem, I go through the graph in the video (video quality is a little bad, hopefully you can see the graph though) and right at the end of the video I show what is happening with my character. I followed the tutorial all the way through and haven't gone away from the methods you show in the tutorial, the only difference between my project and the one in the tutorial is that I have moved the camera and attached it to the characters head socket, all values for the tracers are as they are in your video (I started with the 3rd person BP template).

                      https://www.dropbox.com/s/mvkh0l3umt...3_00-56-30.mp4

                      If you need access to the project I can upload to Dropbox so you can see what I have done, I've been scratching my head over it, I don't know whether the values for the tracers in my project need to be different, or whether there is something wrong with the animations and their states. I would really love your help debugging this though as its killing me

                      Keep up the great work though bro, would love to see more tutorials and if you haven't already got a hard drive then drop me a PM, I will gladly buy you one

                      Cheers,

                      Dave.

                      I think thats possibly just because you havent disabled the inputs that allow your char to move. The standard move fwd and right axis inputs. Put a branch there with a bool called "DisableMovement" and if true do nothing if false carry on as normal.
                      When the hang event runs then set disablemovement to true so the player cant move. And make a button to stop hanging. I think the OP uses crouch input.
                      Snap-In Systems: <<< CLICK
                      | Inventory (Battle Royale) |Smart Select Box | Ready Game Modes | Handy Macros | Gun Weapon System |Simple Mesh Outliner |

                      Comment


                        #41
                        Hi.

                        Apologies i wasnt subscribed to the thread and never got notifications. Will keep a better eye on this now that i am subscribed.
                        I would say thankstipcom is correct.

                        Will respond soon to the other questions. Sorry again for not keeping a better eye on this one.
                        Cheers
                        http://celestialarch.com
                        Free UE4 things available. More coming

                        Comment


                          #42
                          Yo everyone
                          Last year July i ran out of funds and went back to a day job. been inactive this entire time for the most part focusing on the day job and just being drained in the schedule change. But im working hard again after hours now and have new passion.
                          Sorry for the late responses. Things will go a bit better now.

                          Good luck with your projects. Below are some responses. If i did not correctly address your issue please post back and we can have another look.
                          Thx

                          Originally posted by Mik2121 View Post
                          Hello Crocopede,

                          Thanks a lot for the tutorials! I've followed it all (except the wall running and sliding, I don't need those for what I'm doing) but I'm running into a weird issue.
                          If I jump around and climb, everything works fine, but I tried going crazy and jump > crouch to go down > jump > crouch > run around for a second > jump > crouch, etc.. and after a bit, my character will end up teleporting to different areas of the climbable wall. Have you tried doing that kind of debug, and if so, any suggestion for how to fix it? I'm not a blueprint expert really, so I'm kind of lost on trying to fix this one.
                          .
                          If that happens the registered hits are being written incorrectly to the variable. You will have to play around and see when the trace happens and perhaps add a branch somewhere to prevent the trace from firing.


                          Originally posted by AutoLiMax View Post
                          * EDIT - How Accidentally set the ledge height to Impact Normal instead of Impact Point.
                          Glad you got it sorted

                          Originally posted by McTune View Post
                          after investigating, I found that the "wall go to location" macro always fires off 0,0,100 the first shot. after the first one it starts doing the properly but first one always wrong. so is there any way to make it not mess up right off ??
                          Hmm, hard to say... its possible that its firing the trace and the trace is being blocked by something. Will try to reproduce this

                          Originally posted by ant3222 View Post
                          hey i followed your tutorial and for some reason when you press space bar when the player is on the ledge it just goes off the wall and stands and can walk in thin air and dont know why here are the blueprints:
                          Sounds like the let go of ledge section is firing prematurely. double check your branches also on the controls section and make sure other keys are not interfering.

                          Originally posted by IgazHarcos View Post
                          Hello Crocopede!

                          I tried to apply this systems first part (first video) to the sidescroller template, but encountered with errors:
                          1. If I implement ledge detection when jump, the character instead jump further from the camera
                          2. Animation not played

                          What can I do? thanks for your help!
                          Hi.

                          In a platformer game i would eliminate the one axis from the move to location. You dont want to set that because if your character is busy rotating and the trace fires it will hit somewhere not in line with your plane constraint causing this issue.

                          Originally posted by Drixil View Post
                          Ok so I have put a ton of work into this, I used this system as a base of my mechanics and I have updated and it upgraded to 4.10, I only needed to change a few things and they weren't a big deal. It works fine with that stupid, dumb UE mannequin. I retargeted and had a few issues, but all the animations are working now with a fuse/mixamo the UE4 fbx skeleton. I had to adjust the pose which was aggravating, but that isn't your fault... that is epic's... Anyway everything appears to be working but the character (with the new skeletal mesh) won't ledge grab and won't continue up a wall if there are two placed on top of each other. The model is slightly smaller than the retardedUEman... but it is lined up exactly the same in the collision cap.. . If I switch back to the retaredUEman it works fine. I have been scratching my head for two days now and I am afraid to move on to combat until that is solid...

                          Any idea's I have tried it with two different skeletal meshes...

                          Basically it isn't locking in anyway on the ledge. It does however allow for left and right movement on the ledge but after the ledge is gone it flys all over the place
                          Check the macros or branches that checks the distance from your hip to the ledge. Might be it never registers that it is in range. Would make sense considering the size difference. It checks the distance from hip to ledge.



                          Originally posted by ScrotieFlapWack View Post
                          Hi,

                          I know this thread is a little old but when I saw your tutorial and the results it gave along with the free stuff, well I had to try! (sick tutorial by the way man your one really cool guy).
                          However,
                          I have a problem
                          I have followed your first tutorial for the ledge grab system, I downloaded the new animations on your website rather than the old placeholder animations, I've imported them into UE4 and all looks good!
                          Cheers,
                          Dave.
                          I think we resolved this via email? Can remember the video. Let me know if not.
                          http://celestialarch.com
                          Free UE4 things available. More coming

                          Comment


                            #43
                            Originally posted by Crocopede View Post
                            Hi.

                            Apologies i wasnt subscribed to the thread and never got notifications. Will keep a better eye on this now that i am subscribed.
                            I would say thankstipcom is correct.

                            Will respond soon to the other questions. Sorry again for not keeping a better eye on this one.
                            Cheers
                            Hey man,

                            Thanks for popping back in. Seriously.
                            I actually tried to get your system working in my game and didn't fully succeed. I was going to ask for help but I noticed you weren't around so I didn't want to add to the thread until some people started getting things working.

                            I didn't follow your tutorials, intead I grabbed your project and your anims and tried to replicate it in my already worked on game.

                            It works somewhat. Like the traces hit the block, but it doesnt look nice. The wall run and the hang anims are the only ones that work for me. the climb up one goes all bonkers on me. Like the rotation is messed up. Character does a head dive into the ledge hes trinyg to climb. it plays out but it looks insane. I compared it to your working project and the anim settings are the same. I tried for a few hours to figure it out and edit the anim and so on but no luck. So I decided to put it on the back burner with sadness. I was hoping to expand on it and add some more parkour style stuff and some more movements.

                            If you're back and willing to help out. I'll post a video of the behviour I'm seeing later, maybe you can spot something I'm missing!
                            Last edited by thankstipscom; 01-29-2016, 12:25 AM.
                            Snap-In Systems: <<< CLICK
                            | Inventory (Battle Royale) |Smart Select Box | Ready Game Modes | Handy Macros | Gun Weapon System |Simple Mesh Outliner |

                            Comment


                              #44
                              sure thing. the head dive sounds like a root motion mismatch on axis but im still half asleep
                              post a vid lets have a look
                              http://celestialarch.com
                              Free UE4 things available. More coming

                              Comment


                                #45
                                Originally posted by Crocopede View Post
                                sure thing. the head dive sounds like a root motion mismatch on axis but im still half asleep
                                post a vid lets have a look
                                have a look see.

                                https://youtu.be/iUru8MxCYkQ
                                Snap-In Systems: <<< CLICK
                                | Inventory (Battle Royale) |Smart Select Box | Ready Game Modes | Handy Macros | Gun Weapon System |Simple Mesh Outliner |

                                Comment

                                Working...
                                X