Announcement

Collapse
No announcement yet.

Ledge Climbing System guide

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    Wonderful series! Cheers!

    Comment


      #17
      Originally posted by Keny View Post
      Hi , I need help , I just like this in the tutorial video 1 and 2 but my character does not rise . Already revised several times and I not find the error. I use Mixamo eskeleton . Would you help me ?? Here is one video of my problem . https://www.dropbox.com/s/t4t8vzqw1q...ERROR.mp4?dl=0
      Hi.

      Looks like there is no root motion on your animation. Can you confirm that your animation does have root motion?
      If it does have root motion check that you are playing an Animation Montage and that root motion is enabled in the animation sequence and also check that your movement state is flying.
      http://celestialarch.com
      Free UE4 things available. More coming

      Comment


        #18
        You were right, my animation was wrong , I corrected it and now is working perfectly , sorry for my ignorance , I am beginner. I want to thank the help and patience with me I'm happy. Thank you thank you.
        Here is a video , now functions correctly , thank you. https://www.dropbox.com/s/q998x9cv22...RFECT.mp4?dl=0

        Comment


          #19
          Awesome man. Glad its working now.
          http://celestialarch.com
          Free UE4 things available. More coming

          Comment


            #20
            Hi , how do I get my character rise more slowly, it rises very fast . I have to move on animation or any other way to do this ??

            Comment


              #21
              If you are referring to the the part where the character climbs then you will have to modify your animation or you have to set the play rate of the animation to a slower play rate. As its the root motion / animation controlling the speed.
              http://celestialarch.com
              Free UE4 things available. More coming

              Comment


                #22
                Hi!
                Your tutorial is amazing btw but im having an issue importing your Ledge Grab place holder, its failing to import.
                it states:

                Error could not import SK_Mannequin duplicate bone names found.
                (SK_mannequin') each bone mush have a unique name
                Multiple roots found
                Import failed.

                I tried to open the FBX in 3DS Max and get rid of the roots, this allowed me to import it. However in the Third Person Animation blueprint, It cant find the ledge grab animation and it wont let me drag it in

                Knowing me its probably something stupid

                P.S. im using 4.8.3

                thanks for the the help!

                Comment


                  #23
                  Originally posted by hazratb_DMU View Post
                  Hi!
                  Your tutorial is amazing btw but im having an issue importing your Ledge Grab place holder, its failing to import.
                  it states:

                  Error could not import SK_Mannequin duplicate bone names found.
                  (SK_mannequin') each bone mush have a unique name
                  Multiple roots found
                  Import failed.

                  I tried to open the FBX in 3DS Max and get rid of the roots, this allowed me to import it. However in the Third Person Animation blueprint, It cant find the ledge grab animation and it wont let me drag it in

                  Knowing me its probably something stupid

                  P.S. im using 4.8.3

                  thanks for the the help!
                  Hey,

                  Make sure you're importing the animation selecting the skeleton asset you already have for your character (the one you created the anim blueprint to) instead of leaving it to none; which will create a new skeleton just for that animation and won't let you select it for you animbp.
                  "sic parvis magna"
                  @Meguido

                  Comment


                    #24
                    Thank you that was helpful!!!

                    Out of curiosity, the tutorials show how to disable the movement when your on the ledge, If i wanted to shimmy along the ledge how would i go about doing this as a blueprint??

                    Thanks for all your help though!!

                    Comment


                      #25
                      Originally posted by Meguido View Post
                      Hey,

                      Make sure you're importing the animation selecting the skeleton asset you already have for your character (the one you created the anim blueprint to) instead of leaving it to none; which will create a new skeleton just for that animation and won't let you select it for you animbp.
                      thankyou that was very helpful by the way! I am also having trouble with calling a function from a blueprint class, i made a function and i can call it in the animation blueprint but not in the charterer blueprint, any ideas why??
                      Last edited by hazratb_DMU; 08-27-2015, 12:58 PM.

                      Comment


                        #26
                        Hello,
                        First of all great tutorial

                        In 4.9, I have a problem at around part 2 (and maybe after that as well). When I set the wall climb animation to root motion (ref pose) it is rotated, so that the character is crawling on the ground instead of climbing. When I set it to something else for root motion the climb animation moves the character up but not forward so it stands in the air until I move it again. What am I doing wrong? Is there a fix in a later video or is it something in 4.9 that changed, so that I might have to go back to 4.8?

                        Please help,
                        Apolyon

                        Comment


                          #27
                          Originally posted by Apolyon6k View Post
                          Hello,
                          First of all great tutorial

                          In 4.9, I have a problem at around part 2 (and maybe after that as well). When I set the wall climb animation to root motion (ref pose) it is rotated, so that the character is crawling on the ground instead of climbing. When I set it to something else for root motion the climb animation moves the character up but not forward so it stands in the air until I move it again. What am I doing wrong? Is there a fix in a later video or is it something in 4.9 that changed, so that I might have to go back to 4.8?

                          Please help,
                          Apolyon

                          Hey dude can you send us a screenshot of the issue, I have it working in 4.9 so I might be able to help they maybe a fix on the later videos to be fair
                          Last edited by hazratb_DMU; 09-14-2015, 07:26 AM. Reason: quote

                          Comment


                            #28
                            Here are two screenshots for the wall climb animation, where you can see the issue with the root motion rotation.
                            I am using the newer animations that are introduced in part 5 but the issue was there for the older ones as well.

                            Click image for larger version

Name:	WallClimb-Animation-Issue.jpg
Views:	1
Size:	559.8 KB
ID:	1087589
                            Click image for larger version

Name:	WallClimb-Animation-Issue2.jpg
Views:	1
Size:	572.2 KB
ID:	1087590

                            The problem might be on my end as I am using a different character mesh and is could be rotated there (mixamo auto rigged). Maybe I did something wrong on the imports, don't know, kinda new to UE4...
                            Last edited by Apolyon6k; 09-14-2015, 12:59 PM.

                            Comment


                              #29
                              This would go fantastic in the EPIC Heroes and Villains game! :-)

                              Fantastic work man, always love your stuff, also thanks for the freebies on your website too, very awesome!!

                              Comment


                                #30
                                Hey I wanted to start a project that includes Ledge grabbing but I can't import your mannequin into the project. (Using 4.9) Tried importing the asset and all it says is an error. The main reason being that there are multiple bones named after the same thing or something (im not too sure myself). Hope I can get this fixed soon and start watching the tutorial vids! Any help would be appreciated!

                                Heres exactly what the program says:

                                Error, Could not import SK_Mannequin.
                                Duplicate bone name found ('SK_Mannequin'). Each bone must have a unique name.
                                Multiple roots found
                                import failed.

                                Comment

                                Working...
                                X