Announcement

Collapse
No announcement yet.

Dungeon Architect

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Originally posted by Ali Akbar View Post
    [MENTION=31112]unit23[/MENTION] I faced the motion blur issue too. I'll profile the network bandwidth and see if replication is the issue (although no variables are replicated)
    Notice that some of the assets are very performance hungry, like the lava material or the fire particles.

    Leave a comment:


  • replied
    I've improved the stair connection model to create better quality result

    Also fixed a crash issue with the clone actor node in some cases

    Leave a comment:


  • replied
    Originally posted by Yun-Kun View Post
    Hello there

    I have a question regarding the way to implement something I've seen in one of your video [MENTION=28980]Ali Akbar[/MENTION]:

    https://youtu.be/fbIwQFKBUWE?t=23s

    In this video, you're adding a "SideDeco" theme which adds a layer of "buildings", and I can't think of how to implement such a layer. Could you (or someone with the knowledge) point me towards the right direction please? It'd be super nice!

    Thanks in advance for any answer
    [MENTION=32515]Yun-Kun[/MENTION] I used a marker emitter script. It runs after the dungeon layout is built and it tries to fit in NxM tiles (e.g. 2x3, 3x3 etc) in the empty spaces surrounding the dungeon. If it finds it, it emits a marker there and the SideDemo theme file picks up those markers and places those buildings there

    This works similar to the AdjacentCellEmitter in the fire demo that is used to place rocks to build a cave like structure. Instead of finding 1x1 adjacent free tiles, it could be extended to find bigger tiles. I'll try to create a BP for your tomorrow

    Leave a comment:


  • replied
    Originally posted by simpple View Post
    i am using Floor Plan builder.
    There is no floor plan corridor volume.
    Can you make it? I need it too.
    I'll see if I can get this in 2.8

    Leave a comment:


  • replied
    Originally posted by Paradox View Post
    Snap builder is marked as WIP. Is there any work in this direction? And what are the pitfalls in its current state?
    Originally posted by Harcarik View Post
    Same here, snap builder is the part of the plugin i am quite interested in. I am working on a project that could adapt this plugin but in the current state it's not ready for the use. At least from i can gather from reading available documentation and watching videos.
    Is there a chance you could tell us your plans for it? Roadmap of sorts if you will. I would really apreciate that. Thanks, H.
    The snap builder pieces together modules. As of now, these modules have to be blueprints (with meshes in it). This should be replaced with maps files so each individual pieces are stored in their own map files. It's a pain to design your level modules in a blueprint editor.

    I did support map files in the past but that caused various issues that needs to be addressed

    Also, I'll be supporting multiple layout algorithms in snap builder (where you select the layout type from a drop down box). The default snap algorithm goes from start to finish with some branches on the side along the way.

    Some possibilities:

    Space Partitioning so you can have keys / doors and a constraint system. I believe this is what the game ziggaurath uses






    NxN tile layout algorithms with opening on any of NWSE like in Spelunky

    I'll have more updates on the Snap builder in 2.8 after i release 2.7 in a few days
    Last edited by Ali Akbar; 07-24-2017, 12:44 PM.

    Leave a comment:


  • replied
    Originally posted by unit23 View Post
    I use the latest version, and the latest (July 14 downloaded) content package. Not a high priority issue.

    ps. I wrote you an email a few days ago.

    Another thing, in this video, while the ping is reasonable for the assets used, the player has some sort of motion blur, is this intended (kind of cool), or the engine dealing with high load computing?
    [MENTION=31112]unit23[/MENTION] I faced the motion blur issue too. I'll profile the network bandwidth and see if replication is the issue (although no variables are replicated)

    Leave a comment:


  • replied
    Hello there

    I have a question regarding the way to implement something I've seen in one of your video [MENTION=28980]Ali Akbar[/MENTION]:

    https://youtu.be/fbIwQFKBUWE?t=23s

    In this video, you're adding a "SideDeco" theme which adds a layer of "buildings", and I can't think of how to implement such a layer. Could you (or someone with the knowledge) point me towards the right direction please? It'd be super nice!

    Thanks in advance for any answer

    Leave a comment:


  • replied
    i am using Floor Plan builder.
    There is no floor plan corridor volume.
    Can you make it? I need it too.

    Leave a comment:


  • replied
    Originally posted by Paradox View Post
    Snap builder is marked as WIP. Is there any work in this direction? And what are the pitfalls in its current state?
    Same here, snap builder is the part of the plugin i am quite interested in. I am working on a project that could adapt this plugin but in the current state it's not ready for the use. At least from i can gather from reading available documentation and watching videos.
    Is there a chance you could tell us your plans for it? Roadmap of sorts if you will. I would really apreciate that. Thanks, H.
    Last edited by Harcarik; 07-20-2017, 06:24 PM.

    Leave a comment:


  • replied
    Snap builder is marked as WIP. Is there any work in this direction? And what are the pitfalls in its current state?

    Leave a comment:


  • replied
    Originally posted by Ali Akbar View Post
    [MENTION=31112]unit23[/MENTION] Could you try the updated multiplayer demo? The one I uploaded earlier was from the previous version and not the one you see in the video tutorial
    I use the latest version, and the latest (July 14 downloaded) content package. Not a high priority issue.

    ps. I wrote you an email a few days ago.

    Another thing, in this video, while the ping is reasonable for the assets used, the player has some sort of motion blur, is this intended (kind of cool), or the engine dealing with high load computing?

    Leave a comment:


  • replied
    DA is on sale right now (50% off)

    https://www.unrealengine.com/marketp...geon-architect
    Last edited by Ali Akbar; 07-18-2017, 07:24 AM. Reason: link

    Leave a comment:


  • replied
    Originally posted by LuaChunk View Post
    We think we've solved this now, Ali. If you have a theme that spawns a static mesh actor and also spawns a blueprint actor with a static mesh component with mobility set to 'movable', and both use a static mesh with the same texture, then that texture wont stream correctly. The fix for us was we had to go into all our blueprints and make sure the static mesh components in them had their mobility set to 'static'. If the blueprint had a 'movable' root component, which means the static mesh components must be movable then we had to dup the texture for that mesh.

    Regards,

    Ryan.
    Ryan, thanks for the followup post. I'll add this to the docs

    Leave a comment:


  • replied
    [MENTION=31112]unit23[/MENTION] Could you try the updated multiplayer demo? The one I uploaded earlier was from the previous version and not the one you see in the video tutorial

    Leave a comment:


  • replied
    Originally posted by Ali Akbar View Post
    [MENTION=10853]UppercutAJ[/MENTION] I'm trying to get this streaming issue to show up in my computer but unable to. By standalone builds, do you mean a packaged project or Play > Standalone Game. I'll also try with a packaged build

    Here's what I did:
    - Set the engine scalability to Medium
    - Build a dungeon really far away with meshes that have a 4K texture. Since they are too far away, only the lowest mip is streamed in
    - After the dungeon is built, move the player close to the mesh. It properly streams the higher mips in (video 0:02-0:03)



    For debugging, could you try spawning a gate mesh from blueprints next to your player and see if this also has the same issue

    We think we've solved this now, Ali. If you have a theme that spawns a static mesh actor and also spawns a blueprint actor with a static mesh component with mobility set to 'movable', and both use a static mesh with the same texture, then that texture wont stream correctly. The fix for us was we had to go into all our blueprints and make sure the static mesh components in them had their mobility set to 'static'. If the blueprint had a 'movable' root component, which means the static mesh components must be movable then we had to dup the texture for that mesh.

    Regards,

    Ryan.

    Leave a comment:

Working...
X