Announcement

Collapse
No announcement yet.

Dungeon Architect

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Hey man, the plugin is so deep it really needs an API list for the all the blueprints function, Query/Builder/Config etc. It's so hard to explore within unreal. Just a dump of the .h files would do honestly. It's hard to introspect.

    Leave a comment:


  • replied
    [MENTION=28980]Ali Akbar[/MENTION]

    How is development coming along? What's new coming into DA soon ?

    Leave a comment:


  • replied
    I apologize if this has been asked before, but I have two questions:

    1. The 'Draw Debug Data' looks weird. It seems the ground cells are drawn in solid black and other cells are not colored at all. Did I miss some settings somewhere or is this a bug.

    2. I have some trouble understanding spatial constraints. I think I figured out how the 3x3 constraint works for ground cells. However, I am not sure how the 2x2 constraint works. I suppose it looks at the corner of a cell and checks the four adjacent cells, but I don't understand which corner is looked at.
    I also don't quite understand how to utilize spatial constraints for wall cells. Which is the reference point from which the neighboring cells are checked?

    This is what I am trying to accomplish: I want wall cells that are adjacent to an outwards bend corner to use a different mesh. I could get it to work for walls facing one direction but never all four directions at once.

    I am using UE4.16 and installed the plugin via the Epic Launcher.

    (I just realized I am using the wrong PC and cannot take screen shots of the project. I will add pictures once I booted the correct computer. )

    Draw Debug Data issue:
    Click image for larger version

Name:	debugData.png
Views:	1
Size:	524.3 KB
ID:	1130019

    Spatial Constraints: I want the red wall sections to use a different mesh than the blue sections. The visible wall piece is a Separator that I managed to place the way I want.
    Click image for larger version

Name:	walls.png
Views:	1
Size:	414.2 KB
ID:	1130020
    Last edited by Praseodyl; 06-21-2017, 04:12 AM.

    Leave a comment:


  • replied
    Can you also provide arm64-v8a binaries ? Currently only armv7-es2.a are present

    Leave a comment:


  • replied
    Oh, this is a simple grid dungeon with a mirrored volume on the X-axis.

    Leave a comment:


  • replied
    [MENTION=59935]A[/MENTION]li, seeing a lockup on a mesh node when attempting to select a selection logic in a drop-down. May be something specific to my theme (it's got a log of stuff in it). Add mesh node, click mesh node, under "Selection Logic" click '+' to add a logic, click on drop-down (currently set to "None"), BOOM! locks-up URE. I've waited as long as 10 minutes to see if URE makes it back. Processor is stuck at 13% (8 cores, that's 100% on 1 core); suspect a bug in DA that drops into an infinite loop.

    Leave a comment:


  • replied
    @ ali Akbar: I purchased this pack a long time ago on your website. Is it possible in any way to add this addon or plugin to my library instead of adding it every time again and again!?

    Leave a comment:


  • replied
    How do I get my dungeons (sci-fi) to come with the same lighting as your youtube videos.. do you have to tweak the lighting or is that generated also? I see the orange and blue lights but the overall lighting looks bland and flat... I KNOW IT'S SOMETHING I'M DOING WRONG. Any suggestion?

    Leave a comment:


  • replied
    [MENTION=28980]Ali Akbar[/MENTION] - Is it trivial to expose the Snap builder config variables to Blueprint? (module arrays, branch sizes, etc) If so, can that be worked into an update? Thanks!

    Leave a comment:


  • replied
    Thank you for your help. Now everything is perfet

    Leave a comment:


  • replied
    Originally posted by OnlyOneLab View Post
    Could you help me with quick start content pack for Dungeon Architect plugin.
    I've download quick start content from website, made a new third person project in 4.6.1 for it and copied all files in content folder.
    here is a link for screenshot
    https://ibb.co/kPPzQv
    I've tried to open example maps, but it is empty at all:
    https://ibb.co/nojzQv
    Dungeon theme is empty too:
    https://ibb.co/hjiFyF
    Same problems with all demos.

    Could you help me to solve this problem?
    Thank you in advance.
    [MENTION=274250]OnlyOneLab[/MENTION] You need to copy them in the Content's root folder
    • Delete whatever you copied
    • Copy over the files again to the Content/ folder
    • If you need this in a sub folder, the from within the editor's content browser, move the files to a sub folder so UnrealEd can properly move them
    • Add starter content to the project


    Also refer the quick start guide instructions for each map. There are some art dependencies for some maps (like infinity blade's free assets from the marketplace) that you need to add to you project first

    Leave a comment:


  • replied
    Quick Start Content Pack problem

    Could you help me with quick start content pack for Dungeon Architect plugin.
    I've download quick start content from website, made a new third person project in 4.6.1 for it and copied all files in content folder.
    here is a link for screenshot
    https://ibb.co/kPPzQv
    I've tried to open example maps, but it is empty at all:
    https://ibb.co/nojzQv
    Dungeon theme is empty too:
    https://ibb.co/hjiFyF
    Same problems with all demos.

    Could you help me to solve this problem?
    Thank you in advance.

    Leave a comment:


  • replied
    Originally posted by Bloodwork View Post
    Hi. Can this asset be used for paper2D games?
    [MENTION=1691]Bloodwork[/MENTION] Paper2D is not supported

    Leave a comment:


  • replied
    Hi. Can this asset be used for paper2D games?

    Leave a comment:


  • replied
    Originally posted by Ali Akbar View Post
    [MENTION=525502]rctorres[/MENTION] There are a few things you need to consider:

    If you are spawning the AI in a runtime dungeon, then the navmesh needs to be regenerated at runtime. You can set this in the project setting: Video (skip to 2:08)
    If you build your dungeon at design time in the editor and hit play and they don't move, make sure the ground tile is not blocking them (you'll need to adjust the Z offset on the actor node). Also check this for NPCs that are falling through the ground
    Thanks for pointing out the runtime navmesh issue! Looks like I had set my custom spawner to always use z=0 to spawn no matter how high I placed the spawner. Looks like things are working as intended!

    Leave a comment:

Working...
X