Announcement

Collapse
No announcement yet.

Dungeon Architect

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Any idea when the "Is Near Marker" node will be fixed?

    Comment


      Is 4.17.x no longer supported? Dungeon Architect caused a unknown issue in my project so I decided to try reinstalling the plugin but the launcher(and the marketplace description) says 4.17 is not compatible.

      Comment


        Oh, and in 4.18.3, if the dungeon is built with the "Instanced" flag checked, it disappears when played on a mobile device. It doesn't matter whether it was built on design-time or runtime. DungeonInstancedStaticMeshActor just disappears.
        If the "Instanced" flag is not checked(i.e. if the dungeon actor is consist of static meshes only), it doesn't disappear.

        It was working well on 4.17.2 with the old version of plugin, so I guess it's a bug.

        ++
        Ran some test on 4.20 and the same thing happened. The DungeonInstancedMeshActor created in the editor gets destroyed(returns invalid) when played on mobile for some reason.
        Last edited by netcop0207; 08-06-2018, 01:23 PM.

        Comment


          Any update on when the new SnapMap demo will be available?

          Comment


            SnapMapBuilder "Build Module Cache" doesn't seem to work for me - I get the "Invalid Snap Builder Module Data" red warning message and it won't go away even when I click Build Model Cache. Also, clicking Build Model Cache doesn't seem to do anything visible in the Editor or in the Output Log, so maybe it isn't working?

            I've create a small test in 4.19 and 4.20 and have seen this same result:

            1. Make a new blank level, place a floor static mesh and drop some default SnapMapConnectionActors into it. Save level.
            2. In a separate level, add a Dungeon actor, set it to Snap Map and add the module level to each module type array.
            3. Click build module cache. Nothing seems to happen.
            4. in the level blueprint, hook up "build dungeon" on your dungeon actor to Event Begin Play so the dungeon will be built at runtime.
            5. Play in Editor and a Red warning message says "Invalid Snap Builder Module Data" and the dungeon is never generated, regardless of how many times the Build Module Cache button was clicked in Editor before pressing Play.

            You said that the Dungeon won't generate in Editor, but I assumed that meant just that it wouldnt work if you click "build dungeon" while in editor mode, but that it should work this way if you Play in Editor and build at runtime - or does it only work in an actual Packaged build (which would be crazy because there'd be no way to test in editor)?

            *EDIT - Found a Fix*
            Seems if I "build dungeon" and "Destroy Dungeon" from the editor before adding any modules, something is initialized and the dungeon afterwards works correctly when adding modules and clicking "Build Module Cache"
            Last edited by JBernhelm; 08-07-2018, 03:21 PM. Reason: found a fix

            Comment


              Ooh - ran into a major blocker with the SnapMapBuilder setup.

              In my game, currently set up with Blueprint/Actor SnapBuilder, I have a class that stores a set of default settings for a SnapDungeonConfig. This way I can hand author a bunch of different sets of modules, dungeon lengths, etc, and then choose one on runtime (say based on difficulty level or map type), assign that config to my dungeon actor and then Build Dungeon on the fly.

              I'd love to use SnapMapBuilder instead of SnapBuilder to get the new mission editor features you're working on and because yeah, it's a pain to build modules as actors!

              But how can I assign a config on the fly to a SnapMapBuilder Dungeon and make that work with the Build Model Cache?

              Possible options:
              • Is there a way to bake-out a model cache for each SnapDungeonConfig I might want to use?
              • Build the model cache in runtime?
              • Store a Dungeon Actor + config combo with the Build Model Cache included somehow, so I can save those and choose which dungeon to spawn instead of choosing from different dungeon configs at runtime?
              • Have dozens of Dungeon Actors in my level, with their individual configs set and Build Model Cache's clicked, then choose one and build it at runtime?

              EDIT
              - having multiple Dungeon Actors in my level and only building from the one I want at the time seems to work okay. Not sure if there are performance issues down the road though if I have 30+ Dungeon Actors with model caches all in one level?
              Last edited by JBernhelm; 08-08-2018, 12:17 AM.

              Comment


                Originally posted by Baradine View Post
                I can't seem to get stairs to work in floorplan. does anyone have any suggestions? I put the stairs in and it generates in every room. I just want the stairs to generate in the far left corner of every floor of the building. Great tool, thanks for it.
                Put in a "Floor Plan Room Volume" to cut through the floors of the corner room and create a marker for the "Per floor centre marker" in your theme file

                Comment


                  I recently purchased DA because the vids are so awesome, and I'm just not a TA to make levels. However, I'm finding that DA is constantly crashing the app due to video memory leak, or locks up. Even small actions by dropping a mesh into a theme. If I'm not using DA then no problems, UE run's smooth. Maybe it's just the theme builder, but since I need a theme and I can't make one I can't tell if there is any other issues.

                  I upgraded my computer because it died, and I decided to skimp on ram until next month. So I'm only running 8gb for now due to the prices and I'm not made of money :\
                  I'm wondering if it's a memory issue, or a memory leak. Either way it's unusable right now. Also one final note, for some reason loading up any UE project even a empty one takes a few minutes. I'm not sure if it's related though.

                  I'm using UE 4.20
                  DA 2.9.2

                  If anyone has had these problems and may know what's up(buy more memory?) I would appreciate some assistance to resolve the issue.

                  Comment


                    Ok, well as for my crash/lockup. I've found a work around in the mean time.
                    1) I stopped working with meshes and am now only working with blue prints with meshes in them.
                    2) I don't leave the DA theme open for long.
                    - Create a blue print
                    - open theme
                    - add blue print
                    - adjust blue print in theme
                    - close
                    3) don't turn on the debug or dungeon properties.

                    My problem seems to mostly be related to keeping the theme open and doing more work. the longer it runs sooner or later it breaks. say about 5-10 minutes. where as open and closing allows me to work on it for a few hours. So go figure. I'm thinking more ram will help remove the problem.

                    Note: with more checking out. It seems to be more with the debug and dungeon options in the preview window.
                    Last edited by jayderyu; 08-18-2018, 02:23 PM.

                    Comment


                      Ok, different question. now that i can work with the tool

                      I'm working mostly in the city system. I'm wondering how can I make smaller roads. I've made my base road 2 lanes wide, and I'm thinking of going to 4 laes. however, 2 or 4, how can I do smaller roads.

                      Say for example I want to do major road ways at 4 lanes, and then city core being 2 lanes, with some back alleys being 1 lane.

                      Comment


                        Constant crashes with the snap builder. Repro is simple. Open DA_Snap_GameDemo. Open MySnapConnection in the editor (should be data-only BP). Change Door Class to BP_BasicWall. Reset it back (yellow reset button). Insta-crash.

                        I've had all sorts of problems with the snap builder, generally around the connectors. Even the sample is very unstable.

                        I suspected for a while that it was because I was using instanced meshes in the room BPs, but that doesn't seem to be the issue.

                        Another issue that I see is that the walls and/or doors meshes are often created at the origin rather than at the BP connectors. There just really seems to be problems with the connectors.

                        4.20 w/latest DA (2.9.2)


                        LoginId:
                        EpicAccountId:

                        Ensure condition failed: ChildActorTemplate == nullptr [File:\Build\++UE4\Sync\Engine\Source\Runtime\Engine\Private\Components\ChildActorComponent.cpp] [Line: 105] Found unexpected ChildActorTemplate BP_BasicWall_C /Game/DA_Snap_GameDemo/Modules/Module_1x1A.Module_1x1A_C:MySnapConnection_GEN_VARIABLE.MySnapConnection_GEN_VARIABLE_MySnapConnection_C_CAT.Door.Door_BP_BasicWall_C_CAT when ChildActorClass is null

                        UE4Editor_Engine!UChildActorComponent::SetChildActorClass() [d:\build\++ue4\sync\engine\source\runtime\engine\private\components\childactorcomponent.cpp:461]
                        UE4Editor_DungeonArchitectRuntime!ASnapConnection::PostEditChangeProperty() [d:\build\++portal+dev-marketplace+full\sync\localbuilds\plugintemp\hostproject\plugins\dungeonarchitect\source\dungeonarchitectruntime\private\builders\snap\connection\snapconnection.cpp:89]
                        UE4Editor_CoreUObject!UObject::PostEditChangeChainProperty() [d:\build\++ue4\sync\engine\source\runtime\coreuobject\private\uobject\obj.cpp:444]
                        UE4Editor_CoreUObject!UObject::PropagatePostEditChange() [d:\build\++ue4\sync\engine\source\runtime\coreuobject\private\uobject\obj.cpp:518]
                        UE4Editor_CoreUObject!UObject::PostEditChangeChainProperty() [d:\build\++ue4\sync\engine\source\runtime\coreuobject\private\uobject\obj.cpp:411]
                        UE4Editor_PropertyEditor!FPropertyNode::NotifyPostChange() [d:\build\++ue4\sync\engine\source\editor\propertyeditor\private\propertynode.cpp:2122]
                        UE4Editor_PropertyEditor!FPropertyValueImpl::ImportText() [d:\build\++ue4\sync\engine\source\editor\propertyeditor\private\propertyhandleimpl.cpp:545]
                        UE4Editor_PropertyEditor!FPropertyValueImpl::ImportText() [d:\build\++ue4\sync\engine\source\editor\propertyeditor\private\propertyhandleimpl.cpp:333]
                        UE4Editor_PropertyEditor!FPropertyValueImpl::ImportText() [d:\build\++ue4\sync\engine\source\editor\propertyeditor\private\propertyhandleimpl.cpp:242]
                        UE4Editor_PropertyEditor!FPropertyValueImpl::ResetToDefault() [d:\build\++ue4\sync\engine\source\editor\propertyeditor\private\propertyhandleimpl.cpp:995]
                        UE4Editor_PropertyEditor!SResetToDefaultPropertyEditor::OnResetClicked() [d:\build\++ue4\sync\engine\source\editor\propertyeditor\private\userinterface\propertyeditor\sresettodefaultpropertyeditor.cpp:83]
                        UE4Editor_PropertyEditor!TBaseSPMethodDelegateInstance<0,SResetToDefaultPropertyEditor,0,FReply __cdecl(void)>::Execute() [d:\build\++ue4\sync\engine\source\runtime\core\public\delegates\delegateinstancesimpl.h:269]
                        UE4Editor_Slate!SButton::OnMouseButtonUp() [d:\build\++ue4\sync\engine\source\runtime\slate\private\widgets\input\sbutton.cpp:290]
                        UE4Editor_Slate!FEventRouter::Route<FReply,FEventRouter::FToLeafmostPolicy,FPointerEvent,<lambda_1002768c627006711ef2f351a87ec0e7> >() [d:\build\++ue4\sync\engine\source\runtime\slate\private\framework\application\slateapplication.cpp:268]
                        UE4Editor_Slate!FSlateApplication::RoutePointerUpEvent() [d:\build\++ue4\sync\engine\source\runtime\slate\private\framework\application\slateapplication.cpp:5472]
                        UE4Editor_Slate!FSlateApplication::ProcessMouseButtonUpEvent() [d:\build\++ue4\sync\engine\source\runtime\slate\private\framework\application\slateapplication.cpp:5979]
                        UE4Editor_Slate!FSlateApplication::OnMouseUp() [d:\build\++ue4\sync\engine\source\runtime\slate\private\framework\application\slateapplication.cpp:5959]
                        UE4Editor_ApplicationCore!FWindowsApplication::ProcessDeferredMessage() [d:\build\++ue4\sync\engine\source\runtime\applicationcore\private\windows\windowsapplication.cpp:1736]
                        UE4Editor_ApplicationCore!FWindowsApplication:eferMessage() [d:\build\++ue4\sync\engine\source\runtime\applicationcore\private\windows\windowsapplication.cpp:2182]
                        UE4Editor_ApplicationCore!FWindowsApplication::ProcessMessage() [d:\build\++ue4\sync\engine\source\runtime\applicationcore\private\windows\windowsapplication.cpp:895]
                        UE4Editor_ApplicationCore!FWindowsApplication::AppWndProc() [d:\build\++ue4\sync\engine\source\runtime\applicationcore\private\windows\windowsapplication.cpp:732]
                        user32
                        user32
                        UE4Editor_ApplicationCore!FWindowsPlatformApplicationMisc::PumpMessages() [d:\build\++ue4\sync\engine\source\runtime\applicationcore\private\windows\windowsplatformapplicationmisc.cpp:129]
                        UE4Editor!FEngineLoop::Tick() [d:\build\++ue4\sync\engine\source\runtime\launch\private\launchengineloop.cpp:3417]
                        UE4Editor!GuardedMain() [d:\build\++ue4\sync\engine\source\runtime\launch\private\launch.cpp:166]
                        UE4Editor!GuardedMainWrapper() [d:\build\++ue4\sync\engine\source\runtime\launch\private\windows\launchwindows.cpp:144]
                        UE4Editor!WinMain() [d:\build\++ue4\sync\engine\source\runtime\launch\private\windows\launchwindows.cpp:223]
                        UE4Editor!__scrt_common_main_seh() [f:\dd\vctools\crt\vcstartup\src\startup\exe_common.inl:283]
                        kernel32
                        ntdll

                        Comment


                          Hi,
                          I've downloaded the plugin from the marketplace but it keeps giving me this error on my Mac (High Serria) my Unreal Engine version is 4.20.2


                          this error doesn't occur in my Windows machine only my mac

                          Comment


                            Not sure if this was posted before since I am just starting with this plugin, but in the Theme Editor in properties when you click "Skylight" the editor crashes


                            Also, I noticed several people have reported that the IsNearMarker node no longer works. Could that be fixed sometime soon, it is quite important?

                            Edit
                            -----
                            I made a temporary fix since I really want to use this node. I don't know if there was a good reason to disable that node in code and if my fix will break something else later on, but I post it here for those of you who are in need of this. Feel free to add a better solution.

                            - Since I don't know how to compile a plugin that is installed in the engine, I copied the whole DungeonArchitect subfolder from the engine/Marketplace location to my project's plugins
                            - Go to \DungeonArchitectRuntime\Private\Builders\Grid\GridDungeonQuery.cpp near the end and uncomment the code for IsNearNode()
                            - Go to DungeonBuilder.h near the end and make the protected declaration of the marker array public
                            - Rebuild the whole project

                            This got the node working. Like I said it is not a proper solution but it makes the node work again. I hope this will be fixed in an official update sometime soon so that I wont need to use this patch in the future


                            Last edited by Wallenstein; 09-09-2018, 07:48 AM.

                            Comment


                              Hello,

                              I have run into issues using your plugin with dedicated server. I continuously get Outer errors from references inside the theme file. When I remove the mesh node in question the error goes away. This happens for every mesh node in a theme file.

                              Things I've tried:
                              1. Moving plugin location from engine to project and visa versa.
                              2. Deleting plugin binaries and force rebuild
                              3. Creating a brand new project with DA/Dungeon/Theme
                              4. Tried switching from 4.20 to 4.19

                              Code:
                              [2018.09.11-21.10.08:698][ 0]LoadErrors: Warning: CreateExport: Failed to load Outer for resource 'Template': EdGraphNode_DungeonMesh /Game/Theme.Theme:EdGraph_DungeonProp_0.EdGraphNode_DungeonMesh_4

                              Could you please reach out to me about this issue. I have spent a great deal of time working with your plugin to find that I can't package a dedicated server. I have reached out via several methods with no response as of yet, ty.
                              Attached Files

                              Comment


                                Originally posted by draxous View Post
                                Hello, I was curious if you could tell me how to make a TransformLogic that allows me to make sure 1 side of a mesh is always facing "inwards". I have a wall mesh that is one sided and need to make sure the the material view-able side is always facing inwards towards the floor.

                                I have also tried making transform logic to move "walls" that are rotated < 90 degree's on the Z axis, this allows me to move a wall sideways only if its rotated a certain way, but the following blueprint seems to effect all ways regardless of rotation.

                                Anything you could do to help would be most appreciated.
                                draxous Sometimes walls are shared between two rooms and only a single wall marker is emitted. So it assumes that the wall is two sided. In this case, I usually emit two wall meshes from the theme file on both directions. Would this work for you?
                                Dungeon Architect | Prefabricator

                                Discord Support

                                Comment

                                Working...
                                X