Announcement

Collapse
No announcement yet.

[Community Project] WIP Weather & Ocean Water Shader

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    **** stuck at initializing
    4.12:stuck at 45%
    4.13from cascade256)stuck at 39% (if i delete the dlls and rebuild it stuck at 43%)
    what to say……
    waste time
    呵呵呵

    Leave a comment:


  • replied
    It works fine if you compile it for 4.13. I'm not sure if I can post the files so I'll wait for someone to confirm if I can or not.

    Leave a comment:


  • replied
    Does the version difference between UE 4.12 and 4.13 break the plugin or will it still work on 4.13 even though it's meant for 4.12? Or does it work only in parts?

    Leave a comment:


  • replied
    Having issues with this, loading the project as provided, it functions fine.

    Getting it into my project, is where I am having issues. Even tried copying ALL files into my project, then loading the included maps, and even in the editor errors are thrown up that /scripts/oceanproject cannot be found. this isnt in the downloaded package, yet that works. Am I missing something?

    Leave a comment:


  • replied
    [MENTION=515743]Unmei no kizuna[/MENTION]

    im pretty sure it is still alive - updates dont come every day, we usually see them 1 time per month, maybe ... everything generally works tho.

    Leave a comment:


  • replied
    [MENTION=18451]RedSaturnSix[/MENTION]

    make sure you have the plugin in the plugins folder
    make sure you have it enabled
    make sure you have the global reflections turned on (options > project > render > global reflections)

    If its working in its own project then you had either a bad import, or, something in your settings is wrong, or, you didnt fully import all the required items.

    Leave a comment:


  • replied
    Will this project was abandoned ?

    Leave a comment:


  • replied
    Yeha it opens fine inside it's own project. I'm running .13 and downloaded the latest version from this thread. I've had this issue with every version of the project i've downloaded.

    Leave a comment:


  • replied
    Originally posted by RedSaturnSix View Post
    Thanks for the reply.

    Yeah this is exactly what I've done a number of times.

    I can get water to appear in my levels but it doesn't appear in my editor view.



    I get all these weird errors.



    And all the original folders are there still with no files in the content browser but 2k redirect files on the disk.
    can you open the project without migration? as in the original ocean project files?
    do you get errors?
    looks like for some reason you are getting big BP errors in there - make sure you are using the correct version with the version of UE4 you are using.

    Leave a comment:


  • replied
    I'm struggling with replication of wave.
    My project is gun-shooting game using dedicated server and have a plan about the battle on the ocean.
    So, many things have to be replicated to clients including the wave.

    I tested OceanPlugin at the dedicated server and clients and found that the wave is not synchronized.
    I changed OceanPlugin's code to use replicated world time for creating the wave.
    But, it didn't work.

    Is there anyone who know how to deal with it?

    Leave a comment:


  • replied
    Originally posted by g19max1 View Post
    Hey RedSaturnSix. I was able to implement this in my project by following these steps in this exact order:

    1. Add plugin to project. I just copied the plugin files into my project's plugin folder. It should be a sibling to the Content folder in your projects root directory.
    2. Restart the editor.
    3. Migrate the OceanProject assets DIRECTLY to your Content folder root. YOU MUST migrate the assets straight into the Content folder. If you attempt to migrate into a sub folder of content, it will likely cause issues.
    4. Once the migration is complete, you should now be able to drag the newly migrated assets to whatever subfolder you wish them to permanently reside.
    5. Once the assets are moved to your desired subfolder, right click on the Content folder in the editor content browser. Select "Fix Redirectors".
    6. Now you should be able to freely use the assets in any scene or map.

    Let me know if I can help further! Good luck!
    Thanks for the reply.

    Yeah this is exactly what I've done a number of times.

    I can get water to appear in my levels but it doesn't appear in my editor view.



    I get all these weird errors.



    And all the original folders are there still with no files in the content browser but 2k redirect files on the disk.

    Leave a comment:


  • replied
    hi, great job on this! but how i can use the blueprint water onan other project... i've tried to migrate the bluepint for the water but i can't find it in the other project where i migrated it. can someone help me? thanks!

    Leave a comment:


  • replied
    Originally posted by SirPixell View Post
    Can anyone explain to me why this weird reflection is happening? I can't figure out why it happens or how to change it.
    [ATTACH=CONFIG]107484[/ATTACH]
    Were you ever able to figure out why the large objects in front of the water were generating reflections? I'm having the same issue and haven't had any luck troubleshooting it.

    Leave a comment:


  • replied
    for this plugin,
    Can i change wave/surface in runtime?
    I tried change wave length variable when playing in editor, but it was not work.
    And also, base on existing code to modify, is it possible to create multiple area for the ocean? For example, the wave's length is 10000 in area 1, but the wave's length is 5000 in area 2.
    It is because I want to create an open world ocean game. thx!
    Last edited by WFredC; 09-23-2016, 09:12 AM.

    Leave a comment:


  • replied
    when it will be available the new version 4.13 ?

    Leave a comment:

Working...
X