Announcement

Collapse
No announcement yet.

[Community Project] WIP Weather & Ocean Water Shader

Collapse
This topic is closed.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Not any help?
    WIP Thread _ Modular Packs
    ___________________________________
    http://www.permafrostdevelopment.com/

    http://www.indiedb.com/games/the-absence
    https://twitter.com/PermafrostDevs

    Comment


      Originally posted by ImperiumPandemonium View Post
      Not any help?
      This is how it looks in the blueprint viewport, if you add it to a level, apply the correct settings, add the skydome BP etc. then it will look correct.
      You should check out the example maps and see how everything is done.. currently you cannot add the ocean by simple drag-n-drop to any level, we plan to improve that of course but it is what it is now.

      4.10 Update! -> [Community Project] WIP Weather & Ocean Water Shader
      WIP Interactive Water Shader, WIP 2D Water Sim
      WIP FFT Ocean w/ Foam, Quad-tree Infinite Ocean LOD

      Comment


        Originally posted by TK-Master View Post
        This is how it looks in the blueprint viewport, if you add it to a level, apply the correct settings, add the skydome BP etc. then it will look correct.
        You should check out the example maps and see how everything is done.. currently you cannot add the ocean by simple drag-n-drop to any level, we plan to improve that of course but it is what it is now.
        Tk-Master, Before I updated to the version with the fish AI system, the ocean BP worked perfectly without the Skydome BP and my own settings. It was after I updated the plugin this happened. I still have a version of my project where the ocean plugin haven't been updated with the fish-blurprints and AI system, and whenever I start that project I see no fault in the ocean_bp's appearance, both in level and in the editor.

        Thanks in advance!
        WIP Thread _ Modular Packs
        ___________________________________
        http://www.permafrostdevelopment.com/

        http://www.indiedb.com/games/the-absence
        https://twitter.com/PermafrostDevs

        Comment


          Things change between versions obviously

          I'm not sure which settings exactly might have caused this, might investigate at some point.. for now just try to copy over everything from the example map.

          Edit: actually it's the SSS light vector parameter which is fed by the BP_Skydome.

          If you want to use your own sky then you will have to manually set the light vector yourself.

          Check out the UpdateSun function inside BP_Skydome (to the right) to see how it is done.. you can also set it to a static direction if you have static sun.
          Last edited by TK-Master; 04-16-2015, 06:17 PM.

          4.10 Update! -> [Community Project] WIP Weather & Ocean Water Shader
          WIP Interactive Water Shader, WIP 2D Water Sim
          WIP FFT Ocean w/ Foam, Quad-tree Infinite Ocean LOD

          Comment


            Hello everyone,

            Sorry for the lack of updates on this, TK has been doing a great job helping out over the past couple weeks though, thanks TK!

            I had a complication from my recent surgery that has prevented me from working on all of this recently. It has been a really tough couple of weeks, but I'm feeling a bit better now.

            I will try and answer all of your posts/pm's/skype messages, and finally get back to working on the project this weekend.

            Thanks guys!
            Free Community Ocean & Sky Project || Join us on Discord! || Trello Roadmap

            Comment


              Hi and lots of wishes for a fast recovery!
              Is this plugin going to have a Mac version as well?
              Asteroids from Photogrammetry plus a mini game available in the UE4 Marketplace

              Comment


                Hey Everybody,

                I implemented the procedural terrain (Created by Azarus) into a level on github called "ProceduralOcean.umap," feel free to check it out. It will crash every so often at the moment because of my new fish implementation, rest assured I am working on it .

                Comment


                  I've downloaded the project from github and am impressed with the work you have done. Besides being a cool project, tt has been invaluable as an example of a simple project that is a mix of Blueprint and C++.

                  I have a question about compiling the plugin, in case I want to try some changes. There is no .sln file in the github repo, so how are you compiling the plugin? I was able to add a sln file via "File -> Add Code To Project" myself and compile, but I am wondering if that is the 'correct' way to compile a plugin. Thanks!
                  Last edited by Pakfront; 04-19-2015, 01:16 PM.

                  Comment


                    Hey great work on the ocean plugin so far.
                    But I have a little question:

                    Is it possible to have multiple planes with different wave directions? Because we have an island and it looks kind of strange to have waves coming from the land instead of having them flowing towards it.
                    Creating a blueprint duplicate and changing the direction does not work, as it still changes the direction for all planes (even if the values are different).

                    We could also work with some kind of flowmap for wave direction, if that is a possibility.

                    Thanks in advance.

                    Comment


                      Hello!
                      First of all i want to say that the work all of you have done here looks amazing.
                      However, I'm working on a small project, and when i play in the editor everything works great but when i try to compile/launch i get the following error:

                      Code:
                      LogPlayLevel: Project.Build: ********** BUILD COMMAND STARTED **********
                      LogPlayLevel: InternalUtils.SafeFileExists: SafeFileExists C:\Program Files (x86)\Xoreax\IncrediBuild\xgConsole.exe=False
                      LogPlayLevel: UE4Build.Build: XGE was requested, but is unavailable, so we won't use it.
                      LogPlayLevel: UE4Build.Build: ************************* UE4Build:
                      LogPlayLevel: UE4Build.Build: ************************* ForceMonolithic:
                      LogPlayLevel: UE4Build.Build: ************************* ForceNonUnity:
                      LogPlayLevel: UE4Build.Build: ************************* ForceDebugInfo:
                      LogPlayLevel: UE4Build.Build: ************************* UseXGE:
                      LogPlayLevel: InternalUtils.SafeFileExists: SafeFileExists E:\EpicGames\Epic Games\4.7\Engine\Binaries\DotNET\UnrealBuildTool.exe=True
                      LogPlayLevel: InternalUtils.SafeDeleteFile: SafeDeleteFile C:\Users\Alpha Seven\Documents\Unreal Projects\OceanProject-DefaultProject\OceanProject-master\Intermediate\Build\Manifest.xml
                      LogPlayLevel: InternalUtils.SafeFileExists: SafeFileExists E:\EpicGames\Epic Games\4.7\Engine\Binaries\DotNET\UnrealBuildTool.exe=True
                      LogPlayLevel: InternalUtils.SafeFileExists: SafeFileExists E:\EpicGames\Epic Games\4.7\Engine\Binaries\DotNET\UnrealBuildTool.exe=True
                      LogPlayLevel: Completed Launch On Stage: Build Task, Time: 1.750059
                      LogStats:Warning: MetaData mismatch. Did you assign a stat to two groups? New //STATGROUP_Threads//FLauncherTask///Thread_dbc_0///////STATCAT_Advanced//// old //STATGROUP_Threads//FLauncherTask///Thread_ef0_0///////STATCAT_Advanced////
                      LogPlayLevel: CommandUtils.Run: Run: E:\EpicGames\Epic Games\4.7\Engine\Binaries\DotNET\UnrealBuildTool.exe OceanDemo Win64 Development -generatemanifest "C:\Users\Alpha Seven\Documents\Unreal Projects\OceanProject-DefaultProject\OceanProject-master\OceanDemo.uproject"  -noxge -rocket -NoHotReloadFromIDE
                      LogPlayLevel: CommandUtils.Run: Run: Took 1,0910624s to run UnrealBuildTool.exe, ExitCode=0
                      LogPlayLevel: InternalUtils.SafeFileExists: SafeFileExists C:\Users\Alpha Seven\Documents\Unreal Projects\OceanProject-DefaultProject\OceanProject-master\Intermediate\Build\Manifest.xml=True
                      LogPlayLevel: InternalUtils.SafeCopyFile: SafeCopyFile C:\Users\Alpha Seven\Documents\Unreal Projects\OceanProject-DefaultProject\OceanProject-master\Intermediate\Build\Manifest.xml E:\EpicGames\Epic Games\4.7\Engine\Programs\AutomationTool\Saved\Logs\UBTManifest.0.xml
                      LogPlayLevel: UE4Build.PrepareManifest: Copied UBT manifest to E:\EpicGames\Epic Games\4.7\Engine\Programs\AutomationTool\Saved\Logs\UBTManifest.0.xml
                      LogPlayLevel: InternalUtils.SafeFileExists: SafeFileExists E:\EpicGames\Epic Games\4.7\Engine\Binaries\DotNET\UnrealBuildTool.exe=True
                      LogPlayLevel: InternalUtils.SafeFileExists: SafeFileExists E:\EpicGames\Epic Games\4.7\Engine\Binaries\DotNET\UnrealBuildTool.exe=True
                      LogPlayLevel: CommandUtils.Run: Run: E:\EpicGames\Epic Games\4.7\Engine\Binaries\DotNET\UnrealBuildTool.exe OceanDemo Win64 Development  "C:\Users\Alpha Seven\Documents\Unreal Projects\OceanProject-DefaultProject\OceanProject-master\OceanDemo.uproject"  -noxge -rocket -NoHotReloadFromIDE
                      LogPlayLevel: UnrealBuildTool: Performing 1 actions (4 in parallel)
                      LogPlayLevel: UnrealBuildTool: [1/1] Link OceanDemo.exe
                      LogPlayLevel: UnrealBuildTool:    Creating library C:\Users\Alpha Seven\Documents\Unreal Projects\OceanProject-DefaultProject\OceanProject-master\Binaries\Win64\OceanDemo.lib and object C:\Users\Alpha Seven\Documents\Unreal Projects\OceanProject-DefaultProject\OceanProject-master\Binaries\Win64\OceanDemo.exp
                      LogPlayLevel: UnrealBuildTool: UELinkerFixups.cpp.obj : error LNK2019: unresolved external symbol "void __cdecl EmptyLinkFunctionForStaticInitializationOceanPlugin(void)" (?EmptyLinkFunctionForStaticInitializationOceanPlugin@@YAXXZ) referenced in function "void __cdecl UELinkerFixups(void)" (?UELinkerFixups@@YAXXZ)
                      LogPlayLevel: UnrealBuildTool: C:\Users\Alpha Seven\Documents\Unreal Projects\OceanProject-DefaultProject\OceanProject-master\Binaries\Win64\OceanDemo.exe : fatal error LNK1120: 1 unresolved externals
                      LogPlayLevel: UnrealBuildTool: -------- End Detailed Actions Stats -----------------------------------------------------------
                      LogPlayLevel: UnrealBuildTool: ERROR: UBT ERROR: Failed to produce item: C:\Users\Alpha Seven\Documents\Unreal Projects\OceanProject-DefaultProject\OceanProject-master\Binaries\Win64\OceanDemo.exe
                      LogPlayLevel: UnrealBuildTool: Cumulative action seconds (8 processors): 0,00 building projects, 0,00 compiling, 0,00 creating app bundles, 0,00 generating debug info, 3,77 linking, 0,00 other
                      LogPlayLevel: UnrealBuildTool: UBT execution time: 7,20 seconds
                      LogPlayLevel: CommandUtils.Run: Run: Took 7,3214188s to run UnrealBuildTool.exe, ExitCode=2
                      LogPlayLevel: ErrorReporter.Error: ERROR: AutomationTool error: Command failed (Result:2): E:\EpicGames\Epic Games\4.7\Engine\Binaries\DotNET\UnrealBuildTool.exe OceanDemo Win64 Development  "C:\Users\Alpha Seven\Documents\Unreal Projects\OceanProject-DefaultProject\OceanProject-master\OceanDemo.uproject"  -noxge -rocket -NoHotReloadFromIDE. See logfile for details: 'UnrealBuildTool.txt'
                      LogPlayLevel: BuildCommand.Execute: ERROR: BUILD FAILED
                      LogPlayLevel: Program.Main: ERROR: AutomationTool terminated with exception:
                      LogPlayLevel: Program.Main: ERROR: Exception in AutomationTool: Command failed (Result:2): E:\EpicGames\Epic Games\4.7\Engine\Binaries\DotNET\UnrealBuildTool.exe OceanDemo Win64 Development  "C:\Users\Alpha Seven\Documents\Unreal Projects\OceanProject-DefaultProject\OceanProject-master\OceanDemo.uproject"  -noxge -rocket -NoHotReloadFromIDE. See logfile for details: 'UnrealBuildTool.txt'
                      LogPlayLevel: Stacktrace:    at AutomationTool.CommandUtils.RunAndLog(String App, String CommandLine, String Logfile, Int32 MaxSuccessCode, String Input, ERunOptions Options, Dictionary`2 EnvVars)
                      LogPlayLevel:    at AutomationTool.CommandUtils.RunUBT(CommandEnvironment Env, String UBTExecutable, String CommandLine, String LogName, Dictionary`2 EnvVars)
                      LogPlayLevel:    at AutomationTool.UE4Build.BuildWithUBT(String ProjectName, String TargetName, UnrealTargetPlatform TargetPlatform, String Config, String UprojectPath, Boolean ForceMonolithic, Boolean ForceNonUnity, Boolean ForceDebugInfo, Boolean ForceFlushMac, Boolean DisableXGE, String InAddArgs, Boolean ForceUnity, Dictionary`2 EnvVars)
                      LogPlayLevel:    at AutomationTool.UE4Build.Build(BuildAgenda Agenda, Nullable`1 InDeleteBuildProducts, Boolean InUpdateVersionFiles, Boolean InForceNoXGE, Boolean InForceNonUnity, Boolean InForceUnity, Dictionary`2 PlatformEnvVars)
                      LogPlayLevel:    at Project.Build(BuildCommand Command, ProjectParams Params, Int32 WorkingCL)
                      LogPlayLevel:    at BuildCookRun.DoBuildCookRun(ProjectParams Params)
                      LogPlayLevel:    at BuildCommand.Execute()
                      LogPlayLevel:    at AutomationTool.Automation.Execute(List`1 CommandsToExecute, CaselessDictionary`1 Commands)
                      LogPlayLevel:    at AutomationTool.Automation.Process(String[] CommandLine)
                      LogPlayLevel:    at AutomationTool.Program.MainProc(Object Param)
                      LogPlayLevel:    at AutomationTool.InternalUtils.RunSingleInstance(MainProc Main, Object Param)
                      LogPlayLevel:    at AutomationTool.Program.Main()
                      LogPlayLevel: Program.Main: ERROR: Command failed (Result:2): E:\EpicGames\Epic Games\4.7\Engine\Binaries\DotNET\UnrealBuildTool.exe OceanDemo Win64 Development  "C:\Users\Alpha Seven\Documents\Unreal Projects\OceanProject-DefaultProject\OceanProject-master\OceanDemo.uproject"  -noxge -rocket -NoHotReloadFromIDE. See logfile for details: 'UnrealBuildTool.txt'
                      LogPlayLevel: ProcessManager.KillAll: Trying to kill 0 spawned processes.
                      LogPlayLevel: Program.Main: AutomationTool exiting with ExitCode=2
                      LogPlayLevel: Domain_ProcessExit
                      LogPlayLevel: ProcessManager.KillAll: Trying to kill 0 spawned processes.
                      Any help or pointers would be greatly appreciated.
                      Thanks

                      Comment


                        Originally posted by Jonatan Bergström View Post
                        Hello!
                        First of all i want to say that the work all of you have done here looks amazing.
                        However, I'm working on a small project, and when i play in the editor everything works great but when i try to compile/launch i get the following error:

                        Code:
                        LogPlayLevel: Project.Build: ********** BUILD COMMAND STARTED **********
                        LogPlayLevel: InternalUtils.SafeFileExists: SafeFileExists C:\Program Files (x86)\Xoreax\IncrediBuild\xgConsole.exe=False
                        LogPlayLevel: UE4Build.Build: XGE was requested, but is unavailable, so we won't use it.
                        LogPlayLevel: UE4Build.Build: ************************* UE4Build:
                        LogPlayLevel: UE4Build.Build: ************************* ForceMonolithic:
                        LogPlayLevel: UE4Build.Build: ************************* ForceNonUnity:
                        LogPlayLevel: UE4Build.Build: ************************* ForceDebugInfo:
                        LogPlayLevel: UE4Build.Build: ************************* UseXGE:
                        LogPlayLevel: InternalUtils.SafeFileExists: SafeFileExists E:\EpicGames\Epic Games\4.7\Engine\Binaries\DotNET\UnrealBuildTool.exe=True
                        LogPlayLevel: InternalUtils.SafeDeleteFile: SafeDeleteFile C:\Users\Alpha Seven\Documents\Unreal Projects\OceanProject-DefaultProject\OceanProject-master\Intermediate\Build\Manifest.xml
                        LogPlayLevel: InternalUtils.SafeFileExists: SafeFileExists E:\EpicGames\Epic Games\4.7\Engine\Binaries\DotNET\UnrealBuildTool.exe=True
                        LogPlayLevel: InternalUtils.SafeFileExists: SafeFileExists E:\EpicGames\Epic Games\4.7\Engine\Binaries\DotNET\UnrealBuildTool.exe=True
                        LogPlayLevel: Completed Launch On Stage: Build Task, Time: 1.750059
                        LogStats:Warning: MetaData mismatch. Did you assign a stat to two groups? New //STATGROUP_Threads//FLauncherTask///Thread_dbc_0///////STATCAT_Advanced//// old //STATGROUP_Threads//FLauncherTask///Thread_ef0_0///////STATCAT_Advanced////
                        LogPlayLevel: CommandUtils.Run: Run: E:\EpicGames\Epic Games\4.7\Engine\Binaries\DotNET\UnrealBuildTool.exe OceanDemo Win64 Development -generatemanifest "C:\Users\Alpha Seven\Documents\Unreal Projects\OceanProject-DefaultProject\OceanProject-master\OceanDemo.uproject"  -noxge -rocket -NoHotReloadFromIDE
                        LogPlayLevel: CommandUtils.Run: Run: Took 1,0910624s to run UnrealBuildTool.exe, ExitCode=0
                        LogPlayLevel: InternalUtils.SafeFileExists: SafeFileExists C:\Users\Alpha Seven\Documents\Unreal Projects\OceanProject-DefaultProject\OceanProject-master\Intermediate\Build\Manifest.xml=True
                        LogPlayLevel: InternalUtils.SafeCopyFile: SafeCopyFile C:\Users\Alpha Seven\Documents\Unreal Projects\OceanProject-DefaultProject\OceanProject-master\Intermediate\Build\Manifest.xml E:\EpicGames\Epic Games\4.7\Engine\Programs\AutomationTool\Saved\Logs\UBTManifest.0.xml
                        LogPlayLevel: UE4Build.PrepareManifest: Copied UBT manifest to E:\EpicGames\Epic Games\4.7\Engine\Programs\AutomationTool\Saved\Logs\UBTManifest.0.xml
                        LogPlayLevel: InternalUtils.SafeFileExists: SafeFileExists E:\EpicGames\Epic Games\4.7\Engine\Binaries\DotNET\UnrealBuildTool.exe=True
                        LogPlayLevel: InternalUtils.SafeFileExists: SafeFileExists E:\EpicGames\Epic Games\4.7\Engine\Binaries\DotNET\UnrealBuildTool.exe=True
                        LogPlayLevel: CommandUtils.Run: Run: E:\EpicGames\Epic Games\4.7\Engine\Binaries\DotNET\UnrealBuildTool.exe OceanDemo Win64 Development  "C:\Users\Alpha Seven\Documents\Unreal Projects\OceanProject-DefaultProject\OceanProject-master\OceanDemo.uproject"  -noxge -rocket -NoHotReloadFromIDE
                        LogPlayLevel: UnrealBuildTool: Performing 1 actions (4 in parallel)
                        LogPlayLevel: UnrealBuildTool: [1/1] Link OceanDemo.exe
                        LogPlayLevel: UnrealBuildTool:    Creating library C:\Users\Alpha Seven\Documents\Unreal Projects\OceanProject-DefaultProject\OceanProject-master\Binaries\Win64\OceanDemo.lib and object C:\Users\Alpha Seven\Documents\Unreal Projects\OceanProject-DefaultProject\OceanProject-master\Binaries\Win64\OceanDemo.exp
                        LogPlayLevel: UnrealBuildTool: UELinkerFixups.cpp.obj : error LNK2019: unresolved external symbol "void __cdecl EmptyLinkFunctionForStaticInitializationOceanPlugin(void)" (?EmptyLinkFunctionForStaticInitializationOceanPlugin@@YAXXZ) referenced in function "void __cdecl UELinkerFixups(void)" (?UELinkerFixups@@YAXXZ)
                        LogPlayLevel: UnrealBuildTool: C:\Users\Alpha Seven\Documents\Unreal Projects\OceanProject-DefaultProject\OceanProject-master\Binaries\Win64\OceanDemo.exe : fatal error LNK1120: 1 unresolved externals
                        LogPlayLevel: UnrealBuildTool: -------- End Detailed Actions Stats -----------------------------------------------------------
                        LogPlayLevel: UnrealBuildTool: ERROR: UBT ERROR: Failed to produce item: C:\Users\Alpha Seven\Documents\Unreal Projects\OceanProject-DefaultProject\OceanProject-master\Binaries\Win64\OceanDemo.exe
                        LogPlayLevel: UnrealBuildTool: Cumulative action seconds (8 processors): 0,00 building projects, 0,00 compiling, 0,00 creating app bundles, 0,00 generating debug info, 3,77 linking, 0,00 other
                        LogPlayLevel: UnrealBuildTool: UBT execution time: 7,20 seconds
                        LogPlayLevel: CommandUtils.Run: Run: Took 7,3214188s to run UnrealBuildTool.exe, ExitCode=2
                        LogPlayLevel: ErrorReporter.Error: ERROR: AutomationTool error: Command failed (Result:2): E:\EpicGames\Epic Games\4.7\Engine\Binaries\DotNET\UnrealBuildTool.exe OceanDemo Win64 Development  "C:\Users\Alpha Seven\Documents\Unreal Projects\OceanProject-DefaultProject\OceanProject-master\OceanDemo.uproject"  -noxge -rocket -NoHotReloadFromIDE. See logfile for details: 'UnrealBuildTool.txt'
                        LogPlayLevel: BuildCommand.Execute: ERROR: BUILD FAILED
                        LogPlayLevel: Program.Main: ERROR: AutomationTool terminated with exception:
                        LogPlayLevel: Program.Main: ERROR: Exception in AutomationTool: Command failed (Result:2): E:\EpicGames\Epic Games\4.7\Engine\Binaries\DotNET\UnrealBuildTool.exe OceanDemo Win64 Development  "C:\Users\Alpha Seven\Documents\Unreal Projects\OceanProject-DefaultProject\OceanProject-master\OceanDemo.uproject"  -noxge -rocket -NoHotReloadFromIDE. See logfile for details: 'UnrealBuildTool.txt'
                        LogPlayLevel: Stacktrace:    at AutomationTool.CommandUtils.RunAndLog(String App, String CommandLine, String Logfile, Int32 MaxSuccessCode, String Input, ERunOptions Options, Dictionary`2 EnvVars)
                        LogPlayLevel:    at AutomationTool.CommandUtils.RunUBT(CommandEnvironment Env, String UBTExecutable, String CommandLine, String LogName, Dictionary`2 EnvVars)
                        LogPlayLevel:    at AutomationTool.UE4Build.BuildWithUBT(String ProjectName, String TargetName, UnrealTargetPlatform TargetPlatform, String Config, String UprojectPath, Boolean ForceMonolithic, Boolean ForceNonUnity, Boolean ForceDebugInfo, Boolean ForceFlushMac, Boolean DisableXGE, String InAddArgs, Boolean ForceUnity, Dictionary`2 EnvVars)
                        LogPlayLevel:    at AutomationTool.UE4Build.Build(BuildAgenda Agenda, Nullable`1 InDeleteBuildProducts, Boolean InUpdateVersionFiles, Boolean InForceNoXGE, Boolean InForceNonUnity, Boolean InForceUnity, Dictionary`2 PlatformEnvVars)
                        LogPlayLevel:    at Project.Build(BuildCommand Command, ProjectParams Params, Int32 WorkingCL)
                        LogPlayLevel:    at BuildCookRun.DoBuildCookRun(ProjectParams Params)
                        LogPlayLevel:    at BuildCommand.Execute()
                        LogPlayLevel:    at AutomationTool.Automation.Execute(List`1 CommandsToExecute, CaselessDictionary`1 Commands)
                        LogPlayLevel:    at AutomationTool.Automation.Process(String[] CommandLine)
                        LogPlayLevel:    at AutomationTool.Program.MainProc(Object Param)
                        LogPlayLevel:    at AutomationTool.InternalUtils.RunSingleInstance(MainProc Main, Object Param)
                        LogPlayLevel:    at AutomationTool.Program.Main()
                        LogPlayLevel: Program.Main: ERROR: Command failed (Result:2): E:\EpicGames\Epic Games\4.7\Engine\Binaries\DotNET\UnrealBuildTool.exe OceanDemo Win64 Development  "C:\Users\Alpha Seven\Documents\Unreal Projects\OceanProject-DefaultProject\OceanProject-master\OceanDemo.uproject"  -noxge -rocket -NoHotReloadFromIDE. See logfile for details: 'UnrealBuildTool.txt'
                        LogPlayLevel: ProcessManager.KillAll: Trying to kill 0 spawned processes.
                        LogPlayLevel: Program.Main: AutomationTool exiting with ExitCode=2
                        LogPlayLevel: Domain_ProcessExit
                        LogPlayLevel: ProcessManager.KillAll: Trying to kill 0 spawned processes.
                        Any help or pointers would be greatly appreciated.
                        Thanks
                        I only came across that code when trying to compile the game with my own custom code in C++. If you just want to use the plugin and arnt coding you shouldnt even have visual studio open or compiling anything with unrealbuildtool.

                        //not an expert
                        Tek LLC a personal Candaian Company running BlenderTek & UnrealTek is currently looking for help to bring back submarine simulator gaming with a new genre of sub sims: Cold War! (1945-1991) Operation: Trident SubSim Dev Diary Thread - Donations

                        Comment


                          Originally posted by Pakfront View Post
                          ..I have a question about compiling the plugin, in case I want to try some changes. There is no .sln file in the github repo, so how are you compiling the plugin? I was able to add a sln file via "File -> Add Code To Project" myself and compile, but I am wondering if that is the 'correct' way to compile a plugin. Thanks!
                          If you are using the TK or master branch (ha! see what I did there?) then there should already be a Source folder, in which case to get a .sln file all you need to do is right click the .uproject file and click "Generate Visual Studio project files".
                          But there is nothing wrong with "Add Code to Project" you only need to use that method when there is no Source folder though.


                          Originally posted by Drommedar View Post
                          ...Is it possible to have multiple planes with different wave directions? Because we have an island and it looks kind of strange to have waves coming from the land instead of having them flowing towards it.
                          Creating a blueprint duplicate and changing the direction does not work, as it still changes the direction for all planes (even if the values are different).

                          We could also work with some kind of flowmap for wave direction, if that is a possibility.

                          Thanks in advance.
                          To get multiple planes working you would have to modify the ocean material to use regular parameters instead of the collection parameters, then edit the Ocean BP accordingly (that on itself would probably take hours).

                          But let me save you the trouble right now and tell you that you will not achieve the results you are looking for by doing that
                          Not only the buoyancy will not work right but also the planes will not blend together properly if they have different parameters.. not to mention the performance will go down significantly since there will be multiple gerstner wave cluster calculations.

                          If you are making a single player game then I would try changing the wave direction in the ocean manager over time, depending on the player's location.

                          If you are making multiplayer.. you could try modifying each wave set's "rotation" parameter to make the waves more "chaotic" and move into multiple directions to hopefully make it look less obvious, I have no idea how well that would work though so don't blame me if you waste your time

                          In a perfect world we would want a mix of FFT, gerstner waves and some kind of flow map so we can transition/fade the waves near the shore while keeping everything as mathematical as possible so we can calculate buoyancy on the CPU.
                          But that is pretty challenging to say the least, if even possible


                          Originally posted by Jonatan Bergström View Post
                          ..However, I'm working on a small project, and when i play in the editor everything works great but when i try to compile/launch i get the following error:

                          Any help or pointers would be greatly appreciated.
                          Thanks
                          No idea.. it's not easy to tell what is going on from an error log we need more info.
                          What are you trying to do exactly? package the game? compile the code? what steps are you taking exactly?


                          Originally posted by DotCam View Post
                          Hello everyone,

                          Sorry for the lack of updates on this, TK has been doing a great job helping out over the past couple weeks though, thanks TK!

                          I had a complication from my recent surgery that has prevented me from working on all of this recently. It has been a really tough couple of weeks, but I'm feeling a bit better now.

                          I will try and answer all of your posts/pm's/skype messages, and finally get back to working on the project this weekend.

                          Thanks guys!
                          Hey Dot! glad to hear you are feeling better

                          4.10 Update! -> [Community Project] WIP Weather & Ocean Water Shader
                          WIP Interactive Water Shader, WIP 2D Water Sim
                          WIP FFT Ocean w/ Foam, Quad-tree Infinite Ocean LOD

                          Comment


                            Originally posted by Nsomnia
                            I only came across that code when trying to compile the game with my own custom code in C++. If you just want to use the plugin and arnt coding you shouldnt even have visual studio open or compiling anything with unrealbuildtool.
                            I have added some classes to the sailing sim. that I'm making, which is why i had to add some code and go into VS. but the error dose not show up in VS.
                            I only get the error when i try to launch the project. but it dont rly do anything except torn some lights on and off and so on.
                            And if you don't mind me asking, how did you solve it? i saw that you posted the same error a while back.


                            Originally posted by TK-Master View Post
                            No idea.. it's not easy to tell what is going on from an error log we need more info.
                            What are you trying to do exactly? package the game? compile the code? what steps are you taking exactly?
                            I'm in the process of building a sim. for sailboats. and when i launch the project i get this error.
                            So i tried going back to the master branch to se if that could be launched but i get the same error there (as posted above) :s
                            I have tried different ways but the all lead to the same error.
                            The most basic way was to download the project, unzip. launch with unreal and then try to launch it on the PC.

                            When that didn't work i tried to add code to project to rebuild the project in VS then run it and launch it when the editor shows up, but the same error.

                            Btw if I for example create a blank template project and launch it i don't get this error.

                            PS. Thanks for replies
                            Last edited by Jonatan Bergström; 04-21-2015, 03:13 AM.

                            Comment


                              I finally had a chance to check out this project after much time reading through the thread and watching the videos/screenshots and I must say that it is a great project!! There were a couple of issues I noticed that I wanted to feedback...

                              1. Each time a chunk of terrain gets generated, there is a brief pause. I expect it is caused by a CPU spike but didn't have time to debug this....I will take a closer look this evening and get back to you.
                              2. The shark is great however just like my grandfather, his teeth didn't appear to be in his mouth and he at one point started flying above the ocean (Granddad wishes he could fly above the ocean)

                              I'm actually quite keen on getting involved with this and will see if there's anything cool I can add to this project. Great work guys!!
                              [FREE] Procedural Bridge Blueprint, [FREE] Spline Enabled Ivy BP

                              Comment


                                Originally posted by Jonatan Bergström View Post
                                I have added some classes to the sailing sim. that I'm making, which is why i had to add some code and go into VS. but the error dose not show up in VS.
                                I only get the error when i try to launch the project. but it dont rly do anything except torn some lights on and off and so on.
                                And if you don't mind me asking, how did you solve it? i saw that you posted the same error a while back.




                                I'm in the process of building a sim. for sailboats. and when i launch the project i get this error.
                                So i tried going back to the master branch to se if that could be launched but i get the same error there (as posted above) :s
                                I have tried different ways but the all lead to the same error.
                                The most basic way was to download the project, unzip. launch with unreal and then try to launch it on the PC.

                                When that didn't work i tried to add code to project to rebuild the project in VS then run it and launch it when the editor shows up, but the same error.

                                Btw if I for example create a blank template project and launch it i don't get this error.

                                PS. Thanks for replies

                                I really dont remember. I was just trying to make a struct out of TK's buoyancy location and density values. The error only showed up in VS for me cause I had the wrong syntax, then fixed it, built it, Was fine and launched the project with changes no problem. So I dunno thats related to unrealbuildtool and your code. I'd guess its an issue in your code somewhere. Remove parts of your code peice by peice till you find the problem... thats basic debugging it sucks buts its one way to figure it out.
                                Tek LLC a personal Candaian Company running BlenderTek & UnrealTek is currently looking for help to bring back submarine simulator gaming with a new genre of sub sims: Cold War! (1945-1991) Operation: Trident SubSim Dev Diary Thread - Donations

                                Comment

                                Working...
                                X