No announcement yet.

[Community Project] WIP Weather & Ocean Water Shader

This topic is closed.
  • Filter
  • Time
  • Show
Clear All
new posts

    i have tried Both 4.17 solutions, get the same error when i am trying to compile my code can somebody help me out ?

    (some things have been removed for personal reasons )

    1>------ Build started: Project: <projectname>., Configuration: Development_Game x64 ------
    1>Creating makefile for <projectname> (no existing makefile)
    1>Performing full C++ include scan (no include cache file)
    1>EXEC : error : Couldn't find module rules file for module 'OceanProject'.
    1><path>\VsComunity\Common7\IDE\VC\VCTargets\Microsoft.MakeFile.Targets(44,5): error MSB3075: The command "<path>\UE_4.16\Engine\Build\BatchFiles\Build.bat <projectname> Win64 Development "<ProjectFolder>\<projectname>.uproject" -waitmutex" exited with code 5. Please verify that you have sufficient rights to run this command.
    1>Done building project "ProjectFS.vcxproj" -- FAILED.
    ========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========

    Last edited by dimin69; 08-31-2017, 02:59 PM. Reason: removed pc path's


      Has this project been abandoned?


        i try to migrate the whole content folder of the untouched fresh-downloaded community ocean 4.15 into a blank 4.15 project and i cant get the bp_ocean actor to load when i open any of the maps... anybody have success on this?


          Dear maintainers,

          Does the latest version of this plugin support multiple/separate bodies of water? Last time I used it a year and a half ago it didn't.

          Was also curious if it supports underwater air pockets.


            Originally posted by shredder7753 View Post
            i try to migrate the whole content folder of the untouched fresh-downloaded community ocean 4.15 into a blank 4.15 project and i cant get the bp_ocean actor to load when i open any of the maps... anybody have success on this?
            Hey shredder, did you try following this tutorial?

            It might be better than just migrating the Content folder.


              Hey everyone,

              I tried to update an older project (4.13 compatibility) with the 4.17 build Raindance provided (thanks Raindance!) and followed the 'How to add...' tutorial when the update failed, but it still fails. It tries to load but then throws a warning that UE4Editor-OceanProject.dll needs to be Rebuilt, and upon saying yes, the compile fails and says to try rebuilding manually.

              Has anyone got this to work? Currently using UE4 4.17.1

              I feel like I'm missing something. Due to our development environment, I'd reeeeaaaally prefer not to have to put together a custom build of UE4 4.17.1...

              Any help would be fantastic!


                FlashFreak It only has to be rebuilt if you're trying to use the plugin with a version of the engine the plugin is not built for. Are you sure you're using Raindance's 4.17 version and not trying to rebuild your 4.13 version? What steps are you taking to update your project? And if you try to rebuild manually, what errors are you getting?


                  Wow, this is incredible! Thank you for this fantastic creation! I have a question: when you are underwater looking up, the sky becomes very dark almost black, as if you were miles under the ocean. Is there a setting to adjust this to be more clear, as in shallow water? Thanks so much!


                    Originally posted by kusokuso1 View Post

                    Hey shredder, did you try following this tutorial?

                    It might be better than just migrating the Content folder.
                    ohhh wow. this is what i need to try... tomorrow


                      Hi guys,

                      First of all, I'd like to thank the developers, maintainers and the community of this great plugin and all the support it has, it's an amazing development and I totally appreciate what you do.

                      I'm writing to ask if anyone can give me a clue or feedback about a crash I'm coming across in the game I'm working. I found why it happens, but currently I've no clue about how to solve it.

                      The crash happens in particular hardware and configuration: XBox One and DirectX 12 validation layer activated (adding the -dxdebug command argument when executing the game), I'm using Unreal Engine 4.16.3

                      Doing some detailed binary search iterations, I came across the cause of the bug. It's in the "M_Ocean_Ultra" material, particularly in the "Interpolate between base color and scene color based on the distance between this pixel and the pixel behind it" comment group: the Scene Color node will always cause a crash if is used (see "Crash" screenshot). I've tried replacing the node by a fixed constant value, and the game works with no problem (see "Working fine" screenshot).

                      The error I get is the following:

                      D3D12 ERROR: [0x276D3266] ID3D12GraphicsCommandList(Graphics):: DrawIndexedInstanced: The format of render target 0 (R11G11B10_FLOAT) does not match the format specified by the pipeline state (R16G16B16A16_FLOAT). (RTV resource ptr=0x000000031010BA00 resource name="SceneColorDeferred")
                      D3D12 ERROR: [0x5E908FDA] ID3D12GraphicsCommandList(Graphics)::Close: A failure was encountered during command list recording.
                      LogD3D12RHI:Error: CommandList->Close() failed

                      It seems that Unreal Engine's pipeline gives the material a render target as input, with the scene color content (the name of the render target is "SceneColorDeferred"), but then the validation layer complains to a crash level when it finds out that the format of the given render target is R16G16B16A16_FLOAT, since it was expecting a render target with format R11G11B10_FLOAT.

                      I've tried with DirectX11 and it works fine (under the same configuration: XBox One and DirectX validation layer command argument activated), so it's a DX12 / Unreal Engine thing.

                      Also and just in case, the settings I've are as follow:

                      Material Domain: Surface
                      Blend Mode: Translucent
                      Decal Blend Mode: Translucent
                      Shading Model: Default Lit
                      Two sided: true
                      Use Material Attributes: false
                      Subsurface profile: None

                      Screen Space Reflections: true
                      Lighting Mode: Surface ForwardShading
                      Directional Lightinf Intensity: 1.0
                      Apply Fogging: true
                      Compute Fog Per Pixel: false
                      Separate Translucency: true
                      Mobile Separate Translucency: false
                      Resposive AA: true
                      Allow Custom Depth Writes: false
                      Disable Depth Test: false

                      Any help / clue / thought will be appreciated, many thanks!




                        OptionalSteve, sorry for the delay, I've been sidetracked with other projects in the office and I just got back to this.

                        Problem solved.

                        I'm loathe to admit it was sheer laziness on my part. If I'd taken the 1.5 seconds it took to read the log file, I would have realized that the issue was not with the plug-in, but my install of Visual Studio 2015 Community, which was hopelessly out of date. Once I applied the Update 3 patch (required for compiling for Unreal) and waited the 2+ hours while it pulled down the 3GB of patch, it worked first try.

                        Big shout out to Raindance for piecing it together for dopes like me.



                          Hi! As i understand water plane prevent make any shooting underwater. So how to make avaliable shoots underwater????


                            And other problem about submarine controller is how to dive? Cause simply add velocity to Z axis will not work, I should do it by increasing "mesh Density" or other way??


                              Oh looks i find how to do)) Point Density Overide right?? so i have 6 test point on my sub and Mesh Density 600... i put virtual weight on each points, so they should be more then 600 to dive))))


                                Hey guys

                                Cam recently added me as a maintainer of the project, so I did some cleaning and (finally) merged the PR to UE4.17!

                                You can check it here:

                                I'd love if some of you had some time to test and see if everything is okay

                                If you find errors, please, open an issue in GitHub (it's hard to keep up with so many pages in this topic) and I'll try to get to it.

                                If you do have improvements you're willing to submit back to the repository, please, open a pull request and I'll try to get it merged as soon as possible

                                Last edited by Zoc; 10-04-2017, 03:44 AM. Reason: Added repository link